summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen L Arnold <nerdboy@gentoo.org>2015-12-31 14:03:24 -0800
committerStephen L Arnold <nerdboy@gentoo.org>2015-12-31 14:12:03 -0800
commita13463b83699bd6bbed7846f71c538d0b12f1050 (patch)
treee9fc41816ee879970cd336f321f91cf5eee60976
parenteclass, mozconfig: Use --with-intl-api (diff)
downloadgentoo-a13463b8.tar.gz
gentoo-a13463b8.tar.bz2
gentoo-a13463b8.zip
app-pda/libplist: fix for bug 567370 (configure fail on -lpython3.4)
Added to latest two versions for broader testing, fixes above bug plus some duplicates. Fix stolen from Arch (alertly pointed out by veremit). Reported-by: (user) <candrews@integralblue.com> Package-Manager: portage-2.2.26
-rw-r--r--app-pda/libplist/libplist-1.11-r2.ebuild7
-rw-r--r--app-pda/libplist/libplist-1.12.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/app-pda/libplist/libplist-1.11-r2.ebuild b/app-pda/libplist/libplist-1.11-r2.ebuild
index 2f5331b864b2..600f79c1a041 100644
--- a/app-pda/libplist/libplist-1.11-r2.ebuild
+++ b/app-pda/libplist/libplist-1.11-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit eutils python-r1
+inherit autotools eutils python-r1
DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
HOMEPAGE="http://www.libimobiledevice.org/"
@@ -29,6 +29,11 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
BUILD_DIR="${S}_build"
+src_prepare() {
+ sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
+ eautoreconf
+}
+
src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )
diff --git a/app-pda/libplist/libplist-1.12.ebuild b/app-pda/libplist/libplist-1.12.ebuild
index f674ed03a676..bc3d53f8a9d8 100644
--- a/app-pda/libplist/libplist-1.12.ebuild
+++ b/app-pda/libplist/libplist-1.12.ebuild
@@ -4,7 +4,7 @@
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit eutils python-r1
+inherit autotools eutils python-r1
DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
HOMEPAGE="http://www.libimobiledevice.org/"
@@ -29,6 +29,11 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
BUILD_DIR="${S}_build"
+src_prepare() {
+ sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
+ eautoreconf
+}
+
src_configure() {
local ECONF_SOURCE=${S}
local myeconfargs=( $(use_enable static-libs static) )