summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-11-16 18:06:01 -0600
committerAustin English <wizardedit@gentoo.org>2016-11-16 18:06:01 -0600
commita17b08abddfe18d225111b776308718f8f08812b (patch)
treedd90262b1f631d5be4fd1dcf8e350a84b4cdecdd
parentwww-apps/webdavcgi: Version bump to 1.1.1 (diff)
downloadgentoo-a17b08abddfe18d225111b776308718f8f08812b.tar.gz
gentoo-a17b08abddfe18d225111b776308718f8f08812b.tar.bz2
gentoo-a17b08abddfe18d225111b776308718f8f08812b.zip
games-engines/openxcom: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
-rw-r--r--games-engines/openxcom/openxcom-1.0.0-r1.ebuild66
-rw-r--r--games-engines/openxcom/openxcom-9999.ebuild20
2 files changed, 72 insertions, 14 deletions
diff --git a/games-engines/openxcom/openxcom-1.0.0-r1.ebuild b/games-engines/openxcom/openxcom-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..65ea89080411
--- /dev/null
+++ b/games-engines/openxcom/openxcom-1.0.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils cmake-utils gnome2-utils
+
+DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
+HOMEPAGE="http://openxcom.org/"
+SRC_URI="https://github.com/SupSuper/OpenXcom/archive/v1.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
+ media-libs/libsdl[opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[flac,mikmod,vorbis]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( README.txt )
+
+S=${WORKDIR}/OpenXcom-1.0
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ use doc && cmake-utils_src_compile doxygen
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+ doicon -s scalable res/linux/icons/openxcom.svg
+ newicon -s 48 res/linux/icons/openxcom_48x48.png openxcom.png
+ newicon -s 128 res/linux/icons/openxcom_128x128.png openxcom.png
+ domenu res/linux/openxcom.desktop
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ echo
+ elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
+ elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
+ elog "/usr/share/${PN}/data"
+ echo
+ elog "If you need or want text in some language other than english, download:"
+ elog "http://openxcom.org/translations/latest.zip and uncompress it in"
+ elog "/usr/share/${PN}/data/Language"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-engines/openxcom/openxcom-9999.ebuild b/games-engines/openxcom/openxcom-9999.ebuild
index b29d5dfb2574..c8d680ccb828 100644
--- a/games-engines/openxcom/openxcom-9999.ebuild
+++ b/games-engines/openxcom/openxcom-9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils cmake-utils gnome2-utils git-r3 games
+EAPI=6
+inherit eutils cmake-utils gnome2-utils git-r3
DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
HOMEPAGE="http://openxcom.org/"
@@ -32,10 +32,6 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=(
- "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
- "-DCMAKE_INSTALL_DATADIR=${GAMES_DATADIR}"
- )
cmake-utils_src_configure
}
@@ -47,36 +43,32 @@ src_compile() {
src_install() {
DOCS="README.md" \
cmake-utils_src_install
- use doc && dohtml -r "${CMAKE_BUILD_DIR}"/docs/html/*
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
doicon -s scalable res/linux/icons/openxcom.svg
newicon -s 48 res/linux/icons/openxcom_48x48.png openxcom.png
newicon -s 128 res/linux/icons/openxcom_128x128.png openxcom.png
domenu res/linux/openxcom.desktop
-
- prepgamesdirs
}
pkg_preinst() {
- games_pkg_preinst
gnome2_icon_savelist
}
pkg_postinst() {
- games_pkg_postinst
gnome2_icon_cache_update
echo
elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
- elog "${GAMES_DATADIR}/${PN}/UFO"
+ elog "/usr/share/${PN}/UFO"
echo
elog "If you want to play the TFTD mod, you need to copy ANIMS, FLOP_INT,"
elog "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UNITS folders"
elog "from the original Terror from the Deep game to"
- elog "${GAMES_DATADIR}/${PN}/TFTD"
+ elog "/usr/share/${PN}/TFTD"
echo
elog "If you need or want text in some language other than english, download:"
elog "http://openxcom.org/translations/latest.zip and uncompress it in"
- elog "${GAMES_DATADIR}/${PN}/common/Language"
+ elog "/usr/share/${PN}/common/Language"
}
pkg_postrm() {