summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-23 21:27:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-23 22:33:37 +0100
commita199320f07c2823fb044222113d6a2396d89a854 (patch)
tree73720d9b3b44cc87d2f9bd5e14cc28898f4ae9ab
parentmedia-plugins/audacious-plugins: Make USE gtk -> !qt5, alsa default (diff)
downloadgentoo-a199320f07c2823fb044222113d6a2396d89a854.tar.gz
gentoo-a199320f07c2823fb044222113d6a2396d89a854.tar.bz2
gentoo-a199320f07c2823fb044222113d6a2396d89a854.zip
media-sound/audacious: Make USE gtk -> !qt5, drop REQUIRED_USE
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/audacious/audacious-9999.ebuild7
-rw-r--r--media-sound/audacious/metadata.xml1
2 files changed, 4 insertions, 4 deletions
diff --git a/media-sound/audacious/audacious-9999.ebuild b/media-sound/audacious/audacious-9999.ebuild
index 5b4597edcdb..3bbf110f138 100644
--- a/media-sound/audacious/audacious-9999.ebuild
+++ b/media-sound/audacious/audacious-9999.ebuild
@@ -23,8 +23,7 @@ SRC_URI+=" mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
-IUSE="gtk nls +qt5"
-REQUIRED_USE="^^ ( gtk qt5 )"
+IUSE="nls qt5"
RDEPEND="
>=dev-libs/dbus-glib-0.60
@@ -32,7 +31,7 @@ RDEPEND="
>=x11-libs/cairo-1.2.6
>=x11-libs/pango-1.8.0
virtual/freedesktop-icon-theme
- gtk? ( x11-libs/gtk+:2 )
+ !qt5? ( x11-libs/gtk+:2 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -64,8 +63,8 @@ src_configure() {
econf \
--disable-valgrind \
--enable-dbus \
- $(use_enable gtk) \
$(use_enable nls) \
+ $(use_enable !qt5 gtk) \
$(use_enable qt5 qt)
}
diff --git a/media-sound/audacious/metadata.xml b/media-sound/audacious/metadata.xml
index 5eeba2c5c26..503c619ac00 100644
--- a/media-sound/audacious/metadata.xml
+++ b/media-sound/audacious/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<use>
<flag name="gtk3">Link against version 3 of the GIMP Toolkit instead of version 2 (x11-libs/gtk+)</flag>
+ <flag name="qt5">Build with Qt5 interface instead Gtk+</flag>
</use>
</pkgmetadata>