summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-11 17:23:00 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-11 17:23:00 +0200
commita1e8bd32788425ab6c2ebc92a599513ade80a944 (patch)
tree377f09a5344d8b8db06441d0a7c3f0253d0f4773
parentsys-freebsd: Remove empty category (diff)
downloadgentoo-a1e8bd32788425ab6c2ebc92a599513ade80a944.tar.gz
gentoo-a1e8bd32788425ab6c2ebc92a599513ade80a944.tar.bz2
gentoo-a1e8bd32788425ab6c2ebc92a599513ade80a944.zip
profiles: Remove FreeBSD profiles
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--profiles/arch/amd64-fbsd/clang/eapi1
-rw-r--r--profiles/arch/amd64-fbsd/clang/make.defaults7
-rw-r--r--profiles/arch/amd64-fbsd/clang/package.use.force17
-rw-r--r--profiles/arch/amd64-fbsd/clang/package.use.mask21
-rw-r--r--profiles/arch/amd64-fbsd/clang/packages9
-rw-r--r--profiles/arch/amd64-fbsd/clang/packages.build9
-rw-r--r--profiles/arch/amd64-fbsd/clang/parent1
-rw-r--r--profiles/arch/amd64-fbsd/clang/profile.bashrc8
-rw-r--r--profiles/arch/amd64-fbsd/eapi1
-rw-r--r--profiles/arch/amd64-fbsd/make.defaults45
-rw-r--r--profiles/arch/amd64-fbsd/package.use.force22
-rw-r--r--profiles/arch/amd64-fbsd/package.use.mask166
-rw-r--r--profiles/arch/amd64-fbsd/parent3
-rw-r--r--profiles/arch/amd64-fbsd/todo/eapi1
-rw-r--r--profiles/arch/amd64-fbsd/todo/package.use.force7
-rw-r--r--profiles/arch/amd64-fbsd/todo/package.use.mask181
-rw-r--r--profiles/arch/amd64-fbsd/use.force5
-rw-r--r--profiles/arch/amd64-fbsd/use.mask120
-rw-r--r--profiles/arch/x86-fbsd/eapi1
-rw-r--r--profiles/arch/x86-fbsd/make.defaults33
-rw-r--r--profiles/arch/x86-fbsd/package.use.force8
-rw-r--r--profiles/arch/x86-fbsd/package.use.mask72
-rw-r--r--profiles/arch/x86-fbsd/parent1
-rw-r--r--profiles/arch/x86-fbsd/use.force3
-rw-r--r--profiles/arch/x86-fbsd/use.mask74
-rw-r--r--profiles/default/bsd/eapi1
-rw-r--r--profiles/default/bsd/fbsd/amd64/11.1/clang/eapi1
-rw-r--r--profiles/default/bsd/fbsd/amd64/11.1/clang/parent2
-rw-r--r--profiles/default/bsd/fbsd/amd64/11.1/eapi1
-rw-r--r--profiles/default/bsd/fbsd/amd64/11.1/make.defaults6
-rw-r--r--profiles/default/bsd/fbsd/amd64/11.1/parent2
-rw-r--r--profiles/default/bsd/fbsd/amd64/eapi1
-rw-r--r--profiles/default/bsd/fbsd/amd64/parent2
-rw-r--r--profiles/default/bsd/fbsd/eapi1
-rw-r--r--profiles/default/bsd/fbsd/make.defaults25
-rw-r--r--profiles/default/bsd/fbsd/package.mask17
-rw-r--r--profiles/default/bsd/fbsd/package.use12
-rw-r--r--profiles/default/bsd/fbsd/package.use.force4
-rw-r--r--profiles/default/bsd/fbsd/package.use.mask103
-rw-r--r--profiles/default/bsd/fbsd/packages24
-rw-r--r--profiles/default/bsd/fbsd/packages.build50
-rw-r--r--profiles/default/bsd/fbsd/parent1
-rw-r--r--profiles/default/bsd/fbsd/profile.bashrc91
-rw-r--r--profiles/default/bsd/fbsd/use.force3
-rw-r--r--profiles/default/bsd/fbsd/use.mask34
-rw-r--r--profiles/default/bsd/fbsd/x86/11.1/eapi1
-rw-r--r--profiles/default/bsd/fbsd/x86/11.1/make.defaults5
-rw-r--r--profiles/default/bsd/fbsd/x86/11.1/parent2
-rw-r--r--profiles/default/bsd/fbsd/x86/eapi1
-rw-r--r--profiles/default/bsd/fbsd/x86/parent2
-rw-r--r--profiles/default/bsd/make.defaults5
-rw-r--r--profiles/default/bsd/package.mask39
-rw-r--r--profiles/default/bsd/package.use7
-rw-r--r--profiles/default/bsd/package.use.force3
-rw-r--r--profiles/default/bsd/package.use.mask91
-rw-r--r--profiles/default/bsd/packages16
-rw-r--r--profiles/default/bsd/parent1
-rw-r--r--profiles/default/bsd/profile.bashrc14
-rw-r--r--profiles/default/bsd/use.force2
-rw-r--r--profiles/default/bsd/use.mask69
-rw-r--r--profiles/profiles.desc6
-rw-r--r--profiles/releases/freebsd-11.1/package.mask38
-rw-r--r--profiles/releases/freebsd-11.1/package.use.mask9
-rw-r--r--profiles/releases/freebsd-11.1/packages11
-rw-r--r--profiles/releases/freebsd-11.1/packages.build6
-rw-r--r--profiles/releases/freebsd-11.1/parent1
-rw-r--r--profiles/releases/freebsd-11.1/profile.bashrc33
-rw-r--r--profiles/releases/freebsd-11.1/use.mask14
68 files changed, 0 insertions, 1573 deletions
diff --git a/profiles/arch/amd64-fbsd/clang/eapi b/profiles/arch/amd64-fbsd/clang/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/arch/amd64-fbsd/clang/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/arch/amd64-fbsd/clang/make.defaults b/profiles/arch/amd64-fbsd/clang/make.defaults
deleted file mode 100644
index 746ac289456..00000000000
--- a/profiles/arch/amd64-fbsd/clang/make.defaults
+++ /dev/null
@@ -1,7 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-CFLAGS="-O2 -pipe"
-CXXFLAGS="${CFLAGS}"
-FFLAGS="${CFLAGS}"
-FCFLAGS="${CFLAGS}"
diff --git a/profiles/arch/amd64-fbsd/clang/package.use.force b/profiles/arch/amd64-fbsd/clang/package.use.force
deleted file mode 100644
index 36c6e4aadf9..00000000000
--- a/profiles/arch/amd64-fbsd/clang/package.use.force
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Force building libc++ over libcxxrt.
-sys-libs/libcxx libcxxrt
-
-# Force static libs and multilib on the C++ stack.
-sys-libs/libcxxrt static-libs abi_x86_32
-sys-libs/libcxx static-libs abi_x86_32
-
-# Force openssl on curl since cmakes needs it and is in @system because of
-# libcxx on this profile. Mask the other ssl providers.
-net-misc/curl ssl curl_ssl_openssl
-
-# o-flag-munging is required to compile dev-libs/libgcrypt with clang.
-# https://bugs.gentoo.org/629410
-dev-libs/libgcrypt o-flag-munging
diff --git a/profiles/arch/amd64-fbsd/clang/package.use.mask b/profiles/arch/amd64-fbsd/clang/package.use.mask
deleted file mode 100644
index 666f4a7f80d..00000000000
--- a/profiles/arch/amd64-fbsd/clang/package.use.mask
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Disable libcxxabi since it collides with forced libcxxrt
-# Build libcxxrt over libgcc_s since that is what clang defaults to.
-sys-libs/libcxx libcxxabi libunwind
-sys-libs/libcxxrt libunwind
-
-# Needs to be fixed: cxx useflag enables plugins and gold.
-# gold fails to build with clang:
-# https://bugs.gentoo.org/show_bug.cgi?id=427344
-# http://llvm.org/bugs/show_bug.cgi?id=12299
-sys-devel/binutils cxx
-
-# Force openssl on curl since cmakes needs it and is in @system because of
-# libcxx on this profile. Mask the other ssl providers.
-net-misc/curl curl_ssl_gnutls curl_ssl_nss
-
-# Needs to be fixed: build fails with clang++
-# https://bugs.gentoo.org/show_bug.cgi?id=578506
-sys-libs/db cxx
diff --git a/profiles/arch/amd64-fbsd/clang/packages b/profiles/arch/amd64-fbsd/clang/packages
deleted file mode 100644
index f60852f668d..00000000000
--- a/profiles/arch/amd64-fbsd/clang/packages
+++ /dev/null
@@ -1,9 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Don't remove gcc from here: clang uses it for crt{begin,end}*.o and its c++
-# stack.
-
-*sys-devel/llvm
-*sys-devel/clang
-*sys-libs/libcxx
diff --git a/profiles/arch/amd64-fbsd/clang/packages.build b/profiles/arch/amd64-fbsd/clang/packages.build
deleted file mode 100644
index 0cf609150f0..00000000000
--- a/profiles/arch/amd64-fbsd/clang/packages.build
+++ /dev/null
@@ -1,9 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License v2
-
-# This file describes the packages needed to build a stage 1 based on this
-# profile. Packages in this file are built in order.
-
-sys-devel/llvm
-sys-devel/clang
-sys-libs/libcxx
diff --git a/profiles/arch/amd64-fbsd/clang/parent b/profiles/arch/amd64-fbsd/clang/parent
deleted file mode 100644
index f3229c5b987..00000000000
--- a/profiles/arch/amd64-fbsd/clang/parent
+++ /dev/null
@@ -1 +0,0 @@
-..
diff --git a/profiles/arch/amd64-fbsd/clang/profile.bashrc b/profiles/arch/amd64-fbsd/clang/profile.bashrc
deleted file mode 100644
index 496d41b3853..00000000000
--- a/profiles/arch/amd64-fbsd/clang/profile.bashrc
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-
-# Check if clang/clang++ exist before setting them so that we can more easily
-# switch to this profile and build stages.
-# Some packages will require BUILD_{CC,CXX} variables, bug 595878.
-type -P clang > /dev/null && export CC=clang && export BUILD_CC=clang
-type -P clang++ > /dev/null && [ -f /usr/lib/libc++.so ] && export CXX=clang++ && export BUILD_CXX=clang++
diff --git a/profiles/arch/amd64-fbsd/eapi b/profiles/arch/amd64-fbsd/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/arch/amd64-fbsd/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/arch/amd64-fbsd/make.defaults b/profiles/arch/amd64-fbsd/make.defaults
deleted file mode 100644
index be0830e5687..00000000000
--- a/profiles/arch/amd64-fbsd/make.defaults
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-# System-wide defaults for the G/FBSD Portage system
-
-ARCH="amd64-fbsd"
-ACCEPT_KEYWORDS="amd64-fbsd ~amd64-fbsd"
-
-CFLAGS="-O2 -pipe"
-CXXFLAGS="${CFLAGS}"
-FFLAGS="${CFLAGS}"
-FCFLAGS="${CFLAGS}"
-
-MULTILIB_ABIS="amd64_fbsd x86_fbsd"
-DEFAULT_ABI="amd64_fbsd"
-# Do not remove this one, or all kinds of hell breaks loose.
-ABI="amd64_fbsd"
-
-# 32bit specific settings.
-CFLAGS_x86_fbsd="-m32"
-LDFLAGS_x86_fbsd="-m elf_i386_fbsd -L/usr/lib32"
-
-CPU_FLAGS_X86="mmx mmxext sse sse2"
-
-VIDEO_CARDS="dummy intel mga nv r128 radeon siliconmotion via vmware"
-
-# Vanilla FreeBSD has: lib for native 64 bits libs, lib32 for 32-bits emulation.
-# Let's do this too as this also happens to be more standard among other linux
-# distros.
-# Adjust multilib dirs for multilib-strict.
-LIBDIR_amd64_fbsd="lib"
-LIBDIR_x86_fbsd="lib32"
-MULTILIB_STRICT_DIRS="/lib32 /usr/lib32 /usr/kde/*/lib32 /usr/qt/*/lib32 /usr/X11R6/lib32"
-SYMLINK_LIB="no"
-
-# Unhide the x86-specific USE_EXPANDs.
-USE_EXPAND_HIDDEN="-ABI_X86 -CPU_FLAGS_X86"
-
-# Michał Górny <mgorny@gentoo.org> (2014-07-01)
-# Default to abi_x86_64 for packages that don't have it forced.
-ABI_X86="64"
-
-# Michał Górny <mgorny@gentoo.org> (2014-07-01)
-# Make the native ABI implicit so that MULTILIB_USEDEP can be satisfied
-# by non-multilib ebuilds when non-native ABIs are disabled.
-IUSE_IMPLICIT="abi_x86_64"
diff --git a/profiles/arch/amd64-fbsd/package.use.force b/profiles/arch/amd64-fbsd/package.use.force
deleted file mode 100644
index 03f9be01631..00000000000
--- a/profiles/arch/amd64-fbsd/package.use.force
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-09)
-# Using stdlibc++ is broken on FreeBSD, so just force libcxx.
-sys-devel/clang default-libcxx
-
-# Michał Górny <mgorny@gentoo.org> (2017-04-08)
-# Require sandbox to be multilib-capable to avoid failures when building
-# multilib packages, #611292.
-sys-apps/sandbox abi_x86_32
-
-# Michał Górny <mgorny@gentoo.org> (2016-09-24)
-# Force the host target to avoid dependency hell
-dev-ml/llvm-ocaml llvm_targets_X86
-sys-devel/clang llvm_targets_X86
-sys-devel/llvm llvm_targets_X86
-
-# Multilib flag for the system is forced
-sys-freebsd/freebsd-lib abi_x86_32
-sys-freebsd/freebsd-ubin abi_x86_32
-sys-freebsd/freebsd-libexec abi_x86_32
diff --git a/profiles/arch/amd64-fbsd/package.use.mask b/profiles/arch/amd64-fbsd/package.use.mask
deleted file mode 100644
index 5ae7b61414e..00000000000
--- a/profiles/arch/amd64-fbsd/package.use.mask
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Andreas Sturmlechner <asturm@gentoo.org> (2019-03-31)
-# dev-python/m2crypto is not keyworded here, bugs #597744, 687526
-dev-python/soappy ssl
-
-# Thomas Deutschmann <whissi@gentoo.org> (2019-04-18)
-# app-arch/zstd is not keyworded.
-media-libs/tiff zstd
-
-# Lars Wendler <polynomial-c@gentoo.org> (2019-04-15)
-# dev-vcs/subversion lacks amd64-fbsd keyword
-app-portage/layman subversion test
-dev-vcs/git subversion
-
-# David Seifert <soap@gentoo.org> (2019-04-15)
-# app-arch/zstd is not keyworded.
-dev-libs/boost zstd
-
-# Hans de Graaff <graaff@gentoo.org> (2019-04-08)
-# Obsolete ruby version, no newer versions keyworded or stable.
-dev-vcs/subversion ruby
-
-# Michał Górny <mgorny@gentoo.org> (2019-03-20)
-# Z3 fails to link on FreeBSD but linker produces no error messages.
-sys-devel/clang z3
-
-# Michał Górny <mgorny@gentoo.org> (2019-01-22)
-# Missing keywords on dependencies.
-app-arch/libarchive zstd
-
-# Mikle Kolyada <zlogene@gentoo.org> (2018-10-05)
-# Not keyworded
-app-admin/sudo sssd
-
-# Ulrich Müller <ulm@gentoo.org> (2018-05-01)
-# Missing keyword on virtual/gsasl dependency, bug #635216.
-net-mail/mailutils sasl
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-13)
-# Missing keywords on dependencies.
-dev-qt/designer webkit
-dev-qt/qtgui eglfs evdev ibus libinput
-dev-qt/qtnetwork connman libproxy
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-02)
-# Someone needs to test the driver.
-x11-base/xorg-drivers video_cards_amdgpu
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-02)
-# Requires sys-fs/fuse. Maybe it could work with fuse4bsd?
-net-fs/openafs fuse
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-01)
-# Requires separate libacl while FreeBSD has it in libc.
-dev-lang/php acl
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-01)
-# Unkeyworded dependencies.
-dev-libs/cyrus-sasl authdaemond
-gnome-base/gvfs cdda google nfs
-sys-auth/consolekit evdev pm-utils
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-28)
-# Requires masked USE flags.
-gnome-base/gvfs mtp
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-22)
-# USE=libcxxrt is use.forced.
-sys-libs/libcxx libcxxabi
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-22)
-# Even more unkeyworded dependencies.
-dev-libs/libpeas lua
-dev-util/cmocka doc
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-21)
-# Requires net-misc/curl[kerberos] which is masked here.
-dev-python/pycurl test
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-21)
-# More unkeyworded dependencies.
-media-video/ffmpeg frei0r
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-19)
-# Unkeyworded dependencies.
-app-doc/doxygen clang
-dev-perl/GD fcgi
-media-libs/libcanberra gnome
-media-libs/mesa vaapi
-media-libs/openal sdl
-media-sound/pulseaudio equalizer qt5 realtime
-media-video/ffmpeg kvazaar libilbc openh264
-media-video/ffmpeg rubberband sdl ssh x265 zeromq zimg
-net-libs/gnutls idn
-net-print/cups-filters pdf
-sys-devel/gcc objc-gc
-x11-drivers/nvidia-drivers static-libs tools
-x11-libs/pango test
-x11-wm/fluxbox vim-syntax
-virtual/ffmpeg sdl
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-17)
-# Claims to require dev-libs/elfutils which doesn't support FreeBSD.
-# We can umask if it works with virtual/libelf though.
-media-libs/gstreamer unwind
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-17)
-# Unkeyworded deps.
-media-libs/phonon vlc
-virtual/notification-daemon kde
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-15)
-# Requires USE=seccomp that is masked in this profile.
-net-libs/gnutls test-full
-
-# Ulrich Müller <ulm@gentoo.org> (2017-10-23)
-# Needs net-mail/mailutils which is not keyworded, bug #635216.
-app-editors/emacs mailutils
-app-editors/emacs-vcs mailutils
-
-# Johannes Huber <johu@gentoo.org> (2015-01-28)
-# Missing keyword on dev-libs/botan and dev-libs/pkcs11-helper
-app-crypt/qca botan pkcs11
-
-# Michael Palimaka <kensington@gentoo.org> (2014-12-26)
-# Unkeyworded media-libs/opencv
-media-plugins/frei0r-plugins facedetect
-media-video/vlc opencv
-
-# Patrick Lauer <patrick@gentoo.org> (2014-11-17)
-# Lars Wendler <polynomial-c@gentoo.org> (2015-01-23)
-# Missing keywords
-dev-libs/openssl sctp
-dev-libs/openssl-compat sctp
-net-misc/openssh sctp
-
-# Pacho Ramos <pacho@gentoo.org> (2014-06-01)
-# Missing keywords
->=app-misc/geoclue-2.1 modemmanager
->=x11-libs/gtk+-3.12 cloudprint
->=app-crypt/libsecret-0.16 test
-media-plugins/gst-plugins-meta modplug vaapi
-
-# Lars Wendler <polynomial-c@gentoo.org> (2014-05-09)
-# Masked kde USE flag until bug #509892 is fixed
-dev-vcs/subversion kwallet
-
-# Pacho Ramos <pacho@gentoo.org> (2013-12-02)
-# Missing keywords, bug #493156
-media-libs/libgphoto2 serial
-
-# nvidia-driver uses acpid
-x11-drivers/nvidia-drivers acpi
-
-# Needs emul libs and the package isnt multilib at all for FreeBSD x86_64
-x11-drivers/nvidia-drivers multilib
-
-# requires nvidia-cg-toolkit which is not available on bsd
-# see http://developer.nvidia.com/cg-toolkit-download
-media-libs/libprojectm video_cards_nvidia
-
-# x11-drivers/xf86-video-vmware works fine without KMS- and 3D support.
-# Other packages will not work. keep video_cards_vmware in use.mask.
-x11-base/xorg-drivers -video_cards_vmware
diff --git a/profiles/arch/amd64-fbsd/parent b/profiles/arch/amd64-fbsd/parent
deleted file mode 100644
index 014611b2535..00000000000
--- a/profiles/arch/amd64-fbsd/parent
+++ /dev/null
@@ -1,3 +0,0 @@
-../base
-../../features/multilib
-todo
diff --git a/profiles/arch/amd64-fbsd/todo/eapi b/profiles/arch/amd64-fbsd/todo/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/arch/amd64-fbsd/todo/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/arch/amd64-fbsd/todo/package.use.force b/profiles/arch/amd64-fbsd/todo/package.use.force
deleted file mode 100644
index b7e1ec208ca..00000000000
--- a/profiles/arch/amd64-fbsd/todo/package.use.force
+++ /dev/null
@@ -1,7 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-sys-libs/libcxx libcxxrt
-
-# bug 562412
-www-client/firefox pulseaudio
diff --git a/profiles/arch/amd64-fbsd/todo/package.use.mask b/profiles/arch/amd64-fbsd/todo/package.use.mask
deleted file mode 100644
index 493d7286044..00000000000
--- a/profiles/arch/amd64-fbsd/todo/package.use.mask
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Mask useflags that require deps with missing keywords.
-# Anyone is allowed and _very welcome_ to add masks there.
-# We will pick them up and keyword as time permits and prefer having a sane
-# deptree with missing features than a broken one.
-# Do *NOT* add a ChangeLog entry when modifying this file: it is intended as
-# temporary and cvs log is more than enough for getting its history.
-#
-# Syntax is: # mising dep(s)
-# mask
-# Keep it simple, we do not really care about the date or who masked it, we want
-# to be easily able to determine what we need to keyword.
-
-# net-dns/libidn2
-net-misc/wget idn
-
-# net-libs/gnome-online-accounts
-gnome-base/gvfs gnome-online-accounts
-
-# media-libs/gavl (missing clock_nanosleep on fbsd)
-media-plugins/frei0r-plugins scale0tilt
-
-# net-fs/openafs
-app-crypt/heimdal afs
-
-# app-accessibility/flite (fails at install)
-media-video/ffmpeg flite
-
-# dev-vcs/darcs
-app-portage/layman darcs
-
-# dev-python/mysql-python
-dev-vcs/mercurial bugzilla
-
-# media-libs/libmetalink -> undefined references on TEMP_FAILURE_RETRY (macro
-# provided by glibc)
-net-misc/curl metalink
-
-# sys-process/numactl
-sys-apps/hwloc numa
-
-# dev-lang/mono
-net-dns/libidn mono
-media-libs/libcaca mono
-
-# dev-lang/mono
-# >=dev-dotnet/gtk-sharp-2
-net-dns/avahi mono
-
-# net-misc/netkit-rsh
-x11-apps/xsm rsh
-
-# net-libs/libtirpc
-sys-apps/xinetd rpc
-
-# sci-libs/cfitsio
-media-gfx/ufraw fits
-
-# >=media-gfx/gimp-2
-media-gfx/ufraw gimp
-
-# net-libs/libproxy
-net-libs/neon libproxy
-net-libs/glib-networking libproxy
-
-# dev-libs/pakchois
-net-libs/neon pkcs11
-
-# app-text/texlive[extra]
-app-doc/doxygen latex doc
-
-# x11-misc/colord
-x11-libs/gtk+ colord
-
-# sys-auth/polkit
-sys-auth/consolekit policykit
-gnome-base/gconf policykit
-
-# media-sound/pulseaudio
-media-libs/libsdl pulseaudio
-media-libs/openal pulseaudio
-media-video/ffmpeg pulseaudio
-media-libs/libcanberra pulseaudio
-media-libs/phonon pulseaudio
-media-video/vlc pulseaudio
-media-sound/mpg123 pulseaudio
-media-video/mplayer pulseaudio
-media-libs/xine-lib pulseaudio
-
-# >=media-plugins/gst-plugins-pulse-0.10
-media-plugins/gst-plugins-meta pulseaudio
-
-# >=app-pda/libimobiledevice-1.1.0
-gnome-base/gvfs ios
-
-# >=sys-fs/fuse-2.8.0
-gnome-base/gvfs fuse
-
-# >=x11-libs/libva-0.32
-media-video/ffmpeg vaapi
-virtual/ffmpeg vaapi
-media-video/vlc vaapi
-media-libs/xine-lib vaapi
-
-# media-libs/nas
-media-libs/libsdl nas
-app-editors/xemacs nas
-media-sound/mpg123 nas
-media-video/mplayer nas
-
-# net-misc/openntpd
-net-misc/ntp openntpd
-
-# fails to build, need to investigate why
-net-libs/webkit-gtk geolocation introspection
-
-# virtual/mysql
-sci-mathematics/glpk mysql
-dev-libs/apr-util mysql
-dev-qt/qtsql mysql
-dev-libs/redland mysql
-dev-libs/cyrus-sasl mysql
-dev-lang/php mysql mysqli
-net-libs/courier-authlib mysql
-
-# does not build
-media-libs/mesa video_cards_vmware
-
-# media-libs/libepoxy
-x11-base/xorg-server glamor wayland
-x11-drivers/xf86-video-ati glamor
-
-# >=sys-devel/binutils-2.22
-sys-devel/llvm gold
-
-# media-libs/liboggz
-media-libs/libkate wxwidgets
-
-# media-sound/fluidsynth
-media-video/vlc fluidsynth
-
-# sys-cluster/knem
-sys-cluster/openmpi openmpi_fabrics_knem
-
-# sys-fabric/dapl
-sys-cluster/openmpi openmpi_fabrics_dapl
-
-# sys-fabric/ofed
-sys-cluster/openmpi openmpi_fabrics_ofed openmpi_ofed_features_control-hdr-padding openmpi_ofed_features_connectx-xrc openmpi_ofed_features_udcm openmpi_ofed_features_dynamic-sl openmpi_ofed_features_failover
-
-# sys-fabric/infinipath-psm
-sys-cluster/openmpi openmpi_fabrics_psm
-
-# sys-fabric/librdmacm
-sys-cluster/openmpi openmpi_ofed_features_rdmacm
-
-# sys-cluster/slurm
-sys-cluster/openmpi openmpi_rm_slurm
-
-# x11-libs/dnd
-app-editors/xemacs dnd
-
-# app-i18n/canna
-app-editors/xemacs canna
-
-# app-i18n/freewnn
-app-editors/xemacs freewnn
-
-# media-libs/devil[png,jpeg]
-media-gfx/graphviz devil
-
-# sys-apps/util-linux (libuuid)
-net-misc/wget uuid
-
-# net-misc/freerdp (doesnt build)
-media-video/vlc rdp
-
-# net-wireless/bluez
-media-sound/pulseaudio native-headset ofono-headset
diff --git a/profiles/arch/amd64-fbsd/use.force b/profiles/arch/amd64-fbsd/use.force
deleted file mode 100644
index 9dc35a08b0f..00000000000
--- a/profiles/arch/amd64-fbsd/use.force
+++ /dev/null
@@ -1,5 +0,0 @@
-# Force the flag which corresponds to ARCH.
-amd64-fbsd
-
-# Multilib flag for default ABI
-abi_x86_64
diff --git a/profiles/arch/amd64-fbsd/use.mask b/profiles/arch/amd64-fbsd/use.mask
deleted file mode 100644
index 3dfab0817e6..00000000000
--- a/profiles/arch/amd64-fbsd/use.mask
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Unmask the flag which corresponds to ARCH.
--amd64-fbsd
-
--cpu_flags_x86_3dnow
--cpu_flags_x86_3dnowext
--cpu_flags_x86_aes
--cpu_flags_x86_avx
--cpu_flags_x86_avx2
--cpu_flags_x86_fma3
--cpu_flags_x86_fma4
--cpu_flags_x86_mmx
--cpu_flags_x86_mmxext
--cpu_flags_x86_padlock
--cpu_flags_x86_popcnt
--cpu_flags_x86_sse
--cpu_flags_x86_sse2
--cpu_flags_x86_sse3
--cpu_flags_x86_sse4_1
--cpu_flags_x86_sse4_2
--cpu_flags_x86_sse4a
--cpu_flags_x86_ssse3
--cpu_flags_x86_xop
-
-# nvidia drivers works on x86
--xvmc
--nvidia
--video_cards_nvidia
-
-# Unmask vmware drivers
-#-video_cards_vmware
--input_devices_vmmouse
-
-# Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com> (2019‑08‑31)
-# Dependencies not keyworded.
-ayatana
-
-# Andreas Sturmlechner <asturm@gentoo.org> (2019-03-31)
-# sys-auth/elogind is not keyworded here.
-elogind
-
-# Ulrich Müller <ulm@gentoo.org> (2018-05-01)
-# virtual/mysql is not keyworded.
-mysql
-
-# Michał Górny <mgorny@gentoo.org> (2018-04-21)
-# net-wireless/bluez.
-bluetooth
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-02)
-# Requires dev-libs/libressl (not yet tested).
-curl_ssl_libressl
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-02)
-# Someone needs to test them.
-input_devices_libinput
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-01)
-# virtual/mpi not keyworded at the moment.
-mpi
-
-# Michał Górny <mgorny@gentoo.org> (2018-03-01)
-# sys-process/audit seems pretty Linux-specific.
-audit
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-25)
-# google-perftools does not work on FreeBSD.
-tcmalloc
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-17)
-# libraw is not keyworded here.
-raw
-
-# Michał Górny <mgorny@gentoo.org> (2018-02-17)
-# libav is not keyworded here.
-libav
-
-# Mart Raudsepp <leio@gentoo.org> (2018-02-11)
-# dev-util/valgrind is not keyworded here.
-valgrind
-
-# Michał Górny <mgorny@gentoo.org> (2018-01-23)
-# sys-libs/libseccomp is not keyworded here.
-seccomp
-
-# Michał Górny <mgorny@gentoo.org> (2018-01-23)
-# net-fs/samba is not keyworded here.
-samba
-
-# James Le Cuirot <chewi@gentoo.org> (2015-05-19)
-# icedtea needs testing and gcj isn't supported
-java
-
-# Other
-
-# Alexandre Rostovtsev <tetromino@gentoo.org> (2012-12-09)
-# Orc optimisations work fine on amd64 and x86
--orc
-
-# Diego Elio Pettenò <flameeyes@gentoo.org> (2012-08-21)
-# IPMI is only implemented for x86, amd64 and ia64
--ipmi
-
-# Multilib ABIs
--abi_x86_32
--abi_x86_64
-
-# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (2013-08-22)
-# virtual/opencl is not keyworded
-opencl
-
-# Hans de Graaff <graaff@gentoo.org> (2014-12-27)
-# dev-libs/jemalloc is not keyworded
-jemalloc
-
-# Benda Xu <heroxbd@gentoo.org> (2019-06-26)
-# Not tested
-eselect-ldso
diff --git a/profiles/arch/x86-fbsd/eapi b/profiles/arch/x86-fbsd/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/arch/x86-fbsd/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/arch/x86-fbsd/make.defaults b/profiles/arch/x86-fbsd/make.defaults
deleted file mode 100644
index e801595ce68..00000000000
--- a/profiles/arch/x86-fbsd/make.defaults
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-# System-wide defaults for the G/FBSD Portage system
-
-ARCH="x86-fbsd"
-CFLAGS="-march=i686 -O2 -pipe"
-CXXFLAGS="${CFLAGS}"
-FFLAGS="${CFLAGS}"
-FCFLAGS="${CFLAGS}"
-
-ACCEPT_KEYWORDS="x86-fbsd ~x86-fbsd"
-
-# Michał Górny <mgorny@gentoo.org> (2014-06-20)
-# Provide values for ABI-related variables that are compatible with
-# multilib amd64, to make consistent ebuild writing easier.
-MULTILIB_ABIS="x86_fbsd"
-DEFAULT_ABI="x86_fbsd"
-ABI="x86_fbsd"
-LIBDIR_x86_fbsd="lib"
-
-VIDEO_CARDS="dummy intel mga nv r128 radeon siliconmotion via vmware"
-
-# Unhide the CPU_FLAGS_X86 USE_EXPANDs.
-USE_EXPAND_HIDDEN="-CPU_FLAGS_X86"
-
-# Michał Górny <mgorny@gentoo.org> (2014-07-01)
-# Default to abi_x86_32 for packages that don't have it forced.
-ABI_X86="32"
-
-# Michał Górny <mgorny@gentoo.org> (2014-07-01)
-# Make the native ABI implicit so that MULTILIB_USEDEP can be satisfied
-# by non-multilib ebuilds when non-native ABIs are disabled.
-IUSE_IMPLICIT="abi_x86_32"
diff --git a/profiles/arch/x86-fbsd/package.use.force b/profiles/arch/x86-fbsd/package.use.force
deleted file mode 100644
index 1c803f758db..00000000000
--- a/profiles/arch/x86-fbsd/package.use.force
+++ /dev/null
@@ -1,8 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Michał Górny <mgorny@gentoo.org> (2016-09-24)
-# Force the host target to avoid dependency hell
-dev-ml/llvm-ocaml llvm_targets_X86
-sys-devel/clang llvm_targets_X86
-sys-devel/llvm llvm_targets_X86
diff --git a/profiles/arch/x86-fbsd/package.use.mask b/profiles/arch/x86-fbsd/package.use.mask
deleted file mode 100644
index aafa97aea26..00000000000
--- a/profiles/arch/x86-fbsd/package.use.mask
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Andreas Sturmlechner <asturm@gentoo.org> (2018-09-01)
-# media-libs/libaom not yet keyworded
-# media-libs/aribb24 not yet keyworded, bug #665048
-# media-libs/dav1d is not yet keyworded
-# skins requires USE=qt5 that is masked in this profile.
-media-video/vlc aom aribsub dav1d skins
-
-# Thomas Deutschmann <whissi@gentoo.org> (2017-10-26)
-# idn: Needs net-dns/libidn2 which is not keyworded
-# uuid: Needs sys-apps/util-linux which is not keyworded
-net-misc/wget idn uuid
-
-# Ulrich Müller <ulm@gentoo.org> (2017-10-23)
-# Needs net-mail/mailutils which is not keyworded, bug #635216.
-app-editors/emacs mailutils
-app-editors/emacs-vcs mailutils
-
-# Thomas Deutschmann <whissi@gentoo.org> (2017-06-09)
-# sys-process/audit not keyworded
-sys-process/fcron audit
-
-# Thomas Deutschmann <whissi@gentoo.org> (2017-02-14)
-# net-misc/curl dropped keywords in ffe8d873b8110d4434fc89423ea668450cab1d96
-www-servers/nginx nginx_modules_http_security
-
-# Alexis Ballier <aballier@gentoo.org> (2017-01-31)
-# nvidia drivers are unmasked here
-media-video/ffmpeg -nvenc
-
-# Michael Palimaka <kensington@gentoo.org> (2016-06-21)
-# Requires unkeyworded media-sound/jack-audio-connection-kit & media-video/movit
-media-libs/mlt jack opengl
-
-# Davide Pesavento <pesa@gentoo.org> (2015-10-26)
-# Tests require non-keyworded qt5
-dev-qt/qtchooser test
-
-# Johannes Huber <johu@gentoo.org> (2015-01-28)
-# Missing keyword on dev-libs/botan
-app-crypt/qca botan
-
-# Pacho Ramos <pacho@gentoo> (2011-03-18)
-# Missing keywords on deps (GNOME related packages)
-dev-libs/totem-pl-parser quvi
-media-plugins/gst-plugins-meta dv dvd vcd vpx wavpack
-
-# Justin Lecher <jlec@gentoo.org> (2010-09-19)
-# kde-apps/konqueror not keyworded
-app-arch/p7zip kde
-
-# Justin Lecher <jlec@gentoo.org> (2010-09-12)
-# net-libs/farsight2 not keyworded
-net-im/gajim jingle
-
-# Justin Lecher <jlec@gentoo.org> (2010-08-13)
-# MKL not available on this arch
-media-gfx/povray mkl
-
-# Java currently uses generation 1
-dev-libs/cyrus-sasl java
-
-# nvidia-driver uses acpid
-x11-drivers/nvidia-drivers acpi
-
-# gavl and opencv do not build
-media-plugins/frei0r-plugins scale0tilt facedetect
-
-# Dependencies not keyworded, bug #424571
-net-nds/openldap smbkrb5passwd
diff --git a/profiles/arch/x86-fbsd/parent b/profiles/arch/x86-fbsd/parent
deleted file mode 100644
index eb001c6e8ab..00000000000
--- a/profiles/arch/x86-fbsd/parent
+++ /dev/null
@@ -1 +0,0 @@
-../base
diff --git a/profiles/arch/x86-fbsd/use.force b/profiles/arch/x86-fbsd/use.force
deleted file mode 100644
index 98c1a17086c..00000000000
--- a/profiles/arch/x86-fbsd/use.force
+++ /dev/null
@@ -1,3 +0,0 @@
-# Force the flag which corresponds to ARCH.
-x86-fbsd
-abi_x86_32
diff --git a/profiles/arch/x86-fbsd/use.mask b/profiles/arch/x86-fbsd/use.mask
deleted file mode 100644
index 385830faf29..00000000000
--- a/profiles/arch/x86-fbsd/use.mask
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Unmask the flag which corresponds to ARCH.
--x86-fbsd
--abi_x86_32
-
-# Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com> (2019‑08‑31)
-# Dependencies not keyworded.
-ayatana
-
-# Andreas Sturmlechner <asturm@gentoo.org> (2019-03-31)
-# sys-auth/elogind is not keyworded here.
-elogind
-
-# Michael Palimaka <kensington@gentoo.org> (2016-06-21)
-# Unkeyworded
-qt5
-
-# Diego Elio Pettenò <flameeyes@gentoo.org> (2012-08-21)
-# IPMI is only implemented for x86, amd64 and ia64
--ipmi
-
--cpu_flags_x86_3dnow
--cpu_flags_x86_3dnowext
--cpu_flags_x86_aes
--cpu_flags_x86_avx
--cpu_flags_x86_avx2
--cpu_flags_x86_fma3
--cpu_flags_x86_fma4
--cpu_flags_x86_mmx
--cpu_flags_x86_mmxext
--cpu_flags_x86_padlock
--cpu_flags_x86_popcnt
--cpu_flags_x86_sse
--cpu_flags_x86_sse2
--cpu_flags_x86_sse3
--cpu_flags_x86_sse4_1
--cpu_flags_x86_sse4_2
--cpu_flags_x86_sse4a
--cpu_flags_x86_ssse3
--cpu_flags_x86_xop
-
-# nvidia drivers works on x86
--xvmc
--nvidia
--video_cards_nvidia
-
-# Unmask vmware drivers
--video_cards_vmware
--input_devices_vmmouse
-
-# James Le Cuirot <chewi@gentoo.org> (2015-05-19)
-# icedtea needs testing and gcj isn't supported
-java
-
-# No pulseaudio version is keyworded; unmask when it works
-pulseaudio
-# No portaudio version is keyworded; unmask when it works
-portaudio
-
-# valgrind hasn't been ported to fbsd yet
-valgrind
-
-# libva doesnt build on fbsd for now
-vaapi
-
-# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (2013-08-22)
-# virtual/opencl is not keyworded
-opencl
-
-# Benda Xu <heroxbd@gentoo.org> (2019-06-26)
-# Not tested
-eselect-ldso
diff --git a/profiles/default/bsd/eapi b/profiles/default/bsd/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/amd64/11.1/clang/eapi b/profiles/default/bsd/fbsd/amd64/11.1/clang/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/fbsd/amd64/11.1/clang/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/amd64/11.1/clang/parent b/profiles/default/bsd/fbsd/amd64/11.1/clang/parent
deleted file mode 100644
index 7dbda405f0a..00000000000
--- a/profiles/default/bsd/fbsd/amd64/11.1/clang/parent
+++ /dev/null
@@ -1,2 +0,0 @@
-..
-../../../../../../arch/amd64-fbsd/clang
diff --git a/profiles/default/bsd/fbsd/amd64/11.1/eapi b/profiles/default/bsd/fbsd/amd64/11.1/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/fbsd/amd64/11.1/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/amd64/11.1/make.defaults b/profiles/default/bsd/fbsd/amd64/11.1/make.defaults
deleted file mode 100644
index eaafeb7a93f..00000000000
--- a/profiles/default/bsd/fbsd/amd64/11.1/make.defaults
+++ /dev/null
@@ -1,6 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-CHOST="x86_64-gentoo-freebsd11.1"
-CHOST_amd64_fbsd="x86_64-gentoo-freebsd11.1"
-CHOST_x86_fbsd="i686-gentoo-freebsd11.1"
diff --git a/profiles/default/bsd/fbsd/amd64/11.1/parent b/profiles/default/bsd/fbsd/amd64/11.1/parent
deleted file mode 100644
index 317f8c857ad..00000000000
--- a/profiles/default/bsd/fbsd/amd64/11.1/parent
+++ /dev/null
@@ -1,2 +0,0 @@
-..
-../../../../../releases/freebsd-11.1
diff --git a/profiles/default/bsd/fbsd/amd64/eapi b/profiles/default/bsd/fbsd/amd64/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/fbsd/amd64/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/amd64/parent b/profiles/default/bsd/fbsd/amd64/parent
deleted file mode 100644
index 5fbdc945bbc..00000000000
--- a/profiles/default/bsd/fbsd/amd64/parent
+++ /dev/null
@@ -1,2 +0,0 @@
-..
-../../../../arch/amd64-fbsd
diff --git a/profiles/default/bsd/fbsd/eapi b/profiles/default/bsd/fbsd/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/fbsd/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/make.defaults b/profiles/default/bsd/fbsd/make.defaults
deleted file mode 100644
index 43e27554dfe..00000000000
--- a/profiles/default/bsd/fbsd/make.defaults
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Last building sandbox breaks gfind, bug #374425
-FEATURES="-sandbox -usersandbox"
-
-USERLAND="BSD"
-KERNEL="FreeBSD"
-ELIBC="FreeBSD"
-
-MAKE="gmake"
-
-USE="berkdb crypt iconv ipv6 ncurses nls oss pam pcre readline ssl tcpd zlib"
-
-# Donnie Berkholz <dberkholz@gentoo.org> (2006-03-07)
-# Modular X: Support direct rendering by default
-USE="${USE} dri"
-
-# Donnie Berkholz <dberkholz@gentoo.org> (2006-08-18)
-# Defaults for video drivers
-VIDEO_CARDS="dummy fbdev vmware"
-
-# Let virtual/mta pick ssmtp[mta] for stage1 builds.
-# https://bugs.gentoo.org/show_bug.cgi?id=408587
-BOOTSTRAP_USE="${BOOTSTRAP_USE} mta"
diff --git a/profiles/default/bsd/fbsd/package.mask b/profiles/default/bsd/fbsd/package.mask
deleted file mode 100644
index 973fa4f5bce..00000000000
--- a/profiles/default/bsd/fbsd/package.mask
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Diego Pettenò <flameeyes@gentoo.org> (2005-05-27)
-# SGI's FAM is dead upstream, and requires mayor changes.
-# Gamin before 0.1.0 is not supported as missed the FreeBSD patches.
-# At the moment we rely on Gentopia's patched Gamin.
-app-admin/fam
-
-# Diego Pettenò <flameeyes@gentoo.org> (2005-05-23)
-# Strace doesn't support FreeBSD 5. When a better port will be
-# available, this can be unmasked.
-dev-util/strace
-
-# Don't use them, use the one in base system
-dev-util/yacc
-dev-util/byacc
diff --git a/profiles/default/bsd/fbsd/package.use b/profiles/default/bsd/fbsd/package.use
deleted file mode 100644
index 5c91bf16e4b..00000000000
--- a/profiles/default/bsd/fbsd/package.use
+++ /dev/null
@@ -1,12 +0,0 @@
-# Default USE flags for specific packages
-
-# Diego Pettenò <flameeyes@gentoo.org> (2008-03-06)
-# pam_racklib requires sys-libs/pam, disable it by default (it is
-# masked anyway).
-# pam_passwdqc is used by default on FreeBSD, enable it by default
-# even on Gentoo/FreeBSD.
-sys-auth/pambase -cracklib passwdqc
-
-# Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org> (2011-02-13)
-# Disable deprecated bsddb module of Python 2 by default.
-=dev-lang/python-2* -berkdb
diff --git a/profiles/default/bsd/fbsd/package.use.force b/profiles/default/bsd/fbsd/package.use.force
deleted file mode 100644
index 323ffb50b59..00000000000
--- a/profiles/default/bsd/fbsd/package.use.force
+++ /dev/null
@@ -1,4 +0,0 @@
-# app-arch/xz-utils[threads=] required by app-arch/libarchive
-# https://bugs.gentoo.org/show_bug.cgi?id=594980
-app-arch/libarchive threads
-app-arch/xz-utils threads
diff --git a/profiles/default/bsd/fbsd/package.use.mask b/profiles/default/bsd/fbsd/package.use.mask
deleted file mode 100644
index 3e92ffe92bf..00000000000
--- a/profiles/default/bsd/fbsd/package.use.mask
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Michał Górny <mgorny@gentoo.org> (2018-04-06)
-# We are building only minimal util-linux, so program flags
-# are irrelevant to us.
-sys-apps/util-linux build cramfs fdformat kill ncurses pam readline
-sys-apps/util-linux slang suid tty-helpers
-
-# Brian Evans <grknight@gentoo.org> (2018-03-02)
-# php incorrectly looks for libacl when it is built-in on FreeBSD
-dev-lang/php acl
-
-# Thomas Deutschmann <whissi@gentoo.org> (2017-10-26)
-# libressl: dev-libs/libressl is a base package on FreeBSD
-net-misc/wget libressl
-
-# Thomas Deutschmann <whissi@gentoo.org> (2017-01-20)
-# libressl: dev-libs/libressl is a base package on FreeBSD
-net-libs/libvncserver libressl
-
-# Felix Janda <felix.janda@posteo.de> (2016-09-24)
-# net-libs/libnetfilter_conntrack is not keyworded on FreeBSD
-net-dns/dnsmasq conntrack
-
-# Thomas Deutschmann <whissi@gentoo.org> (2016-08-26)
-# libressl: dev-libs/libressl is a base package on FreeBSD
-# jemalloc: dev-libs/jemalloc is not keyworded on FreeBSD
-# systemtap: dev-util/systemtap is not keyworded on FreeBSD and is also
-# a linux specialized tool
-dev-db/percona-server jemalloc libressl systemtap
-
-# Thomas Deutschmann <whissi@gentoo.org> (2016-08-23)
-# libressl: dev-libs/libressl is a base package on FreeBSD
-# luajit: dev-lang/luajit not keyworded on FreeBSD
-www-servers/nginx libressl luajit
-
-# As per UberLord's requests
-sys-apps/openrc pam
-
-# Jim Ramsay <lack@gentoo.org> (2007-09-07)
-# app-admin/gkrellm may pull in hddtemp, which is not yet available here
-app-admin/gkrellm hddtemp
-
-# PDA masked until we can do some testing on it
-mail-client/claws-mail pda
-
-# Original spell plugin uses ispell that requires
-# miscfiles.. that in turn does not work
-net-irc/rbot spell
-
-x11-misc/xscreensaver new-login
-
-# Gilles Dartiguelongue <eva@gentoo.org> (2007-10-22)
-# GNU attr isn't supported
-dev-libs/glib xattr
-gnome-base/gnome-vfs acl
-# https://bugs.gentoo.org/show_bug.cgi?id=435474
-sys-devel/patch xattr
-# https://bugs.gentoo.org/show_bug.cgi?id=432410
-app-arch/tar xattr
-
-# Diego Pettenò <flameeyes@gentoo.org> (2008-02-21)
-# pam_cracklib is only provided by Linux-PAM which is not usable on
-# Gentoo/FreeBSD.
-# Javier Villavicencio <the_paya@gentoo.org> (2008-07-31)
-# pam_ssh deps on Linux-PAM.
-# Diego Pettenò <flameeyes@gentoo.org> (2008-08-01)
-# sha512 is only supported by Linux-PAM's pam_unix for now
-sys-auth/pambase cracklib pam_ssh sha512
-
-# Naohiro Aota <naota@gentoo.org> (2011-08-04)
-# ads require krb5, which is maksed on FreeBSD
-# cluster require ctdb, which doesn't support FreeBSD
-net-fs/samba ads cluster
-
-# Naohiro Aota <naota@gentoo.org> (2011-11-24)
-# Masked because kerberos is masked
-net-dns/bind gssapi
-
-# Naohiro Aota <naota@gentoo.org> (2012-02-20)
-# Ian Stakenvicius <axs@gentoo.org> (2014-04-30)
-# Upstream does not support FreeBSD wifi nor crashreporter;
-# net-wireless/wireless-tools useless on fbsd, keep mozilla stuff
-# from bringing it in via mozconfig-3.eclass
-www-client/firefox wifi
-www-client/seamonkey wifi
-
-# Naohiro Aota <naota@gentoo.org> (2012-10-06)
-# Mask rpm, app-arch/rpm needs elfutils
-net-analyzer/net-snmp rpm
-
-# Naohiro Aota <naota@gentoo.org> (2012-10-09)
-# Mask dmpai, sys-apps/dmapi cannot build on BSD
-net-fs/samba dmapi
-
-# Naohiro Aota <naota@gentoo.org> (2012-10-15)
-# Mask numa on sys-apps/hwloc. numactl not available on FreeBSD
-sys-apps/hwloc numa
-
-# Naohiro Aota <naota@gentoo.org> (2014-07-07)
-# xattr support is not available on BSD #501534
-sys-apps/portage xattr
diff --git a/profiles/default/bsd/fbsd/packages b/profiles/default/bsd/fbsd/packages
deleted file mode 100644
index 470e41dec3d..00000000000
--- a/profiles/default/bsd/fbsd/packages
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# This files contains a small list of packages that define a
-# minimal FreeBSD system. DO NOT change this without contacting
-# <bsd@gentoo.org>
-#
-*sys-freebsd/freebsd-mk-defs
-*sys-freebsd/freebsd-lib
-*sys-freebsd/freebsd-libexec
-*sys-freebsd/freebsd-bin
-*sys-freebsd/freebsd-sbin
-*sys-freebsd/freebsd-ubin
-*sys-freebsd/freebsd-usbin
-*sys-freebsd/freebsd-share
-
-*sys-devel/gettext
-*dev-libs/libiconv
-
-*app-arch/libarchive
-
-*sys-libs/timezone-data
-
-*sys-process/pidof-bsd
diff --git a/profiles/default/bsd/fbsd/packages.build b/profiles/default/bsd/fbsd/packages.build
deleted file mode 100644
index 4d7682dad3f..00000000000
--- a/profiles/default/bsd/fbsd/packages.build
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License v2
-
-# This file describes the packages needed to build a stage 1 based on this
-# profile. Packages in this file are built in order.
-
-# Please do not move perl before baselayout doing so will break lib -> lib64
-# symlinks on systems that use them.
-
-app-arch/bzip2
-app-arch/gzip
-dev-libs/openssl
-app-arch/libarchive
-app-shells/bash:0
-net-misc/rsync
-net-misc/wget
-sys-devel/autoconf
-sys-devel/automake
-sys-devel/libtool
-sys-apps/openrc
-sys-apps/baselayout
-sys-apps/diffutils
-sys-apps/file
-sys-apps/findutils
-sys-apps/gawk
-sys-apps/grep
-sys-apps/less
-sys-apps/sed
-sys-devel/binutils
-sys-devel/bison
-sys-devel/flex
-sys-devel/gcc
-dev-libs/libiconv
-sys-devel/gettext
-sys-devel/gnuconfig
-sys-devel/make
-sys-devel/patch
-virtual/editor
-virtual/libc
-virtual/os-headers
-virtual/package-manager
-virtual/pkgconfig
-sys-freebsd/freebsd-mk-defs
-sys-freebsd/freebsd-lib
-sys-freebsd/freebsd-libexec
-sys-freebsd/freebsd-bin
-sys-freebsd/freebsd-sbin
-sys-freebsd/freebsd-ubin
-sys-freebsd/freebsd-usbin
-sys-libs/timezone-data
diff --git a/profiles/default/bsd/fbsd/parent b/profiles/default/bsd/fbsd/parent
deleted file mode 100644
index f3229c5b987..00000000000
--- a/profiles/default/bsd/fbsd/parent
+++ /dev/null
@@ -1 +0,0 @@
-..
diff --git a/profiles/default/bsd/fbsd/profile.bashrc b/profiles/default/bsd/fbsd/profile.bashrc
deleted file mode 100644
index 89e6c19f7a8..00000000000
--- a/profiles/default/bsd/fbsd/profile.bashrc
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-
-type -P gmake > /dev/null && alias make=gmake
-type -P gpatch > /dev/null && alias patch=gpatch
-type -P gsed > /dev/null && alias sed=gsed
-type -P gawk > /dev/null && alias awk=gawk
-type -P gfind > /dev/null && alias find=gfind
-type -P gxargs > /dev/null && alias xargs=gxargs
-
-# Attempt to point the default SHELL used by configure scripts to bash.
-# while most should work with BSD's bourne just fine, the extra scripts
-# used by some applications (specially test scripts) use way too many bashisms.
-# Alexis Ballier (2012-05-29): Disable this, we should rather fix bugs and it
-# seems to confuse libtool a couple of packages (dev-libs/libtar, net-dns/hesiod)
-# export CONFIG_SHELL="/bin/bash"
-
-# Hack to avoid every package that uses libiconv/gettext
-# install a charset.alias that will collide with libiconv's one
-# See bugs 169678, 195148 and 256129.
-# Also the discussion on
-# https://archives.gentoo.org/gentoo-dev/msg_8cb1805411f37b4eb168a3e680e531f3.xml
-bsd-post_src_install()
-{
- if [ "${PN}" != "libiconv" -a -e "${D}"/usr/lib*/charset.alias ] ; then
- rm -f "${D}"/usr/lib*/charset.alias
- fi
-}
-
-# These are because of
-# https://archives.gentoo.org/gentoo-dev/msg_529a0806ed2cf841a467940a57e2d588.xml
-# The profile-* ones are meant to be used in etc/portage/profile.bashrc by user
-# until there is the registration mechanism.
-profile-post_src_install() { bsd-post_src_install ; }
- post_src_install() { bsd-post_src_install ; }
-
-
-# Another hack to fix old versions of install-sh (automake) where a non-gnu
-# mkdir is not considered thread-safe (make install errors with -j > 1)
-bsd-patch_install-sh() {
- # Do nothing if we don't have patch installed:
- if [[ -z $(type -P gpatch) ]]; then
- return 0
- fi
-
- # Do nothing if $S does not exist
- [ -d "${S}" ] || return 0
-
- local EPDIR="${EPREFIX}/usr/share/elt-patches/install-sh"
- local EPATCHES="${EPDIR}/1.5.6 ${EPDIR}/1.5.4 ${EPDIR}/1.5"
- local ret=0
- cd "${S}"
- for file in $(find . -name "install-sh" -print); do
- if [[ -n $(egrep "scriptversion=2005|scriptversion=2004" ${file}) ]]; then
- einfo "Automatically patching parallel-make unfriendly install-sh."
- # Stolen from libtool.eclass
- for mypatch in ${EPATCHES}; do
- if gpatch -p0 --dry-run "${file}" "${mypatch}" &> "${T}/patch_install-sh.log"; then
- gpatch -p0 -g0 --no-backup-if-mismatch "${file}" "${mypatch}" \
- &> "${T}/patch_install-sh.log"
- ret=$?
- break
- else
- ret=1
- fi
- done
- if [[ ret -eq 0 ]]; then
- einfo "Patch applied successfully on \"${file}\"."
- else
- ewarn "Unable to apply install-sh patch. "
- ewarn "If you experience errors during install phase, try with MAKEOPTS=\"-j1\""
- fi
- fi
- done
-}
-
-# It should be run after everything has been unpacked/patched, some developers
-# do patch this little bastard from time to time.
-# So do it after unpack() for EAPI=0|1 and after prepare() for everything else.
-if [[ -n $EAPI ]] ; then
- case "$EAPI" in
- 0|1)
- profile-post_src_unpack() { bsd-patch_install-sh ; }
- post_src_unpack() { bsd-patch_install-sh ; }
- ;;
- *)
- profile_post_src_prepare() { bsd-patch_install-sh ; }
- post_src_prepare() { bsd-patch_install-sh ; }
- ;;
- esac
-fi
diff --git a/profiles/default/bsd/fbsd/use.force b/profiles/default/bsd/fbsd/use.force
deleted file mode 100644
index c6a65ae2eb1..00000000000
--- a/profiles/default/bsd/fbsd/use.force
+++ /dev/null
@@ -1,3 +0,0 @@
-# Force freebsd-specific variables
-elibc_FreeBSD
-kernel_FreeBSD
diff --git a/profiles/default/bsd/fbsd/use.mask b/profiles/default/bsd/fbsd/use.mask
deleted file mode 100644
index 0aef3c7ce9c..00000000000
--- a/profiles/default/bsd/fbsd/use.mask
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Espeak does not run on bsd
-espeak
-
-# Someone who knows kerberos is needed to make sure that this works
-kerberos
-
-# fftw requires sinl and cosl function, not present in FreeBSD
-fftw
-
-# we have hardened.
--hardened
-
-# Unmask freebsd-specific variables
--elibc_FreeBSD
--kernel_FreeBSD
-
-# This does not build on FreeBSD, unless anybody wants to fix it, use opie
-skey
-
-# To be tested
-snmp
-pcsc-lite
-
-# we don't have custom patched cdparanoia for fbsd anymore
-cdparanoia
-
-# wayland is not targetting BSDs
-wayland
-
-# Recent sys-auth/polkit cannot be built on FreeBSD
-policykit
diff --git a/profiles/default/bsd/fbsd/x86/11.1/eapi b/profiles/default/bsd/fbsd/x86/11.1/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/fbsd/x86/11.1/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/x86/11.1/make.defaults b/profiles/default/bsd/fbsd/x86/11.1/make.defaults
deleted file mode 100644
index df595c8a018..00000000000
--- a/profiles/default/bsd/fbsd/x86/11.1/make.defaults
+++ /dev/null
@@ -1,5 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-CHOST="i686-gentoo-freebsd11.1"
-CHOST_x86_fbsd="${CHOST}"
diff --git a/profiles/default/bsd/fbsd/x86/11.1/parent b/profiles/default/bsd/fbsd/x86/11.1/parent
deleted file mode 100644
index 317f8c857ad..00000000000
--- a/profiles/default/bsd/fbsd/x86/11.1/parent
+++ /dev/null
@@ -1,2 +0,0 @@
-..
-../../../../../releases/freebsd-11.1
diff --git a/profiles/default/bsd/fbsd/x86/eapi b/profiles/default/bsd/fbsd/x86/eapi
deleted file mode 100644
index 7ed6ff82de6..00000000000
--- a/profiles/default/bsd/fbsd/x86/eapi
+++ /dev/null
@@ -1 +0,0 @@
-5
diff --git a/profiles/default/bsd/fbsd/x86/parent b/profiles/default/bsd/fbsd/x86/parent
deleted file mode 100644
index 2b1ea633a87..00000000000
--- a/profiles/default/bsd/fbsd/x86/parent
+++ /dev/null
@@ -1,2 +0,0 @@
-..
-../../../../arch/x86-fbsd
diff --git a/profiles/default/bsd/make.defaults b/profiles/default/bsd/make.defaults
deleted file mode 100644
index db654124364..00000000000
--- a/profiles/default/bsd/make.defaults
+++ /dev/null
@@ -1,5 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Mask systemd files until upstream supports *BSD
-INSTALL_MASK="/usr/lib/systemd"
diff --git a/profiles/default/bsd/package.mask b/profiles/default/bsd/package.mask
deleted file mode 100644
index 7acc12c39bc..00000000000
--- a/profiles/default/bsd/package.mask
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Mask out the GNU versions of various packages.
-# We want BSD versions wherever possible
-# Also mask packages that are depending on Linux kernel
-sys-apps/apmd
-sys-apps/net-tools
-net-misc/iputils
-sys-apps/hardened-shadow
-sys-apps/shadow
-sys-apps/utempter
-sys-apps/which
-sys-libs/glibc
-sys-libs/libcap
-sys-libs/pam
-sys-power/acpid
-sys-process/procps
-sys-apps/iproute2
-sys-fs/eudev
-sys-fs/udev
-virtual/libgudev
-virtual/libudev
-virtual/udev
-sys-fs/sysfsutils
-sys-apps/attr
-sys-apps/acl
-net-misc/pump
-
-# Diego Pettenò <flameeyes@gentoo.org> (2005-06-05)
-# metamail isn't maintained anymore upstream, Debian patches doesn't
-# work on FreeBSD, and neither on Debian or on FreeBSD the package
-# has a maintainer to coordinate with. Isn't an hard-dep for anything.
-net-mail/metamail
-
-# Diego Pettenò <flameeyes@gentoo.org> (2005-08-20)
-# We obviously can't have linux-sources (mask this to allow the
-# virtual to be masked)
-sys-kernel/gentoo-sources
diff --git a/profiles/default/bsd/package.use b/profiles/default/bsd/package.use
deleted file mode 100644
index e572e7e61ca..00000000000
--- a/profiles/default/bsd/package.use
+++ /dev/null
@@ -1,7 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Michał Górny <mgorny@gentoo.org> (2017-01-26)
-# Preserve the old defaults on *BSD systems.
-sys-libs/libcxx -libcxxabi libcxxrt -libunwind
-sys-libs/libcxxrt -libunwind
diff --git a/profiles/default/bsd/package.use.force b/profiles/default/bsd/package.use.force
deleted file mode 100644
index c7c7c02310c..00000000000
--- a/profiles/default/bsd/package.use.force
+++ /dev/null
@@ -1,3 +0,0 @@
-# Javier Villavicencio <the_paya@gentoo.org> (2009-01-22)
-# Otherwise useless tar.
-app-arch/libarchive bzip2 zlib lzma
diff --git a/profiles/default/bsd/package.use.mask b/profiles/default/bsd/package.use.mask
deleted file mode 100644
index 2842678d58e..00000000000
--- a/profiles/default/bsd/package.use.mask
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Michał Górny <mgorny@gentoo.org> (2018-09-20)
-# dev-libs/libpfm has broken install rules for FreeBSD. Bug #666649.
-sys-devel/llvm exegesis
-
-# Fabian Groffen <grobian@gentoo.org> (2016-12-07)
-# unkeyworded notmuch dependency, bug #587560
-mail-client/mutt notmuch
-
-# Matthias Maier <tamiko@gentoo.org> (2014-12-24)
-# dev-libs/xapian is currently not keyworded for any *-bsd profile
-app-doc/doxygen doxysearch
-
-# Mikle Kolyada <zlogene@gentoo.org> (2014-12-07)
-# There are a lot of unkeyworded dev-perl/* packages
-dev-vcs/git mediawiki mediawiki-experimental
-
-# Robin H. Johnson <robbat2@gentoo.org> (2014-01-05)
-# Pending keywording of net-libs/miniupnpc per bug #497186
-net-proxy/dante upnp
-
-# Naohiro Aota <naota@gentoo.org> (2013-10-14)
-# libcap-ng is for Linux only
-net-analyzer/tcpdump drop-root
-
-# Sebastian Pipping <sping@gentoo.org> (2011-02-22)
-# No dev-util/source-highlight or media-sound/lilypond here, yet (bug #356069, bug #344289)
-app-text/asciidoc test highlight
-
-# iproute2 - linux only
-net-vpn/openvpn iproute2
-
-media-video/ffmpeg ieee1394 iec61883
-net-libs/c-client pam
-net-proxy/squid -ipf-transparent -pf-transparent
-sys-apps/coreutils acl
-sys-apps/help2man nls
-
-# NetworkManager is Linux-only, Zephyr requires kerberos
-net-im/pidgin networkmanager zephyr
-
-# Alexis Ballier <aballier@gentoo.org> (2008-07-18)
-# Requires a linux only library, bug #226085
-dev-lang/erlang sctp
-
-# Alexis Ballier <aballier@gentoo.org> (2008-08-08)
-# Linux only useflags for vlc
-media-video/vlc dc1394 ieee1394
-
-# Alexis Ballier <aballier@gentoo.org> (2008-08-08)
-# Depends on torque which is a linux only thing
-# lksctp-tools is linux only too
-sys-cluster/openmpi openmpi_rm_pbs openmpi_fabrics_sctp
-
-# Alexis Ballier <aballier@gentoo.org> (2008-09-25)
-# elf -> dev-libs/elfutils is too tight to the gnu libc
-# rpm could be masked but we have rpm 5 keyworded even if it's still masked.
-net-analyzer/net-snmp elf
-
-# Alexis Ballier <aballier@gentoo.org> (2008-10-04)
-# clisp doesn't build out of the box but can be fixed, xindy's way of building
-# its clisp module is confused by gmake vs bsdmake, mask it until we can
-# properly keyword xindy.
-app-text/texlive xindy
-
-# Alexis Ballier <aballier@gentoo.org> (2008-11-28)
-# Requires bluez-libs which is linux only
-net-libs/libpcap bluetooth
-
-# Alexis Ballier <aballier@gentoo.org> (2009-01-22)
-# Requires gpm
-www-client/links livecd
-
-# needs udev
-media-libs/libsdl2 kms
-media-libs/mesa gbm dri3 d3d9 vulkan vulkan-overlay
-x11-base/xorg-drivers video_cards_radeonsi
-x11-drivers/xf86-video-ati glamor
-media-libs/gst-plugins-base gbm
->=gnome-base/gvfs-1.38 cdda gphoto2 mtp udisks
-
-# udisks is linux only (for now?)
-gnome-base/gvfs udisks
-
-# joystick useflag is linux only #477750
-media-video/mplayer joystick
-
-# linux only
-media-libs/opencv ieee1394 cuda
diff --git a/profiles/default/bsd/packages b/profiles/default/bsd/packages
deleted file mode 100644
index b4fb8b6d082..00000000000
--- a/profiles/default/bsd/packages
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
--*virtual/dev-manager
--*sys-fs/e2fsprogs
--*sys-process/procps
--*sys-process/psmisc
--*virtual/shadow
--*sys-apps/which
--*virtual/modutils
--*sys-apps/kbd
-#-*sys-apps/findutils
-#-*sys-apps/debianutils
--*sys-apps/coreutils
--*net-misc/iputils
--*app-arch/tar
diff --git a/profiles/default/bsd/parent b/profiles/default/bsd/parent
deleted file mode 100644
index 985c694a07d..00000000000
--- a/profiles/default/bsd/parent
+++ /dev/null
@@ -1 +0,0 @@
-../../base
diff --git a/profiles/default/bsd/profile.bashrc b/profiles/default/bsd/profile.bashrc
deleted file mode 100644
index bd15c469946..00000000000
--- a/profiles/default/bsd/profile.bashrc
+++ /dev/null
@@ -1,14 +0,0 @@
-if [[ ${EBUILD_PHASE} == compile ]] && [ -d "${S}" ] ; then
- if grep -q "Assume that mode_t is passed compatibly" ${S} -r --include openat.c; then
- eerror "The source code contains a faulty openat.c unit from gnulib."
- eerror "Please report this on Gentoo Bugzilla in Gentoo/Alt product for component FreeBSD."
- eerror "https://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%2FAlt&component=FreeBSD&op_sys=FreeBSD"
- die "Broken openat.c gnulib unit."
- fi
- if grep -q "\\<test .*==" "${S}" -r --include configure; then
- eerror "Found a non POSIX test construction in a configure script"
- eerror "The configure checks of this package may not function properly"
- eerror "Please report this on Gentoo Bugzilla in Gentoo/Alt product for component FreeBSD."
- eerror "https://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%2FAlt&component=FreeBSD&op_sys=FreeBSD"
- fi
-fi
diff --git a/profiles/default/bsd/use.force b/profiles/default/bsd/use.force
deleted file mode 100644
index 706719015f8..00000000000
--- a/profiles/default/bsd/use.force
+++ /dev/null
@@ -1,2 +0,0 @@
-split-usr
-userland_BSD
diff --git a/profiles/default/bsd/use.mask b/profiles/default/bsd/use.mask
deleted file mode 100644
index 76347096232..00000000000
--- a/profiles/default/bsd/use.mask
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Mart Raudsepp <leio@gentoo.org>
-# net-misc/networkmanager not keyworded
-networkmanager
-
-# ulm told me to do it!
-m17n-lib
-
-# Linux-dependant flags
-selinux
-nptl
-alsa
-v4l
-libv4l
-fbcon
-gpm
-lirc
-multilib
-lm-sensors
-caps
-filecaps
-vidix
-3dfx
-nvidia
-xvmc
-xfs
-udev
-systemd
-inotify
-aio
-
-# This usually refers just to linux-dvb
-dvb
-
-# Hardened doesn't work on Gentoo/*BSD for now
-hardened
-pax_kernel
-
-# This requires a kernel module that's Linux specific right now
-ifp
-
-# This requires a usb-eject command
-ipod
-
-# Mask extraneous elibc/kernel combinations
--userland_BSD
-elibc_glibc
-kernel_linux
-userland_GNU
-
-# mask linux touch screen access lib.
-tslib
-
-# Mask Xorg-modular drivers that are Linux-specific
-input_devices_evdev
-input_devices_synaptics
-input_devices_vmmouse
-video_cards_vmware
-video_cards_nvidia
-video_cards_nouveau
-
-# Linux only sane backends
-sane_backends_qcam
-
-# Diego E. Pettenò <flameeyes@gentoo.org> (2010-10-19)
-# unmasking flags that only apply to FreeBSD
--kqueue
diff --git a/profiles/profiles.desc b/profiles/profiles.desc
index 79d81595933..9d14fc0487b 100644
--- a/profiles/profiles.desc
+++ b/profiles/profiles.desc
@@ -205,12 +205,6 @@ x86 default/linux/x86/17.0/desktop/plasma/systemd stable
x86 default/linux/x86/17.0/developer stable
x86 default/linux/x86/17.0/systemd stable
-# Gentoo/FreeBSD Profiles
-# @MAINTAINER: bsd@gentoo.org
-amd64-fbsd default/bsd/fbsd/amd64/11.1 exp
-amd64-fbsd default/bsd/fbsd/amd64/11.1/clang exp
-x86-fbsd default/bsd/fbsd/x86/11.1 exp
-
# musl profiles
# @MAINTAINER: musl@gentoo.org
amd64 default/linux/amd64/17.0/musl exp
diff --git a/profiles/releases/freebsd-11.1/package.mask b/profiles/releases/freebsd-11.1/package.mask
deleted file mode 100644
index 7a82ed6bfdf..00000000000
--- a/profiles/releases/freebsd-11.1/package.mask
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Make sure we don't get wrong versions
-<sys-freebsd/freebsd-pam-modules-11.1_alpha
->sys-freebsd/freebsd-pam-modules-11.1.99
-<sys-freebsd/freebsd-rescue-11.1_alpha
->sys-freebsd/freebsd-rescue-11.1.99
-<sys-freebsd/freebsd-pf-11.1_alpha
->sys-freebsd/freebsd-pf-11.1.99
-<sys-freebsd/freebsd-mk-defs-11.1_alpha
->sys-freebsd/freebsd-mk-defs-11.1.99
-<sys-freebsd/freebsd-lib-11.1_alpha
->sys-freebsd/freebsd-lib-11.1.99
-<sys-freebsd/freebsd-libexec-11.1_alpha
->sys-freebsd/freebsd-libexec-11.1.99
-<sys-freebsd/freebsd-bin-11.1_alpha
->sys-freebsd/freebsd-bin-11.1.99
-<sys-freebsd/freebsd-sbin-11.1_alpha
->sys-freebsd/freebsd-sbin-11.1.99
-<sys-freebsd/freebsd-ubin-11.1_alpha
->sys-freebsd/freebsd-ubin-11.1.99
-<sys-freebsd/freebsd-usbin-11.1_alpha
->sys-freebsd/freebsd-usbin-11.1.99
-<sys-freebsd/freebsd-share-11.1_alpha
->sys-freebsd/freebsd-share-11.1.99
-<sys-freebsd/freebsd-cddl-11.1_alpha
->sys-freebsd/freebsd-cddl-11.1.99
-<sys-freebsd/boot0-11.1_alpha
->sys-freebsd/boot0-11.1.99
-<sys-freebsd/freebsd-sources-11.1_alpha
->sys-freebsd/freebsd-sources-11.1.99
-
-# Alexis Ballier <aballier@gentoo.org> (2012-05-11)
-# freebsd-lib provides a utempter compatible interface starting from FreeBSD 9.0
-# via libulog.
-# this package does not build anymore as it requires utmp
-sys-libs/libutempter
diff --git a/profiles/releases/freebsd-11.1/package.use.mask b/profiles/releases/freebsd-11.1/package.use.mask
deleted file mode 100644
index 5e68f049c93..00000000000
--- a/profiles/releases/freebsd-11.1/package.use.mask
+++ /dev/null
@@ -1,9 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Brian Evans <grknight@gentoo.org> (2018-01-15)
-# Mask innodb-snappy as app-arch/snappy is untested
-# Mask innodb-lz4 as app-arch/lz4 is untested
-# Mask oqgraph as dev-libs/judy is untested
-# Mask numa as sys-process-numactl is untested
-dev-db/mariadb innodb-snappy innodb-lz4 oqgraph numa
diff --git a/profiles/releases/freebsd-11.1/packages b/profiles/releases/freebsd-11.1/packages
deleted file mode 100644
index 2f2822721a6..00000000000
--- a/profiles/releases/freebsd-11.1/packages
+++ /dev/null
@@ -1,11 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-*>=sys-apps/baselayout-2.0.0
-*>=sys-apps/openrc-0.2.5
-
-# dev-libs/libiconv isn't necessary in 10.0 and later.
--*dev-libs/libiconv
-
-# sys-freebsd/freebsd-libexec was merged into freebsd-lib in 11.1 and later.
--*sys-freebsd/freebsd-libexec
diff --git a/profiles/releases/freebsd-11.1/packages.build b/profiles/releases/freebsd-11.1/packages.build
deleted file mode 100644
index eb15f165044..00000000000
--- a/profiles/releases/freebsd-11.1/packages.build
+++ /dev/null
@@ -1,6 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
--dev-libs/libiconv
--sys-freebsd/freebsd-libexec
-sys-freebsd/freebsd-share
diff --git a/profiles/releases/freebsd-11.1/parent b/profiles/releases/freebsd-11.1/parent
deleted file mode 100644
index f3229c5b987..00000000000
--- a/profiles/releases/freebsd-11.1/parent
+++ /dev/null
@@ -1 +0,0 @@
-..
diff --git a/profiles/releases/freebsd-11.1/profile.bashrc b/profiles/releases/freebsd-11.1/profile.bashrc
deleted file mode 100644
index 8987e6d324f..00000000000
--- a/profiles/releases/freebsd-11.1/profile.bashrc
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-bsd-fbsd10fix(){
- # http://svnweb.freebsd.org/ports/head/Mk/bsd.port.mk
-
- for f in `find ${WORKDIR} -type f \( -name config.libpath -o \
- -name config.rpath -o -name configure -o -name libtool.m4 -o \
- -name ltconfig -o -name libtool -o -name aclocal.m4 -o \
- -name acinclude.m4 \)` ; do \
- sed -i.fbsd10bak \
- -e 's|freebsd1\*)|freebsd1.\*)|g' \
- -e 's|freebsd\[12\]\*)|freebsd[12].*)|g' \
- -e 's|freebsd\[123\]\*)|freebsd[123].*)|g' \
- -e 's|freebsd\[\[12\]\]\*)|freebsd[[12]].*)|g' \
- -e 's|freebsd\[\[123\]\]\*)|freebsd[[123]].*)|g' \
- ${f} ; \
- touch -mr ${f}.fbsd10bak ${f} ; \
- rm -f ${f}.fbsd10bak ; \
- einfo "===> FreeBSD 10 autotools fix applied to ${f}"; \
- done
-}
-
-if [[ -n $EAPI ]] ; then
- case "$EAPI" in
- 0|1)
- post_src_unpack() { bsd-patch_install-sh ; bsd-fbsd10fix ; }
- ;;
- *)
- post_src_prepare() { bsd-patch_install-sh ; bsd-fbsd10fix ; }
- ;;
- esac
-fi
diff --git a/profiles/releases/freebsd-11.1/use.mask b/profiles/releases/freebsd-11.1/use.mask
deleted file mode 100644
index 57b5cd349fa..00000000000
--- a/profiles/releases/freebsd-11.1/use.mask
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation.
-# Distributed under the terms of the GNU General Public License, v2
-
-# Brian Evans <grknight@gentoo.org> (2018-01-15)
-# Mask dev-util/systemtap is untested
-systemtap
-
-# Brian Evans <grknight@gentoo.org> (2018-01-15)
-# Mask dev-libs/jemalloc is untested
-jemalloc
-
-# Brian Evans <grknight@gentoo.org> (2018-01-15)
-# Mask dev-libs/libressl is untested
-libressl