summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-03-30 21:13:23 +0800
committerJason Zaman <perfinion@gentoo.org>2019-04-05 23:38:25 +0800
commita3ab781fefeacbaf5f48b945d7d5e25baba1ed52 (patch)
tree7b52869cafa762ca12fdfd0f28cf83f23c24c298
parentdev-lang/php: Drop old patches relocated to an archive (diff)
downloadgentoo-a3ab781fefeacbaf5f48b945d7d5e25baba1ed52.tar.gz
gentoo-a3ab781fefeacbaf5f48b945d7d5e25baba1ed52.tar.bz2
gentoo-a3ab781fefeacbaf5f48b945d7d5e25baba1ed52.zip
sci-visualization/tensorboard: bump 1.13.1
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-1.13.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 30d02832f763..8f01fa17b2dd 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -2,3 +2,4 @@ DIST tensorboard-1.10.0.zip 3280385 BLAKE2B b4e9f6d4fc6252b57f31e8514516205c8f81
DIST tensorboard-1.11.0.zip 3027414 BLAKE2B 5a0c325755551d5dfea98cc96cfa5ee0a8c9d39c2e7bcf8139daea54dcc89e5004de0dd90069e626264e11633acc283055ee3e73654b3d883418e07eef6f0f08 SHA512 d3948143a883ed6c6353cfab945814ff4ef21833b38875f003ef375d1e3a63dd65fce49ef80b2eec5827c46ffb6a82f8464f2b0e7d4af348ad8ba51ce4829426
DIST tensorboard-1.12.1.zip 3046273 BLAKE2B 13d49cc9ed194c629943942b95c7a084220ce5f7ac2faaf5c010f8c4b71412144528feb58b2b67cae0d342f6a41e078c0fdffa45fdf526ec93b39ad204242c7c SHA512 b739f387c27a609d3064f7f7a162780d8807f4f9f6b95401f088bc7d6a1763613148056472c8b24b0941d562bb14bb323a82a248deb416ec5fba27fc25d7e62f
DIST tensorboard-1.12.2.zip 3046421 BLAKE2B a43d2b10845364deac5742652bbae6edb6c87400ea45f03acf5ea2a7363f7687911c14a4d23631d329aec017ecac0d42ccda5501f1061f7835acadfc1ba2b377 SHA512 41b8fbd4b0e015931929cd701986c655785221debec3041638d807f412b73d46fbf1c9ad01cb20dbbe9bb8886f9e2e2439afa724f156fcea5bd35e74e278ac9b
+DIST tensorboard-1.13.1.zip 3187614 BLAKE2B e1b8cb43f7941b843e4fa8c84746f4b341e7c7e246422182eec9e1d3e2a5c367fb818c8e3ddd20cb6b5f64515a986dc5e814728340f0592d346dc55ec6065648 SHA512 d1581b7f694909e94a09d4c3fb2d34ddc31a18a6a09323ef48221e88560a9ec3bbb050ff12a2cd78607a2545053cabc448eab7264036a54dddc4720becfc44b3
diff --git a/sci-visualization/tensorboard/tensorboard-1.13.1.ebuild b/sci-visualization/tensorboard/tensorboard-1.13.1.ebuild
new file mode 100644
index 000000000000..c5f7d80d69d2
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-1.13.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Jason Zaman
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-r1 python-utils-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/0f/39/bdd75b08a6fba41f098b6cb091b9e8c7a80e1b4d679a581a0ccd17b10373/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}