summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-03 02:35:25 +0100
committerSam James <sam@gentoo.org>2022-05-03 02:35:25 +0100
commita407f2465ab6b6df4294b0cedebf5d527a3c997e (patch)
treeacdc4721674d22be7579286d09fe00a1eab7be98
parentapp-text/scdoc: add 1.11.2 (diff)
downloadgentoo-a407f2465ab6b6df4294b0cedebf5d527a3c997e.tar.gz
gentoo-a407f2465ab6b6df4294b0cedebf5d527a3c997e.tar.bz2
gentoo-a407f2465ab6b6df4294b0cedebf5d527a3c997e.zip
dev-util/diffoscope: add 211
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/diffoscope/Manifest1
-rw-r--r--dev-util/diffoscope/diffoscope-211.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index b61173cac6a1..892c256e09ac 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,2 +1,3 @@
DIST diffoscope-207.tar.gz 2707223 BLAKE2B e20f21c9e0acc78cadfce082f874b3e3cbbbd26cfa5041012eb07a347f177724506d1263b6636c71c5304993e52b81e8ac1fa82ee7231d892346ede2d00de37f SHA512 ebbcf3e7e41f042626f2d175cea027392fc52f65dd11ded8e2a65ed3d58129fe4948e6129c2aec74d58d8f6b58855ada23be8231b426a9473b165eba0f182955
DIST diffoscope-210.tar.gz 2709384 BLAKE2B 86b88dacf1d777bc63f7698197bc26abe638a25857fa43eac48051b91c07699d7beb9c0ac6bef6baf23fda895a07ca69342c9469a1853a38276f93fac11ea8fa SHA512 b0bd05ffb6112f5f6cdd7f9567ecbbda286226cc6874dfdded39b5d7221d2dbab4b01f02741f7e10a219bf03f94bc803c651963deebb67308a134b8e97fb3b05
+DIST diffoscope-211.tar.gz 2709392 BLAKE2B c3570f88bcca7193a9650d970f2d943ebe33cc428c5ce3d4c5812588cbb57ae83dd795674e364d5acbb2d1504bd218036a6b04d9431786668386f28bdd6939b7 SHA512 8d674f41e955bd7537ba0cf7df0c886ff87b017a7d756246a183d9ec5ac3b286a798d60d29aadda550de6838b264a9e27fb37cf472b6e93caab7fce2fb65a1b1
diff --git a/dev-util/diffoscope/diffoscope-211.ebuild b/dev-util/diffoscope/diffoscope-211.ebuild
new file mode 100644
index 000000000000..46f6608598b5
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-211.ebuild
@@ -0,0 +1,108 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+)
+
+distutils_enable_tests pytest