summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-09 22:07:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-11 12:57:33 +0100
commita430106ef87cdbffc6cefbc1ac1a8e5bb3ea6242 (patch)
treefba60096bae382ddce072c3a129965fe1c057b72
parentgnome-extra/gnome-color-manager: Fix build with exiv2-0.27 (diff)
downloadgentoo-a430106e.tar.gz
gentoo-a430106e.tar.bz2
gentoo-a430106e.zip
media-gfx/gthumb: Fix build with exiv2-0.27
Using exiv2.hpp instead of individual includes is exiv2 recommendation for some time already while the headers are subject to refactoring. Standard fix as seen in other affected packages. Closes: https://bugs.gentoo.org/674092 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/gthumb/files/gthumb-3.6.2-exiv2-0.27.patch31
-rw-r--r--media-gfx/gthumb/gthumb-3.6.2.ebuild4
2 files changed, 34 insertions, 1 deletions
diff --git a/media-gfx/gthumb/files/gthumb-3.6.2-exiv2-0.27.patch b/media-gfx/gthumb/files/gthumb-3.6.2-exiv2-0.27.patch
new file mode 100644
index 000000000000..2bd8b94c3c11
--- /dev/null
+++ b/media-gfx/gthumb/files/gthumb-3.6.2-exiv2-0.27.patch
@@ -0,0 +1,31 @@
+Patch kindly borrowed from Mageia.
+
+* asturm@gentoo.org: Dropped unnecessary and backwards incompatible
+xmp_exiv2.hpp include.
+
+https://gitlab.gnome.org/GNOME/gthumb/issues/30
+
+diff -Nru a/extensions/exiv2_tools/exiv2-utils.cpp b/extensions/exiv2_tools/exiv2-utils.cpp
+--- a/extensions/exiv2_tools/exiv2-utils.cpp 2018-06-17 08:24:44.000000000 +0200
++++ b/extensions/exiv2_tools/exiv2-utils.cpp 2018-12-31 15:51:50.912329232 +0100
+@@ -32,7 +32,7 @@
+ #include <sstream>
+ #include <vector>
+ #include <iomanip>
+-#include <exiv2/xmp.hpp>
++#include <exiv2/exiv2.hpp>
+ #include <gthumb.h>
+ #include "exiv2-utils.h"
+
+@@ -1073,7 +1073,11 @@
+
+ try {
+ if (exifData.empty()) {
++#if EXIV2_TEST_VERSION(0,27,0)
++ throw Exiv2::Error(Exiv2::kerErrorMessage, " No Exif data found in the file");
++#else
+ throw Exiv2::Error(1, " No Exif data found in the file");
++#endif
+ }
+ Exiv2::ExifData::const_iterator end = exifData.end();
+ for (Exiv2::ExifData::const_iterator i = exifData.begin(); i != end; ++i) {
diff --git a/media-gfx/gthumb/gthumb-3.6.2.ebuild b/media-gfx/gthumb/gthumb-3.6.2.ebuild
index 1eab1eda6c7d..fa3de15b5f1b 100644
--- a/media-gfx/gthumb/gthumb-3.6.2.ebuild
+++ b/media-gfx/gthumb/gthumb-3.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,6 +54,8 @@ DEPEND="${RDEPEND}
# eautoreconf needs:
# gnome-base/gnome-common
+PATCHES=( "${FILESDIR}/${P}-exiv2-0.27.patch" ) # bug 674092
+
src_prepare() {
# Remove unwanted CFLAGS added with USE=debug
sed -e 's/CFLAGS="$CFLAGS -g -O0 -DDEBUG"//' \