summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-19 09:05:49 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-19 09:59:44 +0100
commita476d3a3c302a6c0c8beaf77dd2d22dde439e6b5 (patch)
treeb7148fe432011a4cdf37d79de811d41935eb14c5
parentdev-python/msgpack: Bump to 1.0.2 (diff)
downloadgentoo-a476d3a3c302a6c0c8beaf77dd2d22dde439e6b5.tar.gz
gentoo-a476d3a3c302a6c0c8beaf77dd2d22dde439e6b5.tar.bz2
gentoo-a476d3a3c302a6c0c8beaf77dd2d22dde439e6b5.zip
dev-python/watchdog: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-1.0.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index 85ac3c02f1c3..8298977c347a 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -3,3 +3,4 @@ DIST watchdog-0.10.4.tar.gz 90303 BLAKE2B 0c057fe35383deaa6b7a66c24c07b2260153e9
DIST watchdog-0.10.5.tar.gz 91432 BLAKE2B 0f10a94edf4cb79d68b83f0cc6eebc1eae9a00a0fd7b8164977a2511b952b6dda9d0b26404ef316a57524f948eb6676a5da65bb711530f64a4a37ab82576b9a9 SHA512 b107fe23b123360ba8ad049576bdbbb40061c70157bee0663bcf9ee9a9a9f65b95234540a477ba9ae6d617199ca1d77fe30b3b9dc4868bfef08a6b9099d6fe51
DIST watchdog-0.8.3.tar.gz 83154 BLAKE2B d5d0635e83bbcd31544d5ea5811c2f202b0da76bd7a4086e8fc61e3293640e701b04599f95decaa82bee3705dbd6b91ad24b9dbd20edcfc329913600c8a3c932 SHA512 61f1db886e8e9a6d78b569329f4d5944c296778a5a34f94fbf115a748fb4c3be422bf4d3cc828e22fcdcd380fdf9009f5bd91a8a5edc87089afc58297a0b946f
DIST watchdog-1.0.0.tar.gz 89861 BLAKE2B 79734397fc91e3c733fd28e8c607c07265230f8e7949b07e4236e4fe38af48cd0f758270990b384ccee88bc88311291cc3758f29296edda2dff06dc757d6d492 SHA512 e89f34aba7547022a48ff16e36e6a2eea340e80a4b1e1f8657d4e70d4a451ac43351aafc76978fb4241c583df11c2dd6c53cb1a03c43c2734f4a8a07d5b2604f
+DIST watchdog-1.0.2.tar.gz 91796 BLAKE2B 001cbe82ff8aff0c4e56e4d1f02519047580cccb48466566ad7c9c1f462f90a9a036cf90846eb38ec4fb24ff1df2a1ddfec20b3f0587afdc1f938ada1bb0b1ef SHA512 e87a0955ce822daabd7d030804876698f98ed2aad58486e26a94585763655302063f091b653abd385ea99642361b6253d8e051d96019b243a77b078ba86b0d6e
diff --git a/dev-python/watchdog/watchdog-1.0.2.ebuild b/dev-python/watchdog/watchdog-1.0.2.ebuild
new file mode 100644
index 000000000000..fd006a578472
--- /dev/null
+++ b/dev-python/watchdog/watchdog-1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ # broken when django is installed
+ sed -i -e 's:test_eventlet_monkey_patching:_&:' \
+ tests/test_skip_repeats_queue.py || die
+ default
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}