summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 08:55:25 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 09:53:12 +0200
commita5350b9a4884eb26068d25846f1efd28805077f4 (patch)
tree15ee1dfff506a24f0dadc6e0edf3ccf61478a99c
parentdev-python/humanfriendly: Drop old (diff)
downloadgentoo-a5350b9a4884eb26068d25846f1efd28805077f4.tar.gz
gentoo-a5350b9a4884eb26068d25846f1efd28805077f4.tar.bz2
gentoo-a5350b9a4884eb26068d25846f1efd28805077f4.zip
dev-python/humanfriendly: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/humanfriendly/Manifest1
-rw-r--r--dev-python/humanfriendly/humanfriendly-1.35.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/Manifest b/dev-python/humanfriendly/Manifest
index 52ba2e2169cb..01b049030a09 100644
--- a/dev-python/humanfriendly/Manifest
+++ b/dev-python/humanfriendly/Manifest
@@ -1 +1,2 @@
DIST humanfriendly-1.33.tar.gz 34362 SHA256 158259d5cb9b762fb094a3cbbade70b5e623568b92c3765d1914fa87f5bf4ecc SHA512 878dc081b15df2f1d682697b9abde45ea20aebd4a33bd7079af7eb3c86b331ad2135b7153b6727ddadbc2146fe042d5a860aaab4889a637622636d4118179bf5 WHIRLPOOL c57a7404341cff1eca80069e35350b99ddf3c26b68894ab283d39ad4dd80fbd2014f04a8dfdb040aae432c4b2ed9bdc51f0085d743575c78eddcc9985cf3cbed
+DIST humanfriendly-1.35.tar.gz 36181 SHA256 de030bb1976b526f514c9a953c38286f50c3ece01180a1efdda56f091eb33164 SHA512 3cec8629423f640b2b6bdcf95aa8346daf88268b3d7e9ce44be395f7e9f3aa1a23d27d422db3bfda32e1e6c2c6a2eaf8dc1393ef6fcea4895ef6b44671353d0d WHIRLPOOL c44a897a81b2044a9d6913fb1d74d6979534d00cce486035b23facbc5595532996cb19c8b34cd7768381e67ff277b6ed02c034341958f4eff63940136cecaf27
diff --git a/dev-python/humanfriendly/humanfriendly-1.35.ebuild b/dev-python/humanfriendly/humanfriendly-1.35.ebuild
new file mode 100644
index 000000000000..34fa7dd29e0a
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-1.35.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.python.org/pypi/humanfriendly https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die
+}