summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-04 21:03:18 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-04 21:04:17 +1200
commita53cdcc14f27668a5563b956fa595ceae474a801 (patch)
tree0f58e8636f881db49444f1b457abd1db16e41a8c
parentdev-perl/Type-Tie: Add w/ version 0.9.0 (diff)
downloadgentoo-a53cdcc14f27668a5563b956fa595ceae474a801.tar.gz
gentoo-a53cdcc14f27668a5563b956fa595ceae474a801.tar.bz2
gentoo-a53cdcc14f27668a5563b956fa595ceae474a801.zip
dev-perl/Type-Tiny: Bump to version 1.2.0
- EAPI6 - Tests enabled w/ parallel! - Add USE="exmaples" - Add all recommended deps that are used somewhere internally Upstream: - Fix escaping within q{} in tests - Add functions compile_named, validate_named to Type::Params - Can use Sub::Util when available - Better fallback for Utils::dwim_type - Lazy-load dependencies - Optimized HashRef,ArrayRef,ScalarRef,Map,Tuple and StrMatch constraints - Inlined ::Int check checks value isn't a reference - ArrayRef[ Int, Int ] and similar now an exception - Improved error location reporting for Moo - NumericCode can coerce strings with whitespace - constraint parameters can be strings of perl code - localise sig-die in Type::Registry - Tuple[Int] and similar no longer report having coercions of nested type lacks coercions - New CycleTuple type - RegexpRef now accepts blessed objects if $object->isa('Regexp') - Support for StrMatch regexp inlining via Regexp::Util - Include trailing \n at end of stringified exceptions Keywording: - New dependencies, dropping keywords for: hppa, ppc Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-perl/Type-Tiny/Manifest1
-rw-r--r--dev-perl/Type-Tiny/Type-Tiny-1.2.0.ebuild39
-rw-r--r--dev-perl/Type-Tiny/metadata.xml38
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/Type-Tiny/Manifest b/dev-perl/Type-Tiny/Manifest
index cf35564ee3bb..60fb1aa33d91 100644
--- a/dev-perl/Type-Tiny/Manifest
+++ b/dev-perl/Type-Tiny/Manifest
@@ -1 +1,2 @@
DIST Type-Tiny-1.000005.tar.gz 249419 SHA256 42ed36c011825aa1e6995a4e8638621a1b2103a0970b15764ca3919368042365 SHA512 5817ee937384cccbea71fa69f8c2202d721c648a18eedf089529fbb956b2d050b889606e69c8bc3e1d94fb6f638b6cac01394b5534f17a8be6cdf82d69b965b6 WHIRLPOOL 8ac0914d07fbc186c3dcc2cdb7cc9f6288a940818958a148d6ed898849f5e4456d34fa7cd29bdd5315a1f941b2ce0e74a0f2ab9f0d15c7216ec0481a9bf88774
+DIST Type-Tiny-1.002000.tar.gz 264748 SHA256 f37d6d6656b4f8df7b595a253e44b234fe4cd0f3eabf0528067d6651993f4bca SHA512 da9e150011f898bd2af2adafb12124505b651f7b41e4cd9177bcf8e4148f7a7732014292f9f2099bc0b2582f4ee1809009cabe74df8002d182eceb855f6d446a WHIRLPOOL 1c279846cfb650a76e02a1f9108117d3997654f1a79775dd9448fde36e5a494cbcddd7964774e4e338032b9a1b466b0552c4011168e470f2d4a4110ba8b7f490
diff --git a/dev-perl/Type-Tiny/Type-Tiny-1.2.0.ebuild b/dev-perl/Type-Tiny/Type-Tiny-1.2.0.ebuild
new file mode 100644
index 000000000000..f32e44b2d09e
--- /dev/null
+++ b/dev-perl/Type-Tiny/Type-Tiny-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TOBYINK
+DIST_VERSION=1.002000
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="tiny, yet Moo(se)-compatible type constraint"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+# Test rdep for Test::TypeTiny
+RDEPEND="
+ !<dev-perl/Kavorka-0.13.0
+ !<dev-perl/Types-ReadOnly-0.1.0
+ >=dev-perl/Exporter-Tiny-0.26.0
+ >=virtual/perl-Test-Simple-1.1.10
+ !minimal? (
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/Devel-StackTrace
+ >=dev-perl/Ref-Util-XS-0.116.0
+ >=dev-perl/Regexp-Util-0.3.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Type-Tie
+ >=dev-perl/Type-Tiny-XS-0.11.0
+ )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ >=virtual/perl-CPAN-Meta-Requirements-2.0.0
+ test? (
+ dev-perl/Test-Warnings
+ )
+"
diff --git a/dev-perl/Type-Tiny/metadata.xml b/dev-perl/Type-Tiny/metadata.xml
index 2b9a936fc0a1..3f0cbb681fdf 100644
--- a/dev-perl/Type-Tiny/metadata.xml
+++ b/dev-perl/Type-Tiny/metadata.xml
@@ -5,4 +5,42 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="cpan">Type-Tiny</remote-id>
+ <remote-id type="cpan-module">Devel::TypeTiny::Perl56Compat</remote-id>
+ <remote-id type="cpan-module">Devel::TypeTiny::Perl58Compat</remote-id>
+ <remote-id type="cpan-module">Error::TypeTiny</remote-id>
+ <remote-id type="cpan-module">Error::TypeTiny::Assertion</remote-id>
+ <remote-id type="cpan-module">Error::TypeTiny::Compilation</remote-id>
+ <remote-id type="cpan-module">Error::TypeTiny::WrongNumberOfParameters</remote-id>
+ <remote-id type="cpan-module">Eval::TypeTiny</remote-id>
+ <remote-id type="cpan-module">Reply::Plugin::TypeTiny</remote-id>
+ <remote-id type="cpan-module">Test::TypeTiny</remote-id>
+ <remote-id type="cpan-module">Type::Coercion</remote-id>
+ <remote-id type="cpan-module">Type::Coercion::FromMoose</remote-id>
+ <remote-id type="cpan-module">Type::Coercion::Union</remote-id>
+ <remote-id type="cpan-module">Type::Library</remote-id>
+ <remote-id type="cpan-module">Type::Params</remote-id>
+ <remote-id type="cpan-module">Type::Parser</remote-id>
+ <remote-id type="cpan-module">Type::Registry</remote-id>
+ <remote-id type="cpan-module">Type::Tiny</remote-id>
+ <remote-id type="cpan-module">Type::Tiny::Class</remote-id>
+ <remote-id type="cpan-module">Type::Tiny::Duck</remote-id>
+ <remote-id type="cpan-module">Type::Tiny::Enum</remote-id>
+ <remote-id type="cpan-module">Type::Tiny::Intersection</remote-id>
+ <remote-id type="cpan-module">Type::Tiny::Role</remote-id>
+ <remote-id type="cpan-module">Type::Tiny::Union</remote-id>
+ <remote-id type="cpan-module">Type::Utils</remote-id>
+ <remote-id type="cpan-module">Types::Common::Numeric</remote-id>
+ <remote-id type="cpan-module">Types::Common::String</remote-id>
+ <remote-id type="cpan-module">Types::Standard</remote-id>
+ <remote-id type="cpan-module">Types::Standard::ArrayRef</remote-id>
+ <remote-id type="cpan-module">Types::Standard::CycleTuple</remote-id>
+ <remote-id type="cpan-module">Types::Standard::Dict</remote-id>
+ <remote-id type="cpan-module">Types::Standard::HashRef</remote-id>
+ <remote-id type="cpan-module">Types::Standard::Map</remote-id>
+ <remote-id type="cpan-module">Types::Standard::ScalarRef</remote-id>
+ <remote-id type="cpan-module">Types::Standard::Tuple</remote-id>
+ <remote-id type="cpan-module">Types::TypeTiny</remote-id>
+ </upstream>
</pkgmetadata>