summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 10:35:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 11:04:21 +0100
commita549739c8933dcb469d0a986e3e3cff0cc9692b0 (patch)
treeb8efc183ba5e2ff7a428b876ecb0eee6185c2096
parentdev-python/python-gflags: Switch to PEP 517 build (diff)
downloadgentoo-a549739c.tar.gz
gentoo-a549739c.tar.bz2
gentoo-a549739c.zip
dev-python/python-lzo: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-lzo/python-lzo-1.14-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-lzo/python-lzo-1.14-r1.ebuild b/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
new file mode 100644
index 000000000000..73aa90f9490d
--- /dev/null
+++ b/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 prefix
+
+DESCRIPTION="Python interface to lzo"
+HOMEPAGE="https://github.com/jd-boyd/python-lzo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-libs/lzo:2"
+DEPEND="${RDEPEND}"
+
+# We can't use pytest at the moment because the package uses "yield tests"
+# https://docs.pytest.org/en/6.2.x/deprecations.html#yield-tests
+distutils_enable_tests nose
+
+python_prepare_all() {
+ hprefixify setup.py
+ distutils-r1_python_prepare_all
+}