summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-29 12:04:45 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-29 12:07:57 -0700
commita5a91b5dc7b24a8ddf2d295e796aeffb0d85b3ed (patch)
tree1ec02301b7af9443158cde219f2136fe28a1834f
parent../amd64/no-multilib/use.mask: unmask hvm useflag for Xen (diff)
downloadgentoo-a5a91b5dc7b24a8ddf2d295e796aeffb0d85b3ed.tar.gz
gentoo-a5a91b5dc7b24a8ddf2d295e796aeffb0d85b3ed.tar.bz2
gentoo-a5a91b5dc7b24a8ddf2d295e796aeffb0d85b3ed.zip
media-libs/libepoxy: RDEPEND on media-libs/mesa
The .pc file installed by libepoxy says it requires gl, which is installed by Mesa. Closes: https://bugs.gentoo.org/610608
-rw-r--r--media-libs/libepoxy/libepoxy-1.5.2.ebuild4
-rw-r--r--media-libs/libepoxy/libepoxy-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/libepoxy/libepoxy-1.5.2.ebuild b/media-libs/libepoxy/libepoxy-1.5.2.ebuild
index 21db4db9f63..25f715c61c3 100644
--- a/media-libs/libepoxy/libepoxy-1.5.2.ebuild
+++ b/media-libs/libepoxy/libepoxy-1.5.2.ebuild
@@ -26,11 +26,11 @@ LICENSE="MIT"
SLOT="0"
IUSE="test +X"
+RDEPEND="media-libs/mesa[egl,${MULTILIB_USEDEP}]"
DEPEND="${PYTHON_DEPS}
- media-libs/mesa[egl,${MULTILIB_USEDEP}]
+ ${RDEPEND}
X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
>=dev-util/meson-0.44.0"
-RDEPEND=""
src_unpack() {
default
diff --git a/media-libs/libepoxy/libepoxy-9999.ebuild b/media-libs/libepoxy/libepoxy-9999.ebuild
index 17eb5ee20a7..5810d7944cc 100644
--- a/media-libs/libepoxy/libepoxy-9999.ebuild
+++ b/media-libs/libepoxy/libepoxy-9999.ebuild
@@ -26,11 +26,11 @@ LICENSE="MIT"
SLOT="0"
IUSE="test +X"
+RDEPEND="media-libs/mesa[egl,${MULTILIB_USEDEP}]"
DEPEND="${PYTHON_DEPS}
- media-libs/mesa[egl,${MULTILIB_USEDEP}]
+ ${RDEPEND}
X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
>=dev-util/meson-0.44.0"
-RDEPEND=""
src_unpack() {
default