summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 04:30:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 05:14:21 +0200
commita5c2c0654a93de9ed60d2f6e83f0b37a6cee3338 (patch)
treee410c073d4448a19f6c9797799992775335b86f9
parentdev-python/botocore: Bump to 1.29.110 (diff)
downloadgentoo-a5c2c0654a93de9ed60d2f6e83f0b37a6cee3338.tar.gz
gentoo-a5c2c0654a93de9ed60d2f6e83f0b37a6cee3338.tar.bz2
gentoo-a5c2c0654a93de9ed60d2f6e83f0b37a6cee3338.zip
dev-python/boto3: Bump to 1.26.110
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.110.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 27bd266bef90..132ac8ac8eec 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,4 +3,5 @@ DIST boto3-1.26.106.gh.tar.gz 631950 BLAKE2B a8c9a0f1450a743953ebc26c75bef7ca1a5
DIST boto3-1.26.107.gh.tar.gz 632507 BLAKE2B 8331a8e925a390f56af023b49b45df307bd6077fdc24138686acc87b17a5afa15fdd9db2aa8611d745d7682946e3ff94a46d570f4a37edb847eb90b2c6ad0cd2 SHA512 53ca758026eb2952a290c8eee84ed3b3399ebb893fd8cc0ea7a7c9d1f9166810882e326bafc41c67b4183616f953ae2bdd5c91275e2c157f79c6414256f38d0f
DIST boto3-1.26.108.gh.tar.gz 632927 BLAKE2B 836bfda9d5cab0ccd89903f98acab2dc2f13c7ed392c7fe86a13e8410a4152ca57fabf529e3d02c4591906b76e026a9813a6d892c5db8f32fd55dc27b9cecb1f SHA512 9e003e1f7d396a352cf50dff1c83ca8db40b73165880371b10ddbeafced59cdf255a9f3aa3b395347fde8471ee149cb9191280104fdec71baf7975710a356640
DIST boto3-1.26.109.gh.tar.gz 635150 BLAKE2B d60417a5220eb1cd4a82e9652a0c6bc2bdb57749589c3596506e24e6d7f884fa4b8d480dad68dd34af0f0d71e970b43704b458cb2c8a750d81b66bc9a5123044 SHA512 6cd89835d69be9a5e87cd7f35ada43972681658eb7d1cefe3c98402690fd46360b4c0e48ca2d771b18cdce2097f985a42474ec92ab55b53eb24c671eebffe75e
+DIST boto3-1.26.110.gh.tar.gz 635889 BLAKE2B 287bf483337e2e3944474e49b18aaf74871fb82e8280792fcf6e2576febab9a0855d522a791ebce16da772d98fe9278158fe5da342cc78e6954b74610446b5ca SHA512 de3f6664ccbd6105d05f5e4dd7b8dfe3f7a496e7ca3dd0e6722f65f1e9aa36ea0d945679b1fe245b6d2e21426ce1308851100012dbd150d45e57aacded7dbfb5
DIST boto3-1.26.99.gh.tar.gz 625932 BLAKE2B 961a640995abdafbf2cd73f83ed5af0e1314cebbc5dc154771204e7c16532ad4a84aed08cbd7789af30de518bf2e8bd5204e9a540a2d3a08e75222c2eeb9a68a SHA512 ff726483a83a11a8c088905998af0a1a791e87503b39422811d82b3122275a24eb955636407422af7552908eee22d4c1369779a7798f09f958a8af5234c0c11d
diff --git a/dev-python/boto3/boto3-1.26.110.ebuild b/dev-python/boto3/boto3-1.26.110.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.110.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}