summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-28 08:40:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-28 09:08:59 +0200
commita63bac8bb1e102ba3080c319d778d7fa97f99325 (patch)
tree860646960f210d704ff208684508480c0adb3631
parentdev-python/tomlkit: Bump to 0.11.6 (diff)
downloadgentoo-a63bac8bb1e102ba3080c319d778d7fa97f99325.tar.gz
gentoo-a63bac8bb1e102ba3080c319d778d7fa97f99325.tar.bz2
gentoo-a63bac8bb1e102ba3080c319d778d7fa97f99325.zip
dev-python/exceptiongroup: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/exceptiongroup/Manifest1
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index 4487b819155f..2d9efab93073 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,2 +1,3 @@
+DIST exceptiongroup-1.0.0.gh.tar.gz 19766 BLAKE2B 2c4aa2c7c096b91971872b2236fad211a1bd7cb8ae921f5a0255b5a534eefdb5033bbca4c562ff7045acf30e13371a38d52851749cd5bca4df6adfe359a43012 SHA512 e2e05066c0c7664bb36696737c0c33abd811637c5f0ae7e70a20525283d4db4667fa814b15cb6b21165416ae1a0c47f22250a2ed9be4be99b6237e0c1b45fdd4
DIST exceptiongroup-1.0.0rc8.gh.tar.gz 17562 BLAKE2B 617e174e32f4c062f576b12c9dfe96e5495003097dc0da82e383019a65b2a043546d4b73181081defb641d453127e056be52e55e76fdf0ec0247513f5eb211ff SHA512 f7f1700403f345755a1e32c77eb43744b366b1f55446e1898dd960988d23396ad8334bef072ecc7ec5ac7075300f0f3e8e9a0d454d9dd80677ae55b4166fc6e4
DIST exceptiongroup-1.0.0rc9.gh.tar.gz 19109 BLAKE2B b4a4c127909908aa2d9fb2bfff0f0ae6c6b9be88046a680b6b206164b0ec0d6bc325ec65ce3e61df2270e6b0397ff5f7f11c219a62dc4a3534b1564da64935b3 SHA512 43f0f7338f5e09d45a5b4e1723ecab6dcd1872a387eaf8483961b86db5f1b7c265798538726ec9f2d0d6bd289ff3124883f5095dd7f04fd9b64c9230ce454098
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild
new file mode 100644
index 000000000000..b848cb3eea31
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}