summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-04-10 17:57:09 +0200
committerDavid Seifert <soap@gentoo.org>2022-04-10 17:57:09 +0200
commita6e84758d0d3e686cdde1d411beddb42cb9b03a5 (patch)
treebcd732aaaa6cfe0bf8e065342644edaf6fd8ac52
parentx11-libs/gnome-pty-helper: update EAPI 5 -> 8 (diff)
downloadgentoo-a6e84758d0d3e686cdde1d411beddb42cb9b03a5.tar.gz
gentoo-a6e84758d0d3e686cdde1d411beddb42cb9b03a5.tar.bz2
gentoo-a6e84758d0d3e686cdde1d411beddb42cb9b03a5.zip
net-libs/telepathy-farstream: update EAPI 5 -> 8
Closes: https://bugs.gentoo.org/835363 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-libs/telepathy-farstream/telepathy-farstream-0.6.2-r1.ebuild (renamed from net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild)8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild b/net-libs/telepathy-farstream/telepathy-farstream-0.6.2-r1.ebuild
index a858d56f3f30..1801446994da 100644
--- a/net-libs/telepathy-farstream/telepathy-farstream-0.6.2.ebuild
+++ b/net-libs/telepathy-farstream/telepathy-farstream-0.6.2-r1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-GCONF_DEBUG="no"
+EAPI=8
inherit gnome2
@@ -24,14 +23,14 @@ RDEPEND="
net-libs/farstream:0.2=[introspection?]
introspection? ( >=dev-libs/gobject-introspection-1.30 )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-util/gtk-doc-am-1.17
virtual/pkgconfig
"
src_configure() {
gnome2_src_configure \
- --disable-static \
--disable-Werror \
$(use_enable introspection)
}
@@ -43,6 +42,7 @@ src_install() {
docinto examples
dodoc examples/*.c
docompress -x /usr/share/doc/${PF}/examples
+
docinto examples/python
dodoc examples/python/*.py
docompress -x /usr/share/doc/${PF}/examples/python