summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 12:07:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 22:07:56 +0100
commita70990585a66079620e2bfba0e7d75ddee2365b4 (patch)
tree3376b7e65fb158a6dbc8783e5ec2b12c60a231c4
parentkde-frameworks/plasma: 5.90.0 version bump (diff)
downloadgentoo-a70990585a66079620e2bfba0e7d75ddee2365b4.tar.gz
gentoo-a70990585a66079620e2bfba0e7d75ddee2365b4.tar.bz2
gentoo-a70990585a66079620e2bfba0e7d75ddee2365b4.zip
kde-frameworks/purpose: 5.90.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.90.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index b62ac6acf42b..c6a75af8c9d8 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.88.0.tar.xz 165852 BLAKE2B 67603932b1d092eda49e4011dd2ebf8feb6862e315dc8cc3ce12a14f26e3796bd05f39e1ee91a119629b3cf2c962c3e44c600b4200e9c1fe0ecaf96ba8476673 SHA512 b21e5f50fe463f58cb3be92039e45c4c88f775d6612f85f9711090926ae65798ed159b825196fa314191fbb08eb52ae4d35077b48a1b4d6987291c6380893fae
DIST purpose-5.89.0.tar.xz 168224 BLAKE2B 69b86d0c3e4fde7e11907286151532e87046d446457a89ea5f8d40f69d00b6c8583bab014d26b94ed6187a663dca8aa319930708cec57d92048ae156c03c2a0f SHA512 a3552c54f4c2e7084168a266b812f9d7a2697ade4b3f3f25eba868c7143fe2eeb25b5c1d0504e65a0677b7dbbf75b544450175c1d9ba04deb78a5132b90a5893
+DIST purpose-5.90.0.tar.xz 171204 BLAKE2B 5319b0d1d20a77b35503180f8276752a8478bfccd1f80fe7564aa590c786a64517d2c0484fd5596cfdbe2635c6933f931d8ab43609d8b168a3766de2dea1fcc3 SHA512 8ba0808eba826ed267e42b9d8e9fd247482e964b104f0e68fd73b02862c13486c24d5bdc9cdf22f4912ad1edb49855d113f209d6690463aaec247bacd3ad0154
diff --git a/kde-frameworks/purpose/purpose-5.90.0.ebuild b/kde-frameworks/purpose/purpose-5.90.0.ebuild
new file mode 100644
index 000000000000..0d2e408ffe68
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.90.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}