summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-06-07 09:56:27 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-06-07 09:56:27 +0200
commita778ed2ca9a78c6b8bde07cb629a4c51bc850987 (patch)
tree1d2e3aa2a51dc56964359c64a6f123886f108c34
parentdev-python/matplotlib: Fix returning test failures (diff)
downloadgentoo-a778ed2ca9a78c6b8bde07cb629a4c51bc850987.tar.gz
gentoo-a778ed2ca9a78c6b8bde07cb629a4c51bc850987.tar.bz2
gentoo-a778ed2ca9a78c6b8bde07cb629a4c51bc850987.zip
media-gfx/exact-image: remove python bindings
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--media-gfx/exact-image/exact-image-0.8.1-r3.ebuild39
-rw-r--r--media-gfx/exact-image/metadata.xml5
2 files changed, 19 insertions, 25 deletions
diff --git a/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild b/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild
index 5eaeb57c3e47..91c362a6c1e9 100644
--- a/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild
+++ b/media-gfx/exact-image/exact-image-0.8.1-r3.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
-inherit eutils multilib python-single-r1 toolchain-funcs
+inherit eutils multilib toolchain-funcs
DESCRIPTION="A fast, modern and generic image processing library"
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
@@ -13,20 +12,18 @@ SRC_URI="http://dl.exactcode.de/oss/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="expat jpeg lua openexr php perl png python ruby swig tiff truetype X"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="expat jpeg lua openexr php perl png ruby swig tiff truetype X"
RDEPEND="x11-libs/agg[truetype]
sys-libs/zlib
expat? ( dev-libs/expat )
jpeg? ( virtual/jpeg )
- lua? ( dev-lang/lua )
+ lua? ( dev-lang/lua:= )
openexr? ( media-libs/openexr )
- php? ( dev-lang/php )
+ php? ( dev-lang/php:* )
perl? ( dev-lang/perl )
png? ( >=media-libs/libpng-1.2.43 )
- python? ( ${PYTHON_DEPS} )
- ruby? ( dev-lang/ruby )
+ ruby? ( dev-lang/ruby:* )
tiff? ( media-libs/tiff )
truetype? ( >=media-libs/freetype-2 )
X? (
@@ -39,21 +36,14 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
swig? ( dev-lang/swig )"
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.5-libpng14.patch
+ "${FILESDIR}"/${P}-libpng15.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
src_prepare() {
- eapply \
- "${FILESDIR}"/${PN}-0.7.5-libpng14.patch \
- "${FILESDIR}"/${P}-libpng15.patch \
- "${FILESDIR}"/${P}-gcc6.patch
- eapply_user
-
- # fix python hardcoded path wrt bug #327171
- sed -i -e "s:python2.5:${EPYTHON}:" \
- -e "s:\$(libdir):usr/$(get_libdir):" \
- "${S}"/api/python/Makefile || die
+ default
# Respect user CFLAGS/CXXFLAGS.
sed -i \
@@ -79,6 +69,7 @@ src_configure() {
# evas -> enlightenment overlay
# bardecode -> protected by custom license
# libungif -> not supported anymore
+ # python -> allegedly not python3, but python2 only
./configure \
--prefix=/usr \
@@ -98,7 +89,7 @@ src_configure() {
$(use_with lua) \
$(use_with swig) \
$(use_with perl) \
- $(use_with python) \
+ --without-python \
$(use_with php) \
$(use_with ruby) || die
}
diff --git a/media-gfx/exact-image/metadata.xml b/media-gfx/exact-image/metadata.xml
index 3c2bdaeead9d..b4fce831a061 100644
--- a/media-gfx/exact-image/metadata.xml
+++ b/media-gfx/exact-image/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
<use>
<flag name="swig">Adds Swig support <pkg>dev-lang/swig</pkg></flag>
</use>