summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 11:33:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 12:03:53 +0200
commita7a62213663529025a0581011dccc7a766e1a264 (patch)
tree8d4ecaccb3b37d4b2d6cc0e39c048b783c8c88de
parentdev-python/semantic_version: Enable py3.11 (diff)
downloadgentoo-a7a62213663529025a0581011dccc7a766e1a264.tar.gz
gentoo-a7a62213663529025a0581011dccc7a766e1a264.tar.bz2
gentoo-a7a62213663529025a0581011dccc7a766e1a264.zip
dev-python/cython: Reformat
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cython/cython-0.29.28.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/cython/cython-0.29.28.ebuild b/dev-python/cython/cython-0.29.28.ebuild
index a083c1c8e8e8..61afacee4b6a 100644
--- a/dev-python/cython/cython-0.29.28.ebuild
+++ b/dev-python/cython/cython-0.29.28.ebuild
@@ -10,9 +10,15 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 toolchain-funcs elisp-common
DESCRIPTION="A Python to C compiler"
-HOMEPAGE="https://cython.org https://pypi.org/project/Cython/
- https://github.com/cython/cython"
-SRC_URI="https://github.com/cython/cython/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://cython.org/
+ https://github.com/cython/cython/
+ https://pypi.org/project/Cython/
+"
+SRC_URI="
+ https://github.com/cython/cython/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -23,11 +29,14 @@ RESTRICT="!test? ( test )"
RDEPEND="
emacs? ( >=app-editors/emacs-23.1:* )
"
-BDEPEND="${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
test? (
- $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
- 'python3*')
- )"
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
PATCHES=(
"${FILESDIR}/${PN}-0.29.22-spawn-multiprocessing.patch"