summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-04-01 08:32:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-01 08:32:53 +0300
commita8ab969ebb729f2f8f0b98cade32ec13a20583e8 (patch)
tree5429d07dd57f09abe5fac7da3f1fc0016aa17051
parentsys-kernel/pf-sources: bump to 5.11-pf6 (diff)
downloadgentoo-a8ab969ebb729f2f8f0b98cade32ec13a20583e8.tar.gz
gentoo-a8ab969ebb729f2f8f0b98cade32ec13a20583e8.tar.bz2
gentoo-a8ab969ebb729f2f8f0b98cade32ec13a20583e8.zip
dev-libs/OpenSRF: remove last-rited package
Closes: https://bugs.gentoo.org/655502 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/OpenSRF/Manifest1
-rw-r--r--dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild122
-rw-r--r--dev-libs/OpenSRF/files/OpenSRF-2.1.1-buildfix.patch70
-rw-r--r--dev-libs/OpenSRF/metadata.xml7
-rw-r--r--profiles/package.mask6
5 files changed, 0 insertions, 206 deletions
diff --git a/dev-libs/OpenSRF/Manifest b/dev-libs/OpenSRF/Manifest
deleted file mode 100644
index 125463559b6a..000000000000
--- a/dev-libs/OpenSRF/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST opensrf-2.1.1.tar.gz 1058060 BLAKE2B 83c702727d21bea4683530857cd67037bde9eab94b91a801f64ebe70f5ad3b4994eea956cb9aaf531fbc663d4e9cb3242740f1941604a69aceaab8e396ae0e0e SHA512 5294ae2c9410ae52964067cd9090f9b7b5424e96f1731868cd896c1928ef1e89729af4a83f804f491bf2da0c6d129149105309afa18531b184098ebff2820306
diff --git a/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild b/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild
deleted file mode 100644
index ed235d5aab1e..000000000000
--- a/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils multilib flag-o-matic apache-module autotools perl-module
-
-DESCRIPTION="Framework for the high-level development of the Evergreen ILS software"
-HOMEPAGE="https://open-ils.org/"
-MY_PN="opensrf" # upstream lowercased the tarball in 2.x
-MY_P="${MY_PN}-${PV}"
-SRC_URI="https://open-ils.org/downloads/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="postgres +sqlite"
-DEPEND=">=www-servers/apache-2.2.9
- >=dev-db/libdbi-drivers-0.8.2
- >=dev-db/libdbi-0.8.2
- net-im/ejabberd
- dev-libs/libmemcached
- dev-perl/Cache-Memcached
- dev-perl/Class-DBI-AbstractSearch
- sqlite? ( dev-perl/DBD-SQLite )
- postgres? ( dev-perl/DBD-Pg )
- virtual/perl-Digest-MD5
- dev-perl/JSON-XS
- dev-perl/Net-Server
- dev-perl/UNIVERSAL-require
- dev-perl/Unix-Syslog
- dev-perl/XML-LibXML
- "
-
-S="${WORKDIR}/${MY_P}"
-PERL_S="${S}/src/perl"
-
-APXS2_S="${S}/src/gateway/.libs/"
-APACHE2_MOD_FILE="${APXS2_S}/osrf_json_gateway.so ${APXS2_S}/osrf_http_translator.so"
-#APACHE2_MOD_CONF="42_${PN}"
-#APACHE2_MOD_DEFINE="FOO"
-#DOCFILES="docs/*.html"
-need_apache2_2
-
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- perl_set_version
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.1.1-buildfix.patch
- eautoreconf
-}
-
-#src_compile() {
-# LIBXML2_CFLAGS=$(xml2-config --cflags)
-# LIBXML2_CFLAGS="${LIBXML2_CFLAGS//*-I}"
-# LIBXML2_HEADERS="${LIBXML2_CFLAGS// *}"
-# APR_HEADERS=$(apr-1-config --includedir)
-# APACHE2_HEADERS=$(apxs2 -q INCLUDEDIR)
-# sed -i \
-# -e '/^export PREFIX=/s,/.*,/usr,' \
-# -e '/^export BINDIR=/s,/.*,${PREFIX}/bin,' \
-# -e "/^export LIBDIR=/s,/.*,\${PREFIX}/$(get_libdir)," \
-# -e '/^export PERLDIR=/s,/.*,${LIBDIR}/perl5,' \
-# -e '/^export INCLUDEDIR=/s,/.*,${PREFIX}/include,' \
-# -e '/^export ETCDIR=/s,/.*,/etc,' \
-# -e '/^export SOCK=/s,/.*,/var/run/opensrf,' \
-# -e '/^export PID=/s,/.*,/var/run/opensrf,' \
-# -e '/^export LOG=/s,/.*,/var/log,' \
-# -e '/^export TMP=/s,/.*,/tmp,' \
-# -e '/^export APXS2=/s,/.*,/usr/sbin/apxs2,' \
-# -e "/^export APACHE2_HEADERS=/s,/.*,${APACHE2_HEADERS}," \
-# -e "/^export APR_HEADERS=/s,/.*,${APR_HEADERS}," \
-# -e "/^export LIBXML2_HEADERS=/s,/.*,${LIBXML2_HEADERS}," \
-# install.conf
-# emake verbose
-#}
-src_configure() {
- APXS2_INSTALL="-i" \
- econf \
- --with-apxs=/usr/sbin/apxs2 \
- --sysconfdir=/etc/opensrf \
- --localstatedir=/var
-
- cd "${PERL_S}" && S="${PERL_S}" perl-module_src_configure || die "perl-module_src_configure failed"
-}
-
-src_compile() {
- emake
- cd "${PERL_S}" && S="${PERL_S}" perl-module_src_compile || die "perl-module_src_compile failed"
-}
-
-src_install() {
- einfo "Doing src_install"
- #emake install-verbose DESTDIR="${D}"
- emake install DESTDIR="${D}" APXS2_INSTALL="-i"
- apache-module_src_install || die "apache-module_src_install failed"
- cd "${PERL_S}" && S="${PERL_S}" perl-module_src_install || die "perl-module_src_install failed"
- cd "${S}"
-
- # Docs
- dodoc README doc/*
-}
-
-src_test() {
- emake check
- cd "${PERL_S}" && S="${PERL_S}" perl-module_src_test || die "perl-module_src_test failed"
-}
-
-pkg_config() {
- :
- #JABBER_SERVER=${JABBER_SERVER:=localhost}
- #JABBER_PORT=${JABBER_PORT:=5222}
- #PASSWORD=${PASSWORD:=osrf}
- #einfo "Using Jabber server at ${JABBER_SERVER}:${JABBER_PORT}"
- #einfo "Adding 'osrf' and 'router' users with password ${PASSWORD}"
- #cd "${ROOT}"/usr/share/doc/${PF}/examples
- #for user in osrf router ; do
- # perl register.pl ${JABBER_SERVER} ${JABBER_PORT} ${user} ${PASSWORD} \
- # || die "Failed to add $user user to server"
- #done
-}
diff --git a/dev-libs/OpenSRF/files/OpenSRF-2.1.1-buildfix.patch b/dev-libs/OpenSRF/files/OpenSRF-2.1.1-buildfix.patch
deleted file mode 100644
index 767a478b53a8..000000000000
--- a/dev-libs/OpenSRF/files/OpenSRF-2.1.1-buildfix.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-Upstream uses DESTDIR, but then tries to hard-install the apache config
-modules, as well as not allowing other arguments to Build.PL easily.
-
-Split apache modules to be built during compile phase, and allow control of
-apxs2 install mode (for Gentoo, pass APXS2_INSTALL=-i).
-
-For the Build.PL problem, just disable it entirely here, and use the Gentoo
-build functions to call Build.PL instead
-(presently does --installdirs=vendor --libdoc= --destdir="${D}" --create_packlist=0).
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-
-diff -Nuar opensrf-2.1.1.orig/src/gateway/Makefile.am opensrf-2.1.1/src/gateway/Makefile.am
---- opensrf-2.1.1.orig/src/gateway/Makefile.am 2012-11-06 17:39:46.000000000 +0000
-+++ opensrf-2.1.1/src/gateway/Makefile.am 2012-11-12 21:56:52.108564157 +0000
-@@ -17,20 +17,23 @@
- AM_CFLAGS = -D_LARGEFILE64_SOURCE -Wall -I@abs_top_srcdir@/include/ -I$(LIBXML2_HEADERS) -I$(APACHE2_HEADERS) -I$(APR_HEADERS)
- AM_LDFLAGS = -L$(LIBDIR) -L@top_builddir@/src/libopensrf
- AP_LIBEXECDIR = `$(APXS2) -q LIBEXECDIR`
-+APXS2_INSTALL = -i -a
-
- DISTCLEANFILES = Makefile.in Makefile
-
--install-exec-local:
-- d=`$(APXS2) -q SYSCONFDIR` && \
-- if ! grep mod_placeholder $${d}/httpd.conf 2>&1 >/dev/null ; \
-- then echo -e "#\n#LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so" \
-- >> $${d}/httpd.conf; \
-- fi
-+all:
- $(APXS2) -c $(DEF_LDLIBS) $(AM_CFLAGS) $(AM_LDFLAGS) @srcdir@/osrf_json_gateway.c apachetools.c apachetools.h libopensrf.so
- $(APXS2) -c $(DEF_LDLIBS) $(AM_CFLAGS) $(AM_LDFLAGS) @srcdir@/osrf_http_translator.c apachetools.c apachetools.h libopensrf.so
-+
-+install-exec-local:
-+# d=`$(APXS2) -q SYSCONFDIR` && \
-+# if ! grep mod_placeholder $${d}/httpd.conf 2>&1 >/dev/null ; \
-+# then echo -e "#\n#LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so" \
-+# >> $${d}/httpd.conf; \
-+# fi
- $(MKDIR_P) $(DESTDIR)$(AP_LIBEXECDIR)
-- $(APXS2) -i -S LIBEXECDIR=$(DESTDIR)$(AP_LIBEXECDIR) -a @srcdir@/osrf_json_gateway.la
-- $(APXS2) -i -S LIBEXECDIR=$(DESTDIR)$(AP_LIBEXECDIR) -a @srcdir@/osrf_http_translator.la
-+ $(APXS2) $(APXS2_INSTALL) -S LIBEXECDIR=$(DESTDIR)$(AP_LIBEXECDIR) @srcdir@/osrf_json_gateway.la
-+ $(APXS2) $(APXS2_INSTALL) -S LIBEXECDIR=$(DESTDIR)$(AP_LIBEXECDIR) @srcdir@/osrf_http_translator.la
-
- clean-local:
- rm -f @srcdir@/osrf_http_translator.la @srcdir@/osrf_http_translator.lo @srcdir@/osrf_http_translator.slo @srcdir@/osrf_json_gateway.la @srcdir@/osrf_json_gateway.lo @srcdir@/osrf_json_gateway.slo
-diff -Nuar opensrf-2.1.1.orig/configure.ac opensrf-2.1.1/configure.ac
---- opensrf-2.1.1.orig/configure.ac 2012-11-06 17:39:46.000000000 +0000
-+++ opensrf-2.1.1/configure.ac 2012-11-12 22:04:38.673403306 +0000
-@@ -352,7 +352,6 @@
- src/gateway/Makefile
- src/jserver/Makefile
- src/libopensrf/Makefile
-- src/perl/Makefile
- src/ports/strn_compat/Makefile
- src/python/opensrf.py
- src/router/Makefile
-diff -Nuar opensrf-2.1.1.orig/src/Makefile.am opensrf-2.1.1/src/Makefile.am
---- opensrf-2.1.1.orig/src/Makefile.am 2012-11-06 17:39:46.000000000 +0000
-+++ opensrf-2.1.1/src/Makefile.am 2012-11-12 22:04:35.580149012 +0000
-@@ -40,7 +40,7 @@
- endif
-
- if BUILDCORE
--MAYBE_CORE = libopensrf c-apps router srfsh gateway perl
-+MAYBE_CORE = libopensrf c-apps router srfsh gateway
- if BUILDPYTHON
- dist_bin_SCRIPTS = @top_srcdir@/bin/opensrf-perl.pl @top_srcdir@/src/python/opensrf.py @top_srcdir@/src/python/srfsh.py
- else
diff --git a/dev-libs/OpenSRF/metadata.xml b/dev-libs/OpenSRF/metadata.xml
deleted file mode 100644
index 79d462e85571..000000000000
--- a/dev-libs/OpenSRF/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>robbat2@gentoo.org</email>
-</maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index e09248d808fd..2636535b7159 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -540,12 +540,6 @@ net-misc/gnome-remote-desktop
# https://bugs.gentoo.org/700020
=app-arch/cpio-2.13
-# Lars Wendler <polynomial-c@gentoo.org> (2019-10-16)
-# Joonas Niilola <juippis@gentoo.org> (2021-03-18)
-# Depends on apache-2.2
-# Removal on 2021-04-01. Bug #655502
-dev-libs/OpenSRF
-
# Matt Turner <mattst88@gentoo.org> (2019-09-01)
# TeXmacs is the only remaining package in tree that requires guile-1.8, which
# is unsupported upstream. A TeXmacs port to Guile-2 has been in progress for a