summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-09 12:24:25 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-09 12:26:12 +0100
commita8e750c14019c92612d16d57701d20d6cc78808a (patch)
tree26b727220268818aa7450b5b7bb01e4e6f8c6b93
parentdev-python/brython: version bump. (diff)
downloadgentoo-a8e750c14019c92612d16d57701d20d6cc78808a.tar.gz
gentoo-a8e750c14019c92612d16d57701d20d6cc78808a.tar.bz2
gentoo-a8e750c14019c92612d16d57701d20d6cc78808a.zip
app-portage/gemato: Bump to 11.1
Bump to the 11.1 bugfix release that fixes wiping environment for isolated GnuPG mode, which in turn fixes Prefix support. Closes: https://bugs.gentoo.org/646882
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-11.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 33b150489ef4..2711fb7c8e0d 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,3 @@
DIST gemato-10.3.tar.gz 63279 BLAKE2B 317c98c3989399e3a87cd5452edc509da86b17ecb41d295feca4071141d3ff1ba95a86544d64c786726f2148a899c1597020dde3513a913b1bc1811e2117337e SHA512 dd2b47238ac0707984358bd763ce0dfb23d8b09561939d22aae2e60386de388af9c5e67faa89a6ab9da4f0b334ee8486eeda66e5eb83bd2a26241b8a2b88128d
DIST gemato-11.0.tar.gz 64123 BLAKE2B c1020368eca1f8914c2377e23b27e953e06268e70754e2265af6d31defb2960263371aa6cbfb22b046d1bbdf549c948b62858d09055e8813fc9148a28c264a81 SHA512 c9ba297950a96fc7c07f88b8dcda33c3f351043ca062c354425be43ce4915b5ee37d6a28122797cfc01152546e72eda647e27f764b53345bfef87b292dd893e7
+DIST gemato-11.1.tar.gz 64338 BLAKE2B 672816956115bcf9a8f4832d8ca6af290d5ea2db213fbf485e969ec6f1c79e1f9a42590a8b88e7c204608ee8a1e2d2e7935b02a046fc08730dac667e5e371d09 SHA512 518f2728564a70e1758c3ee1290b01a27815fb51a64e632ad08fc6481becc0bf03756270aa2eed3fc3403557226c00a3f6099e73cd110532455ead515b37e109
diff --git a/app-portage/gemato/gemato-11.1.ebuild b/app-portage/gemato/gemato-11.1.ebuild
new file mode 100644
index 000000000000..6dd1dc95ea59
--- /dev/null
+++ b/app-portage/gemato/gemato-11.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}