summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-26 10:14:03 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-26 10:16:23 +0100
commita9334554bf6d16a75e9665d89716e2a85932335f (patch)
tree976481457810316b38998b747d25952ccbc4c6a4
parentapp-admin/ansible-molecule: remove pyyaml version cap from setup.cfg (diff)
downloadgentoo-a9334554bf6d16a75e9665d89716e2a85932335f.tar.gz
gentoo-a9334554bf6d16a75e9665d89716e2a85932335f.tar.bz2
gentoo-a9334554bf6d16a75e9665d89716e2a85932335f.zip
app-admin/ansible-molecule: bdepend on ansible-pygments if USE=doc
This is now a mandatory dependency of documentation, and dev-python/sphinx_ansible_theme only pulls it in if it itself has USE=doc set. Closes: https://bugs.gentoo.org/827366 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild b/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
index 90b97115e87..0ee7f33a10d 100644
--- a/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
+++ b/app-admin/ansible-molecule/ansible-molecule-3.5.2-r1.ebuild
@@ -41,6 +41,7 @@ BDEPEND="$(python_gen_cond_dep '
>=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
doc? (
+ dev-python/ansible-pygments[${PYTHON_USEDEP}]
>=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
)
test? (