summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-17 22:44:37 +1100
committerMark Wright <gienah@gentoo.org>2020-10-17 22:44:37 +1100
commita9511a558e48c0f6a7a74a8d7c161eda1948dd3f (patch)
tree2bb8c86991acb0c7a4f45d6e47e3bbad723e5697
parentdev-ml/ocaml-gettext: depend on earlier OCaml for old rev (diff)
downloadgentoo-a9511a558e48c0f6a7a74a8d7c161eda1948dd3f.tar.gz
gentoo-a9511a558e48c0f6a7a74a8d7c161eda1948dd3f.tar.bz2
gentoo-a9511a558e48c0f6a7a74a8d7c161eda1948dd3f.zip
dev-ml/cudf: Fix 633836 749243
cudf needs to be linked with libunwind when compiled with dev-lang/ocaml where dev-lang/ocaml is compiled with the spacetime USE flag. Thanks to Flo Gravo and toralf for reporting. Closes: https://bugs.gentoo.org/633836 Closes: https://bugs.gentoo.org/749243 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
-rw-r--r--dev-ml/cudf/cudf-0.8-r1.ebuild6
-rw-r--r--dev-ml/cudf/cudf-0.9.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-ml/cudf/cudf-0.8-r1.ebuild b/dev-ml/cudf/cudf-0.8-r1.ebuild
index 3d7e202217bc..682642554816 100644
--- a/dev-ml/cudf/cudf-0.8-r1.ebuild
+++ b/dev-ml/cudf/cudf-0.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -34,10 +34,10 @@ src_prepare() {
-e 's|make|$(MAKE)|g' \
Makefile || die
sed -i \
- -e 's|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ -e 's|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0 libunwind)|g' \
c-lib/Makefile || die
sed -i \
- -e 's|-lcurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ -e 's|-lcurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0 libunwind)|g' \
c-lib/Makefile.variants || die
tc-export CC PKG_CONFIG
diff --git a/dev-ml/cudf/cudf-0.9.ebuild b/dev-ml/cudf/cudf-0.9.ebuild
index 5a1763469039..0294691bd95c 100644
--- a/dev-ml/cudf/cudf-0.9.ebuild
+++ b/dev-ml/cudf/cudf-0.9.ebuild
@@ -35,10 +35,10 @@ src_prepare() {
-e 's|make|$(MAKE)|g' \
Makefile || die
sed -i \
- -e 's|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ -e 's|-lncurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0 libunwind)|g' \
c-lib/Makefile || die
sed -i \
- -e 's|-lcurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0)|g' \
+ -e 's|-lcurses|$(shell ${PKG_CONFIG} --libs ncurses glib-2.0 libunwind)|g' \
c-lib/Makefile.variants || die
tc-export CC PKG_CONFIG