summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-17 18:55:36 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:21 +0300
commita98473aab93d9aba380c8dbe99c4331c1145e21e (patch)
tree776a2649d81831f80e74c3e34059a99760164c0b
parentdev-python/pytest-regressions: Easy to use fixtures to write regression tests (diff)
downloadgentoo-a98473aab93d9aba380c8dbe99c4331c1145e21e.tar.gz
gentoo-a98473aab93d9aba380c8dbe99c4331c1145e21e.tar.bz2
gentoo-a98473aab93d9aba380c8dbe99c4331c1145e21e.zip
dev-python/pydata-sphinx-theme: move from ::guru
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/pydata-sphinx-theme/Manifest1
-rw-r--r--dev-python/pydata-sphinx-theme/metadata.xml12
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydata-sphinx-theme/Manifest b/dev-python/pydata-sphinx-theme/Manifest
new file mode 100644
index 000000000000..504bdeaf1f71
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/Manifest
@@ -0,0 +1 @@
+DIST pydata-sphinx-theme-0.4.0.tar.gz 3276611 BLAKE2B fb260de2ad40f9a3b5e524ef299a5bf2ee9fbe3f36a0b0e365b53a04702f8a5644154535cfa9f1f3c1deced5de8adbbaf5671488b467d3024b9ae3f60a6f7018 SHA512 abe4924277ec41193019e80a26ccb2ce195741fdae9defc9b500ecc2a63ab9070d1eba5a3398415641ef87ccfe8d573ce6fd10eb069e0f13f09891b5b5e2f932
diff --git a/dev-python/pydata-sphinx-theme/metadata.xml b/dev-python/pydata-sphinx-theme/metadata.xml
new file mode 100644
index 000000000000..d22e99d73577
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
new file mode 100644
index 000000000000..9f7e0b53939b
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap-based Sphinx theme from the PyData community"
+HOMEPAGE="https://github.com/pandas-dev/pydata-sphinx-theme"
+SRC_URI="https://github.com/pandas-dev/pydata-sphinx-theme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/pytest-regressions[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+# ModuleNotFoundError: No module named 'plotly' even if dev-python/plotly is installed
+#distutils_enable_sphinx docs dev-python/commonmark dev-python/recommonmark dev-python/numpydoc dev-python/jupyter-sphinx dev-python/plotly
+distutils_enable_tests pytest