summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-16 11:33:09 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-16 11:41:01 +0100
commita999820820bddaefedbc959999faa7adf467a12b (patch)
treea1e44ec2950c62654bf5f9559d0d2ea68ab5bd43
parentwww-apps/grafana-bin: Add v5.0.2 and drop .0 (diff)
downloadgentoo-a999820820bddaefedbc959999faa7adf467a12b.tar.gz
gentoo-a999820820bddaefedbc959999faa7adf467a12b.tar.bz2
gentoo-a999820820bddaefedbc959999faa7adf467a12b.zip
dev-libs/openssl: Revbump to remove "disable-deprecated" option.
It breaks too many revdeps and many upstreams are not really eager to fix them because "it works with deprecated features". Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-libs/openssl/openssl-1.1.0g-r3.ebuild (renamed from dev-libs/openssl/openssl-1.1.0g-r2.ebuild)3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-libs/openssl/openssl-1.1.0g-r2.ebuild b/dev-libs/openssl/openssl-1.1.0g-r3.ebuild
index b782dea17bf..61e2b4b945c 100644
--- a/dev-libs/openssl/openssl-1.1.0g-r2.ebuild
+++ b/dev-libs/openssl/openssl-1.1.0g-r3.ebuild
@@ -173,13 +173,14 @@ multilib_src_configure() {
# Fedora hobbled-EC needs 'no-ec2m'
# 'srp' was restricted until early 2017 as well.
+ # "disable-deprecated" option breaks too many consumers.
+ # Don't set it without thorough revdeps testing.
echoit \
./${config} \
${sslout} \
--api=1.0.0 \
$(use cpu_flags_x86_sse2 || echo "no-sse2") \
enable-camellia \
- disable-deprecated \
enable-ec \
$(use_ssl !bindist ec2m) \
enable-srp \