summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 12:27:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:10:56 +0100
commita9e7bf728e975ba7af2141239d65a7f7e2262a2e (patch)
treef633a276852e1ebbca1fae7ca07a29f3ad177ac2
parentapp-office/ledger: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-a9e7bf728e975ba7af2141239d65a7f7e2262a2e.tar.gz
gentoo-a9e7bf728e975ba7af2141239d65a7f7e2262a2e.tar.bz2
gentoo-a9e7bf728e975ba7af2141239d65a7f7e2262a2e.zip
app-office/libreoffice: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-office/libreoffice/libreoffice-6.3.4.2-r1.ebuild (renamed from app-office/libreoffice/libreoffice-6.3.4.2.ebuild)6
-rw-r--r--app-office/libreoffice/libreoffice-6.3.9999.ebuild8
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild8
3 files changed, 17 insertions, 5 deletions
diff --git a/app-office/libreoffice/libreoffice-6.3.4.2.ebuild b/app-office/libreoffice/libreoffice-6.3.4.2-r1.ebuild
index d4ce61a869a0..13de879df386 100644
--- a/app-office/libreoffice/libreoffice-6.3.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.3.4.2-r1.ebuild
@@ -152,7 +152,11 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
- accessibility? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ accessibility? (
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
bluetooth? (
dev-libs/glib:2
net-wireless/bluez
diff --git a/app-office/libreoffice/libreoffice-6.3.9999.ebuild b/app-office/libreoffice/libreoffice-6.3.9999.ebuild
index bc4dff890b8f..d552a76a932d 100644
--- a/app-office/libreoffice/libreoffice-6.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.3.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -152,7 +152,11 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
- accessibility? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ accessibility? (
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
bluetooth? (
dev-libs/glib:2
net-wireless/bluez
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 3c04bc1de8e6..f38debf301b9 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -152,7 +152,11 @@ COMMON_DEPEND="${PYTHON_DEPS}
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
- accessibility? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ accessibility? (
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
bluetooth? (
dev-libs/glib:2
net-wireless/bluez