summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-14 10:47:02 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-14 10:47:43 +0100
commita9eeb295e9abcbeb049505801cc36529b6393fe2 (patch)
treeddbc8cd91bf9222bd2c1581f852ea8e0d483a9a1
parentmedia-plugins/audacious-plugins: Add libsamplerate to RDEPEND for USE=speedpitch (diff)
downloadgentoo-a9eeb295e9abcbeb049505801cc36529b6393fe2.zip
gentoo-a9eeb295e9abcbeb049505801cc36529b6393fe2.tar.gz
gentoo-a9eeb295e9abcbeb049505801cc36529b6393fe2.tar.bz2
media-plugins/audacious-plugins: Revbump 3.9 and sync live ebuild
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-3.9-r1.ebuild (renamed from media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild)0
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-9999.ebuild12
2 files changed, 7 insertions, 5 deletions
diff --git a/media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild b/media-plugins/audacious-plugins/audacious-plugins-3.9-r1.ebuild
index 0bafc21..0bafc21 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-3.9.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-3.9-r1.ebuild
diff --git a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
index cc21399..0bafc21 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
@@ -21,11 +21,12 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="aac +adplug alsa ampache aosd bs2b cdda cue ffmpeg flac fluidsynth gnome hotkeys http gme gtk gtk3 jack lame libav
- libnotify libsamplerate lirc mms modplug mp3 nls pulseaudio qt5 scrobbler sdl sid sndfile soxr vorbis wavpack"
+ libnotify libsamplerate lirc mms modplug mp3 nls pulseaudio qt5 scrobbler sdl sid sndfile soxr speedpitch vorbis wavpack"
REQUIRED_USE="
^^ ( gtk gtk3 qt5 )
qt5? ( !libnotify )
- || ( alsa jack pulseaudio sdl )"
+ || ( alsa jack pulseaudio sdl )
+ ampache? ( qt5 http )"
# The following plugins REQUIRE a GUI build of audacious, because non-GUI
# builds do NOT install the libaudgui library & headers.
@@ -47,12 +48,12 @@ REQUIRED_USE="
RDEPEND="
app-arch/unzip
dev-libs/dbus-glib
- dev-libs/glib[utils]
+ dev-libs/glib
dev-libs/libxml2:2
~media-sound/audacious-${PV}[gtk?,gtk3?,qt5?]
aac? ( >=media-libs/faad2-2.7 )
alsa? ( >=media-libs/alsa-lib-1.0.16 )
- ampache? ( www-apps/ampache )
+ ampache? ( =media-libs/ampache_browser-1* )
aosd? (
x11-libs/libXrender
x11-libs/libXcomposite
@@ -85,7 +86,7 @@ RDEPEND="
)
lame? ( media-sound/lame )
libnotify? ( x11-libs/libnotify )
- libsamplerate? ( media-libs/libsamplerate )
+ libsamplerate? ( media-libs/libsamplerate:= )
lirc? ( app-misc/lirc )
mms? ( >=media-libs/libmms-0.3 )
modplug? ( media-libs/libmodplug )
@@ -96,6 +97,7 @@ RDEPEND="
sid? ( >=media-libs/libsidplayfp-1.0.0 )
sndfile? ( >=media-libs/libsndfile-1.0.17-r1 )
soxr? ( media-libs/soxr )
+ speedpitch? ( media-libs/libsamplerate:= )
vorbis? (
>=media-libs/libvorbis-1.2.0
>=media-libs/libogg-1.1.3