summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-18 00:21:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-18 00:21:45 +0100
commitaabe9e2e27390a3a0f4285b6439f21a5d0519558 (patch)
treeff82a91f5505248580b579753866b25299536545
parentgames-engines/devilutionx: Synced live ebuild (diff)
downloadgentoo-aabe9e2e27390a3a0f4285b6439f21a5d0519558.tar.gz
gentoo-aabe9e2e27390a3a0f4285b6439f21a5d0519558.tar.bz2
gentoo-aabe9e2e27390a3a0f4285b6439f21a5d0519558.zip
dev-python/setuptools: Bump to 51.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-51.3.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 9750163fc121..eab769eb7349 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -4,3 +4,4 @@ DIST setuptools-51.1.0.tar.gz 2050951 BLAKE2B 58890bf458ffab84f93e68393a092c2b2e
DIST setuptools-51.1.1.tar.gz 2051053 BLAKE2B 182c8c4b4d3bb8caea8cb1812aaff929d7687942d3c469a7f6e0a68a0c5d3d001be2b42d0d131171815359f2c1d59a7b997c5deab657d2ec99c369c6b27ba03f SHA512 ef08f0ecd0b4a255a8e43c2785c2a1ce76f807322c3358b7955d2ea814f9fa3f52962f7cd0431439ef9ee910fd44922d1be1888c350703031cfcab8db0f60ce7
DIST setuptools-51.1.2.tar.gz 2051107 BLAKE2B a9f1d5dac6bed7b8744f1a3f023398312f6e3696ea68a84bdb252afca3e88b8617ae632384c18cf49906b1ec97f78f467ec158cc09e1842055b5089e154e0429 SHA512 cdfdb3c3666239268ab225704d1a887f027c297262521ee8d55af547cbcef0931656997cc86f4f9a871df6028974bd90b9eea6177c02bf34f98297415b9c410f
DIST setuptools-51.3.1.tar.gz 2057167 BLAKE2B 4077e117c33c5eaad4de2bc66db0432dc14064de3f4a55e853541b09475bec81b9a07c3baec77a1574ed7912f3db2c6a83b7dcffbbe9bbffb15de13a928e6280 SHA512 5ae96ce0595bdaaa86fbe916e79b545db5a18278f150da2a38a83e43e891bbce8d4f03975ef0d7c6138b3ebcdb16fcfa4dae80a970007c8c60683fd57edc998e
+DIST setuptools-51.3.3.tar.gz 2053035 BLAKE2B 73b33359f10f900233b82e68c91781609665bdecb6b0e2963d7d15a798149c104030cc1e124ee945b23e5fc8db3f573d0b9012cfba7767ff913077af907141e4 SHA512 5a3572466a68c6f650111448ce3343f64c62044650bb8635edbff97e2bc7b216b8bbe3b4e3bccf34e6887f3bedc911b27ca5f9a515201cae49cf44fbacf03345
diff --git a/dev-python/setuptools/setuptools-51.3.3.ebuild b/dev-python/setuptools/setuptools-51.3.3.ebuild
new file mode 100644
index 000000000000..49b44d46c0df
--- /dev/null
+++ b/dev-python/setuptools/setuptools-51.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # this one's unhappy about pytest-xdist but one test is not worth
+ # losing the speed gain
+ setuptools/tests/test_build_meta.py::TestBuildMetaBackend::test_build_sdist_relative_path_import
+ )
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${deselect[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ setuptools || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}