summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-05-19 07:47:26 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-05-25 14:12:35 +0300
commitac2512786881302c1e98643515c2c7094cb3cec8 (patch)
treecad2575394c30794f49b4c403dc3ff14d7b15a72
parentdev-util/github-cli: Bump version to 1.10.3 (diff)
downloadgentoo-ac2512786881302c1e98643515c2c7094cb3cec8.tar.gz
gentoo-ac2512786881302c1e98643515c2c7094cb3cec8.tar.bz2
gentoo-ac2512786881302c1e98643515c2c7094cb3cec8.zip
dev-util/rebar-bin: Bump to 3.16.1
Bug: https://bugs.gentoo.org/791862 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-util/rebar-bin/Manifest1
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.16.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
index 2b40f7d90690..4a8751cfb49f 100644
--- a/dev-util/rebar-bin/Manifest
+++ b/dev-util/rebar-bin/Manifest
@@ -1 +1,2 @@
DIST rebar-bin-3.15.1 951017 BLAKE2B b9c71729397678ace6b9988dc3bbcf3685a9c832298f66ac8b758f515c7c4f0e24b5bebaea93fa7f2f1b1fd88cebd7581c6e2c7e6efc08b5138225b1a02700d8 SHA512 3dd66d3e35b4431a9cc565a20ebdad9732df6e673b818236be5be377279b179ddf12c953268b0d6edf5f0c45253b4e5a0b192904f1c606354dbed2ae86fb2403
+DIST rebar-bin-3.16.1 942316 BLAKE2B c3296d54f85c146a58ff24a9b337f7d26e2beb3287257ecca6344c082b84295d9daf042b7bcb422df7c5dd29dd681f0c81064c1ef5b7b30ed8be8328ca694bc4 SHA512 be9e4ffdf654f8038ff14cd4b53328bdbc8b26e0f1306a16220f4d5d4b13bc36ac2f302d52a799424ffc3835e41ce326a4fd8e422ececf70ab8c0f951e3e4b24
diff --git a/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild b/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
new file mode 100644
index 000000000000..83bb5eb671c1
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://rebar3.org https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
+}
+
+src_install() {
+ dobin rebar3
+}