summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2021-05-06 01:01:47 +0000
committerIonen Wolkens <ionen@gentoo.org>2021-06-05 04:40:23 -0400
commitad26594a82336cbc51a19077c8baa27bca7066cb (patch)
treea9c71266098a5b4b5f1d5d7a521aceeaaa7c2a30
parentwww-client/chromium: dev channel bump to 93.0.4530.5 (diff)
downloadgentoo-ad26594a82336cbc51a19077c8baa27bca7066cb.tar.gz
gentoo-ad26594a82336cbc51a19077c8baa27bca7066cb.tar.bz2
gentoo-ad26594a82336cbc51a19077c8baa27bca7066cb.zip
dev-games/openscenegraph-openmw: fix build with gcc 11
Closes: https://bugs.gentoo.org/788301 Signed-off-by: Alexey Sokolov <sokolov@google.com> Closes: https://github.com/gentoo/gentoo/pull/21127 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-games/openscenegraph-openmw/files/openscenegraph-3.4-gcc11.patch23
-rw-r--r--dev-games/openscenegraph-openmw/openscenegraph-openmw-3.4_p20200425-r100.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-games/openscenegraph-openmw/files/openscenegraph-3.4-gcc11.patch b/dev-games/openscenegraph-openmw/files/openscenegraph-3.4-gcc11.patch
new file mode 100644
index 000000000000..0d2dc2d0f73b
--- /dev/null
+++ b/dev-games/openscenegraph-openmw/files/openscenegraph-3.4-gcc11.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/788301
+--- a/include/osgDB/ObjectCache
++++ b/include/osgDB/ObjectCache
+@@ -72,7 +72,7 @@ class OSGDB_EXPORT ObjectCache : public osg::Referenced
+
+ class ClassComp {
+ public:
+- bool operator() (const ObjectCache::FileNameOptionsPair& lhs, const ObjectCache::FileNameOptionsPair& rhs);
++ bool operator() (const ObjectCache::FileNameOptionsPair& lhs, const ObjectCache::FileNameOptionsPair& rhs) const;
+ };
+
+ typedef std::pair<osg::ref_ptr<osg::Object>, double > ObjectTimeStampPair;
+--- a/src/osgDB/ObjectCache.cpp
++++ b/src/osgDB/ObjectCache.cpp
+@@ -16,7 +16,7 @@
+
+ using namespace osgDB;
+
+-bool ObjectCache::ClassComp::operator() (const ObjectCache::FileNameOptionsPair& lhs, const ObjectCache::FileNameOptionsPair& rhs)
++bool ObjectCache::ClassComp::operator() (const ObjectCache::FileNameOptionsPair& lhs, const ObjectCache::FileNameOptionsPair& rhs) const
+ {
+ // check if filename are the same
+ if (lhs.first < rhs.first) return true;
diff --git a/dev-games/openscenegraph-openmw/openscenegraph-openmw-3.4_p20200425-r100.ebuild b/dev-games/openscenegraph-openmw/openscenegraph-openmw-3.4_p20200425-r100.ebuild
index 202f18429af9..08efaabeceae 100644
--- a/dev-games/openscenegraph-openmw/openscenegraph-openmw-3.4_p20200425-r100.ebuild
+++ b/dev-games/openscenegraph-openmw/openscenegraph-openmw-3.4_p20200425-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -87,6 +87,7 @@ PATCHES=(
"${FILESDIR}"/openscenegraph-3.4-cmake.patch
"${FILESDIR}"/openscenegraph-3.5.1-jpeg-9.patch
"${FILESDIR}"/openscenegraph-3.6.3-docdir.patch
+ "${FILESDIR}"/openscenegraph-3.4-gcc11.patch
)
pkg_setup() {