summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-17 08:35:33 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-17 08:36:56 +0100
commitae005981a01198a4dbf61a671f4654fea42f81bf (patch)
treef226b7877114f5c842717b00c351c23b110c4e99
parentapp-backup/duply: remove unused patch(es) (diff)
downloadgentoo-ae005981a01.tar.gz
gentoo-ae005981a01.tar.bz2
gentoo-ae005981a01.zip
sys-libs/zlib-ng: Initial commit
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-libs/zlib-ng/Manifest1
-rw-r--r--sys-libs/zlib-ng/metadata.xml11
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.0.0.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
new file mode 100644
index 000000000000..db6011f474d1
--- /dev/null
+++ b/sys-libs/zlib-ng/Manifest
@@ -0,0 +1 @@
+DIST zlib-ng-2.0.0.tar.gz 696194 BLAKE2B 1e59d42028fc1cb300b1361dc95e4e7dca45b581d0d068722099b4254b795db5e2638b351da2cc1fd873841e9183a3ae4b168bd39dcde826ed4dc5aefe3ad1cd SHA512 8f5ba6a030d363a654ff3ff6a3536aa5301e6836e43743b8ab8ca87e06fcb009ce6adef79c4a46c9d89d2b167135e5d4dda70431f7ff431316e166ea6efbe099
diff --git a/sys-libs/zlib-ng/metadata.xml b/sys-libs/zlib-ng/metadata.xml
new file mode 100644
index 000000000000..28389c0890a4
--- /dev/null
+++ b/sys-libs/zlib-ng/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">zlib-ng/zlib-ng</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/sys-libs/zlib-ng/zlib-ng-2.0.0.ebuild b/sys-libs/zlib-ng/zlib-ng-2.0.0.ebuild
new file mode 100644
index 000000000000..6ed5ef9c1fb4
--- /dev/null
+++ b/sys-libs/zlib-ng/zlib-ng-2.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 688f948c5f3067e775bfab5057e8047f467a9ca9 $
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="zlib data compression library"
+HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+
+#KEYWORDS="~amd64 ~x86"
+IUSE="compat test"
+
+src_prepare() {
+ cmake_src_prepare
+ sed "/LIB_INSTALL_DIR/s@/lib\"@/$(get_libdir)\"@" \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DZLIB_COMPAT="$(usex compat)"
+ -DZLIB_ENABLE_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}