summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Vasquez <fearedbliss@gentoo.org>2020-09-03 12:38:41 -0400
committerJonathan Vasquez <fearedbliss@gentoo.org>2020-09-03 12:38:41 -0400
commitae5be29362e177ce0d8759ee42fe8e7de00fed17 (patch)
tree11f9e317c920b3a5ee16b49fb438dea5ff3c1f29
parentsys-kernel/bliss-initramfs: stabilizing 9.1.0 (diff)
downloadgentoo-ae5be29362e177ce0d8759ee42fe8e7de00fed17.tar.gz
gentoo-ae5be29362e177ce0d8759ee42fe8e7de00fed17.tar.bz2
gentoo-ae5be29362e177ce0d8759ee42fe8e7de00fed17.zip
sys-kernel/bliss-initramfs: bumping to 9.2.0
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Jonathan Vasquez <fearedbliss@gentoo.org>
-rw-r--r--sys-kernel/bliss-initramfs/Manifest1
-rw-r--r--sys-kernel/bliss-initramfs/bliss-initramfs-9.2.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-kernel/bliss-initramfs/Manifest b/sys-kernel/bliss-initramfs/Manifest
index 393307efc8d5..11c203f7157b 100644
--- a/sys-kernel/bliss-initramfs/Manifest
+++ b/sys-kernel/bliss-initramfs/Manifest
@@ -1,2 +1,3 @@
DIST bliss-initramfs-8.1.0.tar.gz 34464 BLAKE2B 5cc4c547fa9fadc91b21f9e752242dd1f3fa81a589457297c2d058fa811ea08deb3aacdcc5f2448856fd1d1c627037c47796f69b39b9691a60d8b0bcfc499cff SHA512 bee5e206ddd388a06ef876d99e36d0e1587d9148d890761e4d56b27e12c83c9a51794a3c9e99cac70de9729297e27051d6c323986f13cf8b3666a6ec66b85090
DIST bliss-initramfs-9.1.0.tar.gz 27708 BLAKE2B 920e33e5c63d0c8eec2f17ceca42c6b83c3850714b63fd8d80855fafaea7f5799a22d213fb05e6ee03c9321d2eaffac434cec2822326d18cb5f8bcea5d361eaa SHA512 2ce98a6dd837062accfdcb145f1eba9e93c6f21f41fc6fdeb38f939749a1a86c6971aa9e438f99a06a7fec7013ff19e8cd3dd346cc9aa80b0048c6402c93865a
+DIST bliss-initramfs-9.2.0.tar.gz 27837 BLAKE2B 9a8dd611b75c2892dba7d96c8e79385034e7a923c62d2223d69ee48a6a8090271981b367d8083db553dfe5a1bbd661857036998bcfe7daf78e1f15bbdb8b1c9c SHA512 2af311a166e4b46bdb365e8e6a518354f27216275f2d941e430d356727c9b2b9080dce411509a3e9093c5324f28ed9e73c3831140d7d2eef3ab8cd514b5c0e43
diff --git a/sys-kernel/bliss-initramfs/bliss-initramfs-9.2.0.ebuild b/sys-kernel/bliss-initramfs/bliss-initramfs-9.2.0.ebuild
new file mode 100644
index 000000000000..042e7d7cf5d5
--- /dev/null
+++ b/sys-kernel/bliss-initramfs/bliss-initramfs-9.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+inherit python-single-r1
+
+DESCRIPTION="Boot your system's rootfs from Encrypted/OpenZFS."
+HOMEPAGE="https://github.com/fearedbliss/bliss-initramfs"
+SRC_URI="https://github.com/fearedbliss/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="strip"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-arch/cpio
+ virtual/udev"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+CONFIG_FILE="/etc/bliss-initramfs/settings.json"
+
+src_install() {
+ # Copy the main executable
+ local executable="mkinitrd.py"
+ exeinto "/opt/${PN}"
+ doexe "${executable}"
+
+ # Copy the libraries required by this executable
+ cp -r "${S}/files" "${D}/opt/${PN}" || die
+ cp -r "${S}/pkg" "${D}/opt/${PN}" || die
+
+ # Copy documentation files
+ dodoc README.md README-MORE.md USAGE.md
+
+ # Copy the configuration file for the user
+ dodir "/etc/${PN}"
+ cp "${S}/files/default-settings.json" "${D}${CONFIG_FILE}"
+
+ # Make a relative symbolic link: /sbin/bliss-initramfs
+ dosym "../opt/${PN}/${executable}" "/sbin/${PN}"
+}
+
+pkg_postinst() {
+ elog "Version >=9.0.0 is a BREAKING CHANGE! bliss-initramfs now has native"
+ elog "zfs encryption support, and LUKS has been completely removed. If you"
+ elog "are using LUKS, please stay on version 8.1.0 since that is the last"
+ elog "version to support LUKS!\n"
+ elog "For a full list of changes, please read the release info located here:"
+ elog "https://github.com/fearedbliss/bliss-initramfs/releases/tag/9.0.0"
+ elog ""
+ elog "As of version 8.1.0, ${PN} has a new centralized configuration architecture."
+ elog "Any customizations you want to provide to ${PN} should be done by modifying"
+ elog "${CONFIG_FILE}. You can use the \"-c/--config\" option to provide"
+ elog "an alternate configuration path.\n"
+ elog "For a full list of changes, please read the release info located here:"
+ elog "https://github.com/fearedbliss/bliss-initramfs/releases/tag/8.1.0"
+}