summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Schlarb <moschlar@metalabs.de>2017-08-03 08:42:06 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-06 13:54:53 +0200
commitae73c14bfbeaa6d837b608c7f8dca3d55d161ac4 (patch)
tree653a668a522b0d8fac56aa2d579b71b7560d22f5
parentprofiles: unmask >sys-apps/openrc-0.23.2 for ppc uclibc, bug #619370 (diff)
downloadgentoo-ae73c14b.tar.gz
gentoo-ae73c14b.tar.bz2
gentoo-ae73c14b.zip
net-libs/ccnet: Version bump to 6.1.0
-rw-r--r--net-libs/ccnet/Manifest1
-rw-r--r--net-libs/ccnet/ccnet-6.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/ccnet/Manifest b/net-libs/ccnet/Manifest
index 8807bad4c069..521c335dc60b 100644
--- a/net-libs/ccnet/Manifest
+++ b/net-libs/ccnet/Manifest
@@ -1 +1,2 @@
DIST ccnet-6.0.7.tar.gz 179356 SHA256 c4e02b5b77d774ffaa47235e6e265ecce00f656766a2f232397ce86eeb3162fa SHA512 66df998bb544ad614479d853820e3ee3119c2b08087d82a2a0633202c860447a7ac79f3639e587d531c2443def3cd58bf9ccdb2fed350c8bd7005737fb3d85fd WHIRLPOOL 27022bcae05958ad34c3b26221f7278184068fba119b63bfb4b13fe1f74ac19b61a34deb2e8b9047e6005c95abb0191299e3c105058e3937d8b873f1c75df73f
+DIST ccnet-6.1.0.tar.gz 179362 SHA256 6b91c1a1a00622a2a07669dae144dd7fcd8f11275912384aa65d33da05088a60 SHA512 0053d342cf9256a37ca2ebf774794c791cb08caa7d608035c1b307a271e11719da1d4c272870ab51ad1cd8d8c0a84d22959b513865ddf98b4691cba35bc93018 WHIRLPOOL fd0a421fcd6433134520d7e9a667a3937af329b2761cc353095cc98814f7cd37b19b4b4593094f4e5d153ecbc632ccb569fb99c328c8c7c7cf547b33f19e4ad7
diff --git a/net-libs/ccnet/ccnet-6.1.0.ebuild b/net-libs/ccnet/ccnet-6.1.0.ebuild
new file mode 100644
index 000000000000..e78f3357f6ea
--- /dev/null
+++ b/net-libs/ccnet/ccnet-6.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="Ccnet is a framework for writing networked applications in C"
+HOMEPAGE="https://github.com/haiwen/ccnet http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ net-libs/libsearpc[${PYTHON_USEDEP}]
+ >=dev-libs/glib-2.16.0:2
+ >=dev-libs/libevent-2.0
+ dev-libs/openssl:0=
+ dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" libccnet.pc.in || die
+ sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
+ eautoreconf
+ vala_src_prepare
+}