summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-31 08:02:28 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-31 08:02:28 +0100
commitae8fe4521b047d71437f98218ff595715f41cfc9 (patch)
treee44ac6cb8d5ef5d34a24ac2001c3579984480cb0
parentsys-libs/newlib: drop stable keywords, bug #713284 (diff)
downloadgentoo-ae8fe4521b047d71437f98218ff595715f41cfc9.tar.gz
gentoo-ae8fe4521b047d71437f98218ff595715f41cfc9.tar.bz2
gentoo-ae8fe4521b047d71437f98218ff595715f41cfc9.zip
sys-libs/newlib: drop old, bug #713284
Bug: https://bugs.gentoo.org/713284 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-libs/newlib/Manifest3
-rw-r--r--sys-libs/newlib/newlib-2.2.0.ebuild81
-rw-r--r--sys-libs/newlib/newlib-2.5.0.ebuild139
-rw-r--r--sys-libs/newlib/newlib-3.1.0.ebuild141
4 files changed, 0 insertions, 364 deletions
diff --git a/sys-libs/newlib/Manifest b/sys-libs/newlib/Manifest
index ac2c4dc6a96e..12a1c1b30174 100644
--- a/sys-libs/newlib/Manifest
+++ b/sys-libs/newlib/Manifest
@@ -1,4 +1 @@
-DIST newlib-2.2.0.tar.gz 16521910 BLAKE2B 530290c8f219774885e3c408889b7f58bbeefe5c092f004c9ad61de8642b725df1f8fd2a00760ebde814e5bf379ae0320a589d2318113f371a733c5abaca2ba7 SHA512 ab9161f16845367c823b6709e3c5708969f29f05c77edb1cf969ff4202f358648f1e55080974599dcefed2fbced4694dc73748596e76c1aa37c50cddff6e4be3
-DIST newlib-2.5.0.tar.gz 17912392 BLAKE2B bc89491758d59f3529c72308e963c5b3e39044d6d586ef3814cc19cf55aee33948656c544df7dfcbe3915105e7373f53d7b2baf96b9b8147e3af780c1d08e670 SHA512 4c99e8dfcb4a7ad0769b9e173ff06628d82e4993ef87d3adf9d6b5578626b14de81b4b3c5f0673ddbb49dc9f3d3628f9f8d4432dcded91f5cd3d27b7d44343cd
-DIST newlib-3.1.0.tar.gz 17958952 BLAKE2B 3a84ae81fc07e442a4ed3da7a78e7ede34cc7e24b5d1c66a12624ed808e5f85f134751fcea0e4ce9eb39df287a582821f751a8610a088c149895b5e38eb06989 SHA512 efc4c3ab7153387780d141386bca5d3e20c9d25ae3e6b87cf94c8df9d301ce5926dacdff9bd33aeb9781559d933c3d0ae77f4e5b46120d90792f75dbfde702c7
DIST newlib-3.3.0.tar.gz 18361083 BLAKE2B bdc81427955d0a2f550bf2973ca82c0b8b55aa170565cdf1cfe8ac926257fad6d3e860ce7b2e286949ab21be2677378b5b6d3c743c05fe8aa6df8a8c34a16945 SHA512 2f0c6666487520e1a0af0b6935431f85d2359e27ded0d01d02567d0d1c6479f2f0e6bbc60405e88e46b92c2a18780a01a60fc9281f7e311cfd40b8d5881d629c
diff --git a/sys-libs/newlib/newlib-2.2.0.ebuild b/sys-libs/newlib/newlib-2.2.0.ebuild
deleted file mode 100644
index 324973fcfa5c..000000000000
--- a/sys-libs/newlib/newlib-2.2.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs eutils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only"
-RESTRICT="strip"
-
-# Handle the SLOT changes. #497344
-RDEPEND="!<${CATEGORY}/${PN}-2.1.0"
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-}
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-newlib-multithread" \
- || myconf="${myconf} $(use_enable threads newlib-multithread)"
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- ${myconf}
-}
-
-src_compile() {
- emake -C "${NEWLIBBUILD}"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}
diff --git a/sys-libs/newlib/newlib-2.5.0.ebuild b/sys-libs/newlib/newlib-2.5.0.ebuild
deleted file mode 100644
index f2b9ba72e10d..000000000000
--- a/sys-libs/newlib/newlib-2.5.0.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- if [[ ${PV} != *.201[5-9]???? ]] ; then
- KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86"
- fi
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only nano"
-RESTRICT="strip"
-
-NEWLIBBUILD="${WORKDIR}/build"
-NEWLIBNANOBUILD="${WORKDIR}/build.nano"
-NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-
-CFLAGS_FULL="-ffunction-sections -fdata-sections"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-}
-
-src_configure() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
- CCASFLAGS_ORIG="${CCASFLAGS}"
- CFLAGS_ORIG="${CFLAGS}"
-
- local myconf=(
- # Disable legacy syscall stub code in newlib. These have been
- # moved to libgloss for a long time now, so the code in newlib
- # itself just gets in the way.
- --disable-newlib-supplied-syscalls
- )
- [[ ${CTARGET} == "spu" ]] \
- && myconf+=( --disable-newlib-multithread ) \
- || myconf+=( $(use_enable threads newlib-multithread) )
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- "${myconf[@]}"
-
- # Build newlib-nano beside newlib (original)
- # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
- if use nano ; then
- mkdir -p "${NEWLIBNANOBUILD}" || die
- cd "${NEWLIBNANOBUILD}" || die
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- --enable-newlib-reent-small \
- --disable-newlib-fvwrite-in-streamio \
- --disable-newlib-fseek-optimization \
- --disable-newlib-wide-orient \
- --enable-newlib-nano-malloc \
- --disable-newlib-unbuf-stream-opt \
- --enable-lite-exit \
- --enable-newlib-global-atexit \
- --enable-newlib-nano-formatted-io \
- ${myconf}
- fi
-}
-
-src_compile() {
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- emake -C "${NEWLIBBUILD}"
-
- if use nano ; then
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- emake -C "${NEWLIBNANOBUILD}"
- fi
-}
-
-src_install() {
- cd "${NEWLIBBUILD}" || die
- emake -j1 DESTDIR="${D}" install
-
- if use nano ; then
- cd "${NEWLIBNANOBUILD}" || die
- emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
- # Rename nano lib* files to lib*_nano and move to the real ${D}
- local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|rdimon\)\.a" -print)
- for f in ${nanolibfiles}; do
- local l="${f##${NEWLIBNANOTMPINSTALL}}"
- mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
- done
-
- # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
- "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
- fi
-
- # minor hack to keep things clean
- rm -rf "${D}"/usr/share/info || die
- rm -rf "${D}"/usr/info || die
-}
diff --git a/sys-libs/newlib/newlib-3.1.0.ebuild b/sys-libs/newlib/newlib-3.1.0.ebuild
deleted file mode 100644
index db1a3fad9cfb..000000000000
--- a/sys-libs/newlib/newlib-3.1.0.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://sourceware.org/git/newlib-cygwin.git"
- inherit git-r3
-else
- SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="https://sourceware.org/newlib/"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-SLOT="0"
-IUSE="nls threads unicode headers-only nano"
-RESTRICT="strip"
-
-NEWLIBBUILD="${WORKDIR}/build"
-NEWLIBNANOBUILD="${WORKDIR}/build.nano"
-NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-
-# Adding -U_FORTIFY_SOURCE to counter the effect of Gentoo's
-# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
-# Currently newlib can't be built itself when _FORTIFY_SOURCE
-# is set.
-CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-}
-
-src_configure() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
- CCASFLAGS_ORIG="${CCASFLAGS}"
- CFLAGS_ORIG="${CFLAGS}"
-
- local myconf=(
- # Disable legacy syscall stub code in newlib. These have been
- # moved to libgloss for a long time now, so the code in newlib
- # itself just gets in the way.
- --disable-newlib-supplied-syscalls
- )
- [[ ${CTARGET} == "spu" ]] \
- && myconf+=( --disable-newlib-multithread ) \
- || myconf+=( $(use_enable threads newlib-multithread) )
-
- mkdir -p "${NEWLIBBUILD}"
- cd "${NEWLIBBUILD}"
-
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- "${myconf[@]}"
-
- # Build newlib-nano beside newlib (original)
- # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
- if use nano ; then
- mkdir -p "${NEWLIBNANOBUILD}" || die
- cd "${NEWLIBNANOBUILD}" || die
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- --enable-newlib-reent-small \
- --disable-newlib-fvwrite-in-streamio \
- --disable-newlib-fseek-optimization \
- --disable-newlib-wide-orient \
- --enable-newlib-nano-malloc \
- --disable-newlib-unbuf-stream-opt \
- --enable-lite-exit \
- --enable-newlib-global-atexit \
- --enable-newlib-nano-formatted-io \
- ${myconf}
- fi
-}
-
-src_compile() {
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
- emake -C "${NEWLIBBUILD}"
-
- if use nano ; then
- export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
- export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
- emake -C "${NEWLIBNANOBUILD}"
- fi
-}
-
-src_install() {
- cd "${NEWLIBBUILD}" || die
- emake -j1 DESTDIR="${D}" install
-
- if use nano ; then
- cd "${NEWLIBNANOBUILD}" || die
- emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
- # Rename nano lib* files to lib*_nano and move to the real ${D}
- local nanolibfiles=""
- nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|rdimon\)\.a" -print)
- for f in ${nanolibfiles}; do
- local l="${f##${NEWLIBNANOTMPINSTALL}}"
- mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
- done
-
- # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
- mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
- mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
- "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
- fi
-
- # minor hack to keep things clean
- rm -rf "${D}"/usr/share/info || die
- rm -rf "${D}"/usr/info || die
-}