summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-10 19:54:35 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-10 19:54:35 -0700
commitae92c516deaa14eb6adb444e6523f09389d48daf (patch)
tree8d03d062d9cee30ce5f7bfeab4d04bb4a6e52e7c
parentdev-python/pytest-freezegun: ppc64 keyworded (bug #731714) (diff)
downloadgentoo-ae92c516deaa14eb6adb444e6523f09389d48daf.tar.gz
gentoo-ae92c516deaa14eb6adb444e6523f09389d48daf.tar.bz2
gentoo-ae92c516deaa14eb6adb444e6523f09389d48daf.zip
app-arch/pigz: revbump, ignore trailing junk.
Closes: https://bugs.gentoo.org/645438 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-arch/pigz/files/2.4-trailing-junk.patch27
-rw-r--r--app-arch/pigz/pigz-2.4-r1.ebuild (renamed from app-arch/pigz/pigz-2.4.ebuild)2
2 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/pigz/files/2.4-trailing-junk.patch b/app-arch/pigz/files/2.4-trailing-junk.patch
new file mode 100644
index 000000000000..eb5585b7d362
--- /dev/null
+++ b/app-arch/pigz/files/2.4-trailing-junk.patch
@@ -0,0 +1,27 @@
+From 1414ff3eb0b1ac9e5f096b0a28efa459cb8be1cd Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Fri, 10 Jul 2020 19:46:10 -0700
+Subject: [PATCH] Ignore trailing junk on .gz by default, to emulate gzip.
+
+backport of
+https://github.com/madler/pigz/commit/9696c84cb1963651707e649978afb07d0c11b254
+---
+ pigz.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pigz.c b/pigz.c
+index bbbfd2c..f2e79d7 100644
+--- a/pigz.c
++++ b/pigz.c
+@@ -3368,7 +3368,7 @@ local void infchk(void) {
+ cat();
+ else if (was > 1 && get_header(0) != -5)
+ complain("warning: %s: entries after the first were ignored", g.inf);
+- else if ((was == 0 && ret != -1) || (was == 1 && (GET(), !g.in_eof)))
++ else if (( g.verbosity > 1 && was == 0 && ret != -1) || (was == 1 && (GET(), !g.in_eof)))
+ complain("warning: %s: trailing junk was ignored", g.inf);
+ }
+
+--
+2.27.0
+
diff --git a/app-arch/pigz/pigz-2.4.ebuild b/app-arch/pigz/pigz-2.4-r1.ebuild
index fe1190bc3a3f..29c9951c6bfa 100644
--- a/app-arch/pigz/pigz-2.4.ebuild
+++ b/app-arch/pigz/pigz-2.4-r1.ebuild
@@ -21,6 +21,8 @@ DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )
test? ( app-arch/ncompress )"
+PATCHES=( "${FILESDIR}/${PV}-trailing-junk.patch" )
+
src_compile() {
use static && append-ldflags -static
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"