summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-18 15:47:46 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-18 15:47:46 -0500
commitae979904112ec6a10b466b95c7e9e4077aff205b (patch)
tree7bd54c9f9b42da47b4fac549c29dbc8ef8ae1467
parentnet-mail/cyrus-imapd: Revbump for mysql dependency change (diff)
downloadgentoo-ae979904112ec6a10b466b95c7e9e4077aff205b.tar.gz
gentoo-ae979904112ec6a10b466b95c7e9e4077aff205b.tar.bz2
gentoo-ae979904112ec6a10b466b95c7e9e4077aff205b.zip
net-mail/ezmlm-idx: Revbump for EAPI and dependency change
Non-maintainer commit Closes: https://bugs.gentoo.org/show_bug.cgi?id=367869 Bug: https://bugs.gentoo.org/665994 Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild
new file mode 100644
index 000000000000..a8b8d7a76fe3
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmail toolchain-funcs
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="http://www.ezmlm.org"
+SRC_URI="http://www.ezmlm.org/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+REQUIRED_USE="?? ( mysql postgres )"
+
+src_prepare() {
+ default
+ echo /usr/bin > conf-bin || die
+ echo /usr/$(get_libdir)/ezmlm > conf-lib || die
+ echo /etc/ezmlm > conf-etc || die
+ echo /usr/share/man > conf-man || die
+ echo ${QMAIL_HOME} > conf-qmail || die
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc || die
+ echo $(tc-getCC) ${CFLAGS} -Wl,-E > conf-ld || die
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/install\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake it man
+
+ if use mysql; then
+ emake mysql
+ elif use postgres; then
+ emake pgsql
+ fi
+}
+
+src_install () {
+ dodir /usr/bin /usr/$(get_libdir)/ezmlm /etc/ezmlm /usr/share/man
+ dobin ezmlm-{cgi,checksub,import,rmtab}
+
+ make DESTDIR="${D}" setup || die "make setup failed"
+}