summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-13 04:41:31 +0000
committerSam James <sam@gentoo.org>2020-09-13 04:41:31 +0000
commitae9855f9d9a1fae1fa77a0fbe1af10881480f90a (patch)
tree2c9ee2e861ebdb18b1b931b29c42ab457ca393ab
parentnet-misc/selfdhcp: port to EAPI 7 (diff)
downloadgentoo-ae9855f9d9a1fae1fa77a0fbe1af10881480f90a.tar.gz
gentoo-ae9855f9d9a1fae1fa77a0fbe1af10881480f90a.tar.bz2
gentoo-ae9855f9d9a1fae1fa77a0fbe1af10881480f90a.zip
net-misc/bsdwhois: bump to EAPI 7
Closes: https://bugs.gentoo.org/742128 Closes: https://bugs.gentoo.org/712872 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/bsdwhois/bsdwhois-1.43.2.1.ebuild10
-rw-r--r--net-misc/bsdwhois/files/bsdwhois-1.43.2.1-musl-cdefs.patch12
2 files changed, 19 insertions, 3 deletions
diff --git a/net-misc/bsdwhois/bsdwhois-1.43.2.1.ebuild b/net-misc/bsdwhois/bsdwhois-1.43.2.1.ebuild
index d528d6c40956..2e825ce486c1 100644
--- a/net-misc/bsdwhois/bsdwhois-1.43.2.1.ebuild
+++ b/net-misc/bsdwhois/bsdwhois-1.43.2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="FreeBSD Whois Client"
HOMEPAGE="https://www.freebsd.org/"
@@ -12,11 +12,15 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
IUSE="userland_BSD"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.43.2.1-musl-cdefs.patch"
+)
+
src_install() {
default
if ! use userland_BSD; then
- mv "${ED}"/usr/share/man/man1/{whois,bsdwhois}.1
- mv "${ED}"/usr/bin/{whois,bsdwhois}
+ mv "${ED}"/usr/share/man/man1/{whois,bsdwhois}.1 || die
+ mv "${ED}"/usr/bin/{whois,bsdwhois} || die
fi
}
diff --git a/net-misc/bsdwhois/files/bsdwhois-1.43.2.1-musl-cdefs.patch b/net-misc/bsdwhois/files/bsdwhois-1.43.2.1-musl-cdefs.patch
new file mode 100644
index 000000000000..2eec53c2645c
--- /dev/null
+++ b/net-misc/bsdwhois/files/bsdwhois-1.43.2.1-musl-cdefs.patch
@@ -0,0 +1,12 @@
+diff --git a/whois.c b/whois.c
+index 329559a..d2f6561 100644
+--- a/whois.c
++++ b/whois.c
+@@ -43,7 +43,6 @@ static char sccsid[] = "@(#)whois.c 8.1 (Berkeley) 6/6/93";
+ #endif /* not lint */
+ #endif
+
+-#include <sys/cdefs.h>
+ #ifdef __FBSDID
+ __FBSDID("$FreeBSD: /repoman/r/ncvs/src/usr.bin/whois/whois.c,v 1.43.2.1 2006/01/31 18:11:21 jhay Exp $");
+ #endif