summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-13 10:51:58 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-13 10:53:13 -0500
commitaef7962e54cf0ba91eeaf7af45eacb739cac314b (patch)
tree1fba126518d065c16d992606cef7ace5872d63b9
parentsys-apps/openrc: remove broken version 0.18 (diff)
downloadgentoo-aef7962e54cf0ba91eeaf7af45eacb739cac314b.tar.gz
gentoo-aef7962e54cf0ba91eeaf7af45eacb739cac314b.tar.bz2
gentoo-aef7962e54cf0ba91eeaf7af45eacb739cac314b.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.20.1
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.2.6.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index ebf38f701dfc..7d29ce792b00 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -4,3 +4,5 @@ DIST puppet-agent_1.2.4-1wheezy_amd64.deb 15187770 SHA256 a711255c7b5aab5f1a653f
DIST puppet-agent_1.2.4-1wheezy_i386.deb 15122670 SHA256 33e9b16ea215089e7a89288faebd4767163e05d7c4a9d5c51ca71b041496c204 SHA512 944f6388d317fab9a2714a6cdc57e713a973d3c1df259b3358be3a0d737878df9f1d66186af8aea0cc768e55650f1dd1d3ef8682b942728fba45e7c0bca20867 WHIRLPOOL bd5710845a9c8f27fb566ead63e45649fb3854200df0259c76b9478d93792b453a9d5cf4fdc20112991d4d091c82143b7504b51be65815b2dcb67796f275303d
DIST puppet-agent_1.2.5-1wheezy_amd64.deb 15187830 SHA256 4d557e45571df033a9e1babf406f9b8a4c387fe6dec7d3645f5e7ad5d7625f0d SHA512 25557aa4d5fa3d2ba0aa226c835d6779d075f0ef7c054cfda9826b1fedd08c90f5143630206b1bd51550f193aecdf4eef6395437f24e5fdfe10d3ed10fb4b75f WHIRLPOOL d6ef920932a708d1a143245f84380384b3a22320c0bb21e60be9807e29af1d3da6dbfef2f498fcb90fe4584618ae338546103c71eb305b743d326e9c20704f1f
DIST puppet-agent_1.2.5-1wheezy_i386.deb 15122650 SHA256 f34a6e9c70b5276806dacf64fb2b41fd927e6875071d044f9901c5a8d9dacd1d SHA512 0989501ca3f011601bb301126ad58084571ee67eb961fbf1f5cf002eb9155bf4f8e838452ac62b45472f00c0a7538cb5c72c3e43c651675a7940d8ab9a1a309c WHIRLPOOL f9698e3154254d9931fdbccd9a75edccae8ab799f8add0e32995453d62a0d070001ad858449c5b816c1b1a448beb8b99b180558feea3b36fc84c0e730e2d5b7e
+DIST puppet-agent_1.2.6-1wheezy_amd64.deb 15187698 SHA256 3448a92d6761bc1c284b17508bf541b0a8c40394b03e7608826e4f2a900e40cc SHA512 b5e6e43f22728cd7d9f4d103aa4de8fa1eccb3159abc31a921fa8f387dd0436a8d0f915b38be8ce233e39448b94f30be90e18da4e2861d6aeda9ef8a312474d2 WHIRLPOOL eca0f32e11b29050e53d93d02a68e874cc5f0f90d823aa7ea5241599872ef39d65f45103542fac84083b40ec47cf09435f27c4fb91b5a5c9a4dee84aa50a2c41
+DIST puppet-agent_1.2.6-1wheezy_i386.deb 15122826 SHA256 271d62f7f6634b49632308d95c75519620335d176d3ee694a3cee42bb445d658 SHA512 3eae7b5a112baf1123c6d942e0b60ee07d76b02a8313a7122884b66f08077fbe430447857e5862182de7cf64ef90f931a49936d6967134937ccff84dd419ae4c WHIRLPOOL bce7ce95c3f6c21ca658d7ba25b3cb7b04c20e5af5499e3f4efb1df997dedd01e0982c67da332fcd8da901f06ce8683219baa6c7e02a7a4eed5ce20547bcfa35
diff --git a/app-admin/puppet-agent/puppet-agent-1.2.6.ebuild b/app-admin/puppet-agent/puppet-agent-1.2.6.ebuild
new file mode 100644
index 000000000000..7de77c52fb14
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.2.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}