summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-23 13:45:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-23 13:54:35 -0500
commitaf069a54aabcd12919d88e69309501618c6f6d16 (patch)
tree3760986887ca2d0ebfe38a7e0f077ed1d439079d
parentsys-libs/libxcrypt-4.4.16: Fix Werror (bug #729132) (diff)
downloadgentoo-af069a54aabcd12919d88e69309501618c6f6d16.tar.gz
gentoo-af069a54aabcd12919d88e69309501618c6f6d16.tar.bz2
gentoo-af069a54aabcd12919d88e69309501618c6f6d16.zip
dev-python/stevedore: 2.0.1 stable allarches
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/stevedore/Manifest2
-rw-r--r--dev-python/stevedore/stevedore-1.32.0.ebuild39
-rw-r--r--dev-python/stevedore/stevedore-2.0.0.ebuild39
-rw-r--r--dev-python/stevedore/stevedore-2.0.1.ebuild2
4 files changed, 1 insertions, 81 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index bfb120da19ea..cad34e96020a 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1,4 +1,2 @@
DIST stevedore-1.31.0.tar.gz 505482 BLAKE2B c69ecf61b32ab996f23aa913a9f226f64164b94e9420da8b7dd5a8ba568a228bd2f536052ab9378167fd2fe2e0d8d7b42515580a966eeffb5beeaf55dbba69ad SHA512 07b641b63766eddd094690acad81c1417a9721d785f81ca11da0ec2afed455d1beedfea5be4dcfd833d9379d650b193e26207ec0411d274bdf399ea2acd321a0
-DIST stevedore-1.32.0.tar.gz 510344 BLAKE2B 96de6598245e88900ba0f0bd69b976425fc5be2c783f32c551ebb2536dc5fde7fab18121947f3f9caa4d7d822372ad502d272285cc66368bfc39c566821a0160 SHA512 98c66b9ac827f69737cc2522029108831380b4bf4c633786d9819b52be930f6116ce5bfab58e724a2efad147830fcb6353409322fc5e01617d35d1c8aafb0259
-DIST stevedore-2.0.0.tar.gz 508206 BLAKE2B c8e8d1044d1af4e2d0366cd836c36783f49a97c54761070d0af3d7c31b7a3bbdc8d98dfadf2425b73b30d7a37b3bb5ca3cde71a6eea76513f9c565aa7c94511d SHA512 10b091749b638330703c256e8614a9519059edcaf109944a0ca04bda5c5fde0d9ab473dc8293cde809867dbd1c2a23cd96d0faaa1f7d802ad68aa0a5aa972a0e
DIST stevedore-2.0.1.tar.gz 505248 BLAKE2B 2fee9467b70aa605ca89060e839a2c00deec571f15f014cb8118710e9221fef65ec15172d727dbafb5d5e2adf15ce0e94919804e2ec7ee72ae9e47afe2a6b88f SHA512 1efe46983975b1a0f176f847874c68dd91538fc3c029facbbf0f96891894176e0eeaf28c19e674baa9e9dae024deabae0555c846e36211a9be6cbba5e2ecd710
diff --git a/dev-python/stevedore/stevedore-1.32.0.ebuild b/dev-python/stevedore/stevedore-1.32.0.ebuild
deleted file mode 100644
index 96df662c46eb..000000000000
--- a/dev-python/stevedore/stevedore-1.32.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx 'doc/source' \
- '>=dev-python/openstackdocstheme-1.18.1' \
- '>=dev-python/reno-2.5.0' \
- '>=dev-python/sphinx-2.0.0'
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/stevedore/stevedore-2.0.0.ebuild b/dev-python/stevedore/stevedore-2.0.0.ebuild
deleted file mode 100644
index 96df662c46eb..000000000000
--- a/dev-python/stevedore/stevedore-2.0.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx 'doc/source' \
- '>=dev-python/openstackdocstheme-1.18.1' \
- '>=dev-python/reno-2.5.0' \
- '>=dev-python/sphinx-2.0.0'
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/stevedore/stevedore-2.0.1.ebuild b/dev-python/stevedore/stevedore-2.0.1.ebuild
index 3b75793f9ca4..6095da755c55 100644
--- a/dev-python/stevedore/stevedore-2.0.1.ebuild
+++ b/dev-python/stevedore/stevedore-2.0.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm64 hppa ~ia64 ~ppc64 sparc x86"
RDEPEND="
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]