summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-25 13:24:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-25 13:35:06 +0100
commitaf2e795c1d47eeb59e2d812ccfe9ecee0b872b82 (patch)
tree4a0f63f799faca67f4a2b1582ff85479d77842f8
parentdev-python/flask: Use distutils_enable_sphinx (diff)
downloadgentoo-af2e795c1d47eeb59e2d812ccfe9ecee0b872b82.tar.gz
gentoo-af2e795c1d47eeb59e2d812ccfe9ecee0b872b82.tar.bz2
gentoo-af2e795c1d47eeb59e2d812ccfe9ecee0b872b82.zip
dev-python/future: Use distutils_enable_sphinx
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/future/future-0.17.1.ebuild23
1 files changed, 2 insertions, 21 deletions
diff --git a/dev-python/future/future-0.17.1.ebuild b/dev-python/future/future-0.17.1.ebuild
index 0aee1d1a9313..a1b80c57871a 100644
--- a/dev-python/future/future-0.17.1.ebuild
+++ b/dev-python/future/future-0.17.1.ebuild
@@ -14,33 +14,21 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
+distutils_enable_sphinx docs \
+ dev-python/sphinx-bootstrap-theme
distutils_enable_tests pytest
# TODO: make numpy unconditional when it supports py3.8
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- $(python_gen_any_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
- ' python{2_7,3_{5,6,7}})
- )
test? (
$(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
python{2_7,3_{5,6,7}})
)
"
-python_check_deps() {
- use doc || return 0
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
- has_version "dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]"
-}
-
python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
# tests requiring network access
rm tests/test_future/test_requests.py || die
sed -i -e 's:test.*request_http:_&:' \
@@ -48,10 +36,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs/ docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}