summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-20 14:06:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-20 14:06:40 +0100
commitaf89fe65d0d94f84e490f4bcb81218541c8f6c6c (patch)
tree107dfada379bf83a641fc83b699beae23defd628
parentapp-text/xchm: Old (diff)
downloadgentoo-af89fe65d0d94f84e490f4bcb81218541c8f6c6c.tar.gz
gentoo-af89fe65d0d94f84e490f4bcb81218541c8f6c6c.tar.bz2
gentoo-af89fe65d0d94f84e490f4bcb81218541c8f6c6c.zip
net-libs/kdav2: Disable tests depending on net access
Closes: https://bugs.gentoo.org/680952 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/kdav2/kdav2-0.2.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-libs/kdav2/kdav2-0.2.0.ebuild b/net-libs/kdav2/kdav2-0.2.0.ebuild
index 1652b2375aeb..73115f33bb10 100644
--- a/net-libs/kdav2/kdav2-0.2.0.ebuild
+++ b/net-libs/kdav2/kdav2-0.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,3 +23,12 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
+src_test() {
+ # disable tests requiring net access, bug #680952
+ local myctestargs=(
+ -E "(kdav2-davcollectionfetchjob|kdav2-davcollectioncreatejob)"
+ )
+
+ kde5_src_test
+}