summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-02 13:32:50 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-02 14:36:48 +0200
commitaff746703b76b57cd29767434d579b3859beebb4 (patch)
tree24de961f81558649a1860db2bf204d179b227067
parentmedia-tv/kodi: Make repoman more happy (diff)
downloadgentoo-aff746703b76b57cd29767434d579b3859beebb4.tar.gz
gentoo-aff746703b76b57cd29767434d579b3859beebb4.tar.bz2
gentoo-aff746703b76b57cd29767434d579b3859beebb4.zip
media-tv/mythtv: Use zeroconf instead of avahi USE flag (#477620)
Package-Manager: portage-2.3.1
-rw-r--r--media-tv/mythtv/mythtv-0.28.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-tv/mythtv/mythtv-0.28.ebuild b/media-tv/mythtv/mythtv-0.28.ebuild
index e87b4cc01933..93a1ca23a323 100644
--- a/media-tv/mythtv/mythtv-0.28.ebuild
+++ b/media-tv/mythtv/mythtv-0.28.ebuild
@@ -24,9 +24,9 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE_INPUT_DEVICES="input_devices_joystick"
-IUSE="alsa altivec avahi libass autostart bluray cec crystalhd debug dvb dvd \
+IUSE="alsa altivec libass autostart bluray cec crystalhd debug dvb dvd \
egl fftw +hls ieee1394 jack lcd lirc +mythlogserver perl pulseaudio python systemd +theora \
-vaapi vdpau +vorbis +wrapper +xml xmltv +xvid ${IUSE_INPUT_DEVICES}"
+vaapi vdpau +vorbis +wrapper +xml xmltv +xvid zeroconf ${IUSE_INPUT_DEVICES}"
REQUIRED_USE="
bluray? ( xml )
@@ -54,10 +54,6 @@ COMMON="
virtual/mysql
virtual/opengl:=
alsa? ( >=media-libs/alsa-lib-1.0.24:= )
- avahi? (
- dev-libs/openssl:0=
- net-dns/avahi[mdnsresponder-compat]
- )
bluray? (
dev-libs/libcdio:=
media-libs/libbluray:=
@@ -114,7 +110,11 @@ COMMON="
media-libs/taglib:=
dev-libs/glib:=
systemd? ( sys-apps/systemd:= )
- "
+ zeroconf? (
+ dev-libs/openssl:0=
+ net-dns/avahi[mdnsresponder-compat]
+ )
+"
RDEPEND="${COMMON}
media-fonts/corefonts
@@ -190,7 +190,7 @@ src_configure() {
myconf="${myconf} --enable-nonfree"
myconf="${myconf} --enable-libmp3lame"
use cec || myconf="${myconf} --disable-libcec"
- use avahi || myconf="${myconf} --disable-libdns-sd"
+ use zeroconf || myconf="${myconf} --disable-libdns-sd"
myconf="${myconf} $(use_enable theora libtheora)"
myconf="${myconf} $(use_enable vorbis libvorbis)"