summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-10-19 04:37:17 +0800
committerYixun Lan <dlan@gentoo.org>2016-10-19 04:39:33 +0800
commitaffdbf49788972d9b7c0b5f3aaa17517fff88642 (patch)
treedf0fe3b208a820780ea63761bfa2a0fb25eaa08b
parentkde-apps: Remove KDE Applications 16.08.1 (diff)
downloadgentoo-affdbf49.tar.gz
gentoo-affdbf49.tar.bz2
gentoo-affdbf49.zip
app-office/lyx: version bump
proxy for maintainer Package-Manager: portage-2.3.2
-rw-r--r--app-office/lyx/Manifest1
-rw-r--r--app-office/lyx/lyx-2.2.2.ebuild193
2 files changed, 194 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index 438576d31d77..f2b89a574f21 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -3,3 +3,4 @@ DIST lyx-2.1.4.tar.xz 10928716 SHA256 d13548cf183f2fc241df8121420933702491a7460c
DIST lyx-2.1.5.tar.xz 10361112 SHA256 2e677591aebdd484efb7d2920357f1358f9525ab1feaa59a63a8cf92b7ee2cf3 SHA512 6f8c62ff96458d0c8c8057ae1e587be4c63bd3bdf2d4f095c24d447017034eda8c6b645efbd258f0956a9bbfe5fde2f90df36515be7b8a94cb63674bc3a58672 WHIRLPOOL 46ee376a7ef9594d22c0c5385e07221dbc5fb3ae1c8e3e754cbc11f53d665d2c9db66a250716fc03384f23ec7133556cca0c500555c471bb7be288c47fc13db5
DIST lyx-2.2.0.tar.xz 14640052 SHA256 d867986870e3f7451f0d4512c60d9c3c7682da59c6c638f18b731f4ad3fa7c80 SHA512 3bc6a3dcd2271d942d1d34cf5f7b7c74d1d58499d070e5b7c056ee03d5195467a4230d18a65e9a591e76655970413370fd6233495c8d3ab977270488082425df WHIRLPOOL 5cd3b13ad8852d4ed5c59a11872547f0bb602119ce2ddbc29c5f7c240b7ca091cf341c0d22ff13c63980057706abf4a35cf5d03625545f598261c98ec4292497
DIST lyx-2.2.1.tar.xz 15522104 SHA256 db6b722f4526d44e09609adcacb6acef38eb7a11c7cde91ffe0d1d54ef94740f SHA512 9403b6e2e957698bed8f95d412d20838c12e192c8525b11fa54d2741a40c598906352c3e9ba728bc7d597c288d0dc6673d65bdea12232135cb9927d00259d435 WHIRLPOOL b33d0846cef5da278c68300c95aa5d36a0d008858d7b5e8b7f303928df5620fe3912baf12f4a1237c96a96d65288c733656ff0dec82e566dddfe0d8549be025a
+DIST lyx-2.2.2.tar.xz 15490148 SHA256 a85c3d7412c4069f8a1f5af4eb172948ae9a50394602f6318ab5c8e990aa5568 SHA512 5057a06f0c37cb2beadb92414eec495ba0619f6c8a9fb5372a9feb90fe0d8bf850de5c94bbf618c8e27bd64404ae6687c48ee24aa6e1bd35580eb3b77d71d45e WHIRLPOOL 0962289b07f767fee7eb7a9b9ae4da99f04a8c3e63f3fe7d4db798bc339772921534e7b1caefc3c0812cc815995d272dee8e365a7c357965acbebd5d6a1930c3
diff --git a/app-office/lyx/lyx-2.2.2.ebuild b/app-office/lyx/lyx-2.2.2.ebuild
new file mode 100644
index 000000000000..3e1e28814183
--- /dev/null
+++ b/app-office/lyx/lyx-2.2.2.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit gnome2-utils eutils fdo-mime flag-o-matic font python-single-r1 toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.2.x/${MY_P}.tar.xz
+ ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.2/${MY_P}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="cups debug nls +latex monolithic-build html rtf dot docbook dia subversion rcs svg gnumeric +hunspell aspell enchant +qt4 qt5"
+
+LANGS="ar ca cs da de el en es eu fi fr gl he hu ia id it ja nb nn pl pt_BR pt_PT ro ru sk sr sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ qt4? ( !qt5 )
+ qt5? ( !qt4 )"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+COMMONDEPEND=">=dev-libs/boost-1.34:=
+ ${PYTHON_DEPS}
+ qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 dev-qt/qtsvg:4 )
+ qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5 dev-qt/qtsvg:5 dev-qt/qtconcurrent:5 )"
+
+RDEPEND="${COMMONDEPEND}
+ dev-texlive/texlive-fontsextra
+ || ( media-gfx/imagemagick[png] media-gfx/graphicsmagick[png] )
+ cups? ( net-print/cups )
+ latex? (
+ app-text/texlive
+ app-text/ghostscript-gpl
+ app-text/noweb
+ app-text/dvipng
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ dev-texlive/texlive-genericextra
+ dev-texlive/texlive-fontsrecommended
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht[java]
+ )
+ )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-vcs/subversion )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( media-gfx/imagemagick[svg] media-gfx/graphicsmagick[svg] )
+ || ( gnome-base/librsvg media-gfx/inkscape )
+ )
+ gnumeric? ( app-office/gnumeric )
+ hunspell? ( app-text/hunspell )
+ aspell? ( app-text/aspell )
+ enchant? ( app-text/enchant )"
+
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.1-python.patch
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+ if use qt4; then
+ export QT_SELECT=qt4
+ elif use qt5; then
+ export QT_SELECT=qt5
+ fi
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+ local qt_flag=""
+ if use qt4; then
+ qt_flag=""
+ elif use qt5; then
+ qt_flag="--enable-qt5"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ $(use_with hunspell) \
+ $(use_with aspell) \
+ $(use_with enchant) \
+ ${qt_flag} \
+ --without-included-boost \
+ --disable-stdlib-debug \
+ --with-packaging=posix
+}
+
+src_install() {
+ default
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ newicon -s 32 "${S}/development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "${S}/lib/images/lyx.png"
+ doicon -s scalable "${S}/lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell ; then
+ dosym /usr/share/myspell /usr/share/lyx/dicts
+ dosym /usr/share/myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+
+ if use latex ; then
+ texhash
+ fi
+}