summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-12 18:53:59 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-12 18:55:02 +0200
commitb0058ad95ebdc811a55214f879c63473bfab9bcb (patch)
treed4f25de89e62d57effee8ded31f3df42f45c2016
parentsys-fs/udisks: Removed old (diff)
downloadgentoo-b0058ad95ebdc811a55214f879c63473bfab9bcb.tar.gz
gentoo-b0058ad95ebdc811a55214f879c63473bfab9bcb.tar.bz2
gentoo-b0058ad95ebdc811a55214f879c63473bfab9bcb.zip
media-plugins/ir_lv2: fixed lv2 compilation issue in 1.3.4
thanks to Samuel Bauer <samuel.bauer@yahoo.fr> for the fix Closes: https://bugs.gentoo.org/728250 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-plugins/ir_lv2/files/ir_lv2-1.3.4-lv2.patch13
-rw-r--r--media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/media-plugins/ir_lv2/files/ir_lv2-1.3.4-lv2.patch b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-lv2.patch
new file mode 100644
index 000000000000..904dab659e73
--- /dev/null
+++ b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-lv2.patch
@@ -0,0 +1,13 @@
+diff --git a/ir_gui.cc b/ir_gui.cc
+index 74ff90a..0f482c6 100644
+--- a/ir_gui.cc
++++ b/ir_gui.cc
+@@ -1523,7 +1523,7 @@ static void cleanup(LV2UI_Handle ui) {
+ free(cp);
+ }
+
+-static LV2UI_Handle instantiate(const struct _LV2UI_Descriptor * descriptor,
++static LV2UI_Handle instantiate(const struct LV2UI_Descriptor * descriptor,
+ const char * plugin_uri,
+ const char * bundle_path,
+ LV2UI_Write_Function write_function,
diff --git a/media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild b/media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild
index 03d78346ab04..232d3932b3de 100644
--- a/media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild
+++ b/media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild
@@ -24,7 +24,8 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-1.3.4-respect-flags.patch
+ "${FILESDIR}"/${P}-respect-flags.patch
+ "${FILESDIR}"/${P}-lv2.patch
)
DOCS=( README.md sshot.png ChangeLog )