summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-11-06 19:14:08 -0500
committerMike Pagano <mpagano@gentoo.org>2022-11-06 19:14:08 -0500
commitb045d231c0a10b9e9a46add0480d6c8fe2f8c77c (patch)
tree5c2fec1fd7d31488297ec2d8f73bae4eccc60e31
parentdev-util/gitchangelog: version bump to latest (diff)
downloadgentoo-b045d231c0a10b9e9a46add0480d6c8fe2f8c77c.tar.gz
gentoo-b045d231c0a10b9e9a46add0480d6c8fe2f8c77c.tar.bz2
gentoo-b045d231c0a10b9e9a46add0480d6c8fe2f8c77c.zip
sys-kernel/git-sources: add 6.1_rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.1_rc4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 79323ef99ca3..10618e1ccdd3 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-6.0.tar.xz 133886176 BLAKE2B c09a9c877ac0fac83dc31d2d04d96f0a3331d4ed
DIST patch-6.1-rc1.patch 50406846 BLAKE2B 357a8a4fab087a67f79efcab4ada2a5d65e77c5ef13a7ab9d58963de31adeb0b3b841b7120acd6bba1767ef2080f086eec2d72ce98a6c21d1920478d6b9fb244 SHA512 80f3fff420e06ea937274ef5ea8927d57f633b0bb1f702ef2b583bd9eddae4c65b0587f57144d1d9eec0aee815d5676d9fc9187779a6149f6c916c432c5a8ea3
DIST patch-6.1-rc2.patch 51039243 BLAKE2B 0f0727885c52a12e5eaf907d40752705a2dc8b174e7ce8f2fd97a1521396db2b32069acc323e732749839e4645dc550be1db16afc942a9513d437160cf509e15 SHA512 753ab27541248489bc3280595b22e138c063defec1ac4f3c7ee60cd9212345e94061ab6206f1cb1c712d76220db0b41b8197ea35e4c72851705046ca986dbb0a
DIST patch-6.1-rc3.patch 51538717 BLAKE2B 3dae85a6363655d534bd1f87eedc9711280484faec8787c89e7a61d54ac56aea7533e9f001a7e8838fe931ba0116d4d9cb0f574ce0c3a53877618dc8fecd47c4 SHA512 2f3f9f53de9d411882f44c740082bcafdb2cc0fe715022225e638b52a53970ddf88c869094bb3afd5ca556da45840fb91aa1e30ca348331ac412ecdee8defedc
+DIST patch-6.1-rc4.patch 51927243 BLAKE2B 168125d2afe15679f55f77bf2509bf38f1c20d5f742430febe0fa53c069b1460b81dca3eb4382ecf47450926bce9f033c1c2370709b93eb4da31ef87900161a0 SHA512 75e2dd8a3a587f9c9027e7d3b007de00e1d142c54405e94f2b36202b47624fbbc89c2a60d9c16f92ef16e317062c2af82356c888b35b1b5007756218dbce69ef
diff --git a/sys-kernel/git-sources/git-sources-6.1_rc4.ebuild b/sys-kernel/git-sources/git-sources-6.1_rc4.ebuild
new file mode 100644
index 000000000000..b91652186526
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.1_rc4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.0"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}