summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-05 08:33:38 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-05 08:33:38 +0200
commitb0bd50d27fdff029ed265435c6a543ce0fc5d699 (patch)
tree8dee474845b45235504f52ee98e106a112bbbab6
parentapp-crypt/certbot-nginx: 0.23.0 stable amd64 and x86 with cleanup (diff)
downloadgentoo-b0bd50d27fdff029ed265435c6a543ce0fc5d699.tar.gz
gentoo-b0bd50d27fdff029ed265435c6a543ce0fc5d699.tar.bz2
gentoo-b0bd50d27fdff029ed265435c6a543ce0fc5d699.zip
net-irc/quassel: Revision bump 0.12.5-r1
Adds an upstream patch which fixes the build with Qt 5.11. Thanks-to: Manuel Nickschas <sputnick@quassel-irc.org> Reported-by: Andreas Sturmlechner <asturm@gentoo.org> Closes: https://bugs.gentoo.org/654024 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--net-irc/quassel/files/quassel-0.12.5-qt511.patch67
-rw-r--r--net-irc/quassel/quassel-0.12.5-r1.ebuild184
2 files changed, 251 insertions, 0 deletions
diff --git a/net-irc/quassel/files/quassel-0.12.5-qt511.patch b/net-irc/quassel/files/quassel-0.12.5-qt511.patch
new file mode 100644
index 00000000000..c46eee8e29b
--- /dev/null
+++ b/net-irc/quassel/files/quassel-0.12.5-qt511.patch
@@ -0,0 +1,67 @@
+commit 0cc8e1431feb739d0727f0131c87a7ecbe336a81
+Author: Manuel Nickschas <sputnick@quassel-irc.org>
+Date: Thu May 3 23:19:34 2018 +0200
+
+ cmake: Fix build with Qt 5.11
+
+ Qt 5.11 removes the qt5_use_modules function, so add a copy. If
+ present, the Qt-provided function will be used instead.
+
+ Closes GH-355.
+
+diff --git a/cmake/QuasselMacros.cmake b/cmake/QuasselMacros.cmake
+index 652c0042..d77ba1cf 100644
+--- a/cmake/QuasselMacros.cmake
++++ b/cmake/QuasselMacros.cmake
+@@ -5,6 +5,9 @@
+ # The qt4_use_modules function was taken from CMake's Qt4Macros.cmake:
+ # (C) 2005-2009 Kitware, Inc.
+ #
++# The qt5_use_modules function was taken from Qt 5.10.1 (and modified):
++# (C) 2005-2011 Kitware, Inc.
++#
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+@@ -43,6 +46,41 @@ function(qt4_use_modules _target _link_type)
+ endforeach()
+ endfunction()
+
++# Qt 5.11 removed the qt5_use_modules function, so we need to provide it until we can switch to a modern CMake version.
++# If present, the Qt-provided version will be used automatically instead.
++function(qt5_use_modules _target _link_type)
++ if (NOT TARGET ${_target})
++ message(FATAL_ERROR "The first argument to qt5_use_modules must be an existing target.")
++ endif()
++ if ("${_link_type}" STREQUAL "LINK_PUBLIC" OR "${_link_type}" STREQUAL "LINK_PRIVATE" )
++ set(_qt5_modules ${ARGN})
++ set(_qt5_link_type ${_link_type})
++ else()
++ set(_qt5_modules ${_link_type} ${ARGN})
++ endif()
++
++ if ("${_qt5_modules}" STREQUAL "")
++ message(FATAL_ERROR "qt5_use_modules requires at least one Qt module to use.")
++ endif()
++ foreach(_module ${_qt5_modules})
++ if (NOT Qt5${_module}_FOUND)
++ find_package(Qt5${_module} PATHS "${_Qt5_COMPONENT_PATH}" NO_DEFAULT_PATH)
++ if (NOT Qt5${_module}_FOUND)
++ message(FATAL_ERROR "Can not use \"${_module}\" module which has not yet been found.")
++ endif()
++ endif()
++ target_link_libraries(${_target} ${_qt5_link_type} ${Qt5${_module}_LIBRARIES})
++ set_property(TARGET ${_target} APPEND PROPERTY INCLUDE_DIRECTORIES ${Qt5${_module}_INCLUDE_DIRS})
++ set_property(TARGET ${_target} APPEND PROPERTY COMPILE_DEFINITIONS ${Qt5${_module}_COMPILE_DEFINITIONS})
++ if (Qt5_POSITION_INDEPENDENT_CODE
++ AND (CMAKE_VERSION VERSION_LESS 2.8.12
++ AND (NOT CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
++ OR CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)))
++ set_property(TARGET ${_target} PROPERTY POSITION_INDEPENDENT_CODE ${Qt5_POSITION_INDEPENDENT_CODE})
++ endif()
++ endforeach()
++endfunction()
++
+ # Some wrappers for simplifying dual-Qt support
+
+ function(qt_use_modules)
diff --git a/net-irc/quassel/quassel-0.12.5-r1.ebuild b/net-irc/quassel/quassel-0.12.5-r1.ebuild
new file mode 100644
index 00000000000..6bb7fb26812
--- /dev/null
+++ b/net-irc/quassel/quassel-0.12.5-r1.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils pax-utils systemd user versionator
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~sparc-solaris"
+else
+ EGIT_REPO_URI=( "https://github.com/${PN}/${PN}" "git://git.${PN}-irc.org/${PN}" )
+ inherit git-r3
+fi
+
+DESCRIPTION="Qt/KDE IRC client supporting a remote daemon for 24/7 connectivity"
+HOMEPAGE="http://quassel-irc.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="crypt dbus debug kde monolithic phonon postgres +server
+snorenotify +ssl syslog webkit X"
+
+SERVER_RDEPEND="
+ dev-qt/qtscript:5
+ crypt? ( app-crypt/qca:2[qt5(+),ssl] )
+ postgres? ( dev-qt/qtsql:5[postgres] )
+ !postgres? ( dev-qt/qtsql:5[sqlite] dev-db/sqlite:3[threadsafe(+),-secure-delete] )
+ syslog? ( virtual/logger )
+"
+
+GUI_RDEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dbus? (
+ >=dev-libs/libdbusmenu-qt-0.9.3_pre20140619[qt5(+)]
+ dev-qt/qtdbus:5
+ )
+ kde? (
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/knotifications:5
+ kde-frameworks/knotifyconfig:5
+ kde-frameworks/ktextwidgets:5
+ kde-frameworks/kwidgetsaddons:5
+ kde-frameworks/kxmlgui:5
+ kde-frameworks/sonnet:5
+ )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ snorenotify? ( >=x11-libs/snorenotify-0.7.0 )
+ webkit? ( dev-qt/qtwebkit:5 )
+"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl?]
+ sys-libs/zlib
+ monolithic? (
+ ${SERVER_RDEPEND}
+ ${GUI_RDEPEND}
+ )
+ !monolithic? (
+ server? ( ${SERVER_RDEPEND} )
+ X? ( ${GUI_RDEPEND} )
+ )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+"
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+REQUIRED_USE="
+ || ( X server monolithic )
+ crypt? ( || ( server monolithic ) )
+ dbus? ( || ( X monolithic ) )
+ kde? ( || ( X monolithic ) dbus phonon )
+ phonon? ( || ( X monolithic ) )
+ postgres? ( || ( server monolithic ) )
+ snorenotify? ( || ( X monolithic ) )
+ syslog? ( || ( server monolithic ) )
+ webkit? ( || ( X monolithic ) )
+"
+
+PATCHES=( "${FILESDIR}/${P}-qt511.patch" )
+
+pkg_setup() {
+ if use server; then
+ QUASSEL_DIR=/var/lib/${PN}
+ QUASSEL_USER=${PN}
+ # create quassel:quassel user
+ enewgroup "${QUASSEL_USER}"
+ enewuser "${QUASSEL_USER}" -1 -1 "${QUASSEL_DIR}" "${QUASSEL_USER}"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ -DEMBED_DATA=OFF
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use_find_package crypt QCA2-QT5)
+ $(cmake-utils_use_find_package dbus dbusmenu-qt5)
+ $(cmake-utils_use_find_package dbus Qt5DBus)
+ -DWITH_KDE=$(usex kde)
+ -DWITH_OXYGEN=$(usex !kde)
+ -DWANT_MONO=$(usex monolithic)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ -DWANT_CORE=$(usex server)
+ $(cmake-utils_use_find_package snorenotify LibsnoreQt5)
+ -DWITH_WEBKIT=$(usex webkit)
+ -DWANT_QTCLIENT=$(usex X)
+ )
+
+ # Something broke upstream detection since Qt 5.5
+ if use ssl ; then
+ mycmakeargs+=( "-DHAVE_SSL=TRUE" )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ # needs PAX marking wrt bug#346255
+ pax-mark m "${ED}/usr/bin/quasselcore"
+
+ # prepare folders in /var/
+ keepdir "${QUASSEL_DIR}"
+ fowners "${QUASSEL_USER}":"${QUASSEL_USER}" "${QUASSEL_DIR}"
+
+ # init scripts & systemd unit
+ newinitd "${FILESDIR}"/quasselcore.init-r1 quasselcore
+ newconfd "${FILESDIR}"/quasselcore.conf-r1 quasselcore
+ systemd_dounit "${FILESDIR}"/quasselcore.service
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/quassel.logrotate" quassel
+ fi
+}
+
+pkg_postinst() {
+ if use monolithic && use ssl ; then
+ elog "Information on how to enable SSL support for client/core connections"
+ elog "is available at http://bugs.quassel-irc.org/projects/quassel-irc/wiki/Client-Core_SSL_support."
+ fi
+
+ if use server; then
+ einfo "If you want to generate SSL certificate remember to run:"
+ einfo " emerge --config =${CATEGORY}/${PF}"
+ fi
+
+ if use server || use monolithic ; then
+ einfo "Quassel can use net-misc/oidentd package if installed on your system."
+ einfo "Consider installing it if you want to run quassel within identd daemon."
+ fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+
+pkg_config() {
+ if use server && use ssl; then
+ # generate the pem file only when it does not already exist
+ if [ ! -f "${QUASSEL_DIR}/quasselCert.pem" ]; then
+ einfo "Generating QUASSEL SSL certificate to: \"${QUASSEL_DIR}/quasselCert.pem\""
+ openssl req -x509 -nodes -days 365 -newkey rsa:2048 \
+ -keyout "${QUASSEL_DIR}/quasselCert.pem" \
+ -out "${QUASSEL_DIR}/quasselCert.pem"
+ # permissions for the key
+ chown ${QUASSEL_USER}:${QUASSEL_USER} "${QUASSEL_DIR}/quasselCert.pem"
+ chmod 400 "${QUASSEL_DIR}/quasselCert.pem"
+ else
+ einfo "Certificate \"${QUASSEL_DIR}/quasselCert.pem\" already exists."
+ einfo "Remove it if you want to create new one."
+ fi
+ fi
+}