summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-08-10 22:25:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2018-08-10 22:26:12 +1000
commitb0e7307062170804b2e1d53d8a9fd40ad08cb490 (patch)
tree4c63c8cf2795cf8570307e9d30e0b5805d6996fa
parentmedia-libs/libdmtx: add github remote-id (diff)
downloadgentoo-b0e73070.tar.gz
gentoo-b0e73070.tar.bz2
gentoo-b0e73070.zip
media-libs/libdmtx: version bump 0.7.5
Closes: https://bugs.gentoo.org/662860 Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--media-libs/libdmtx/Manifest1
-rw-r--r--media-libs/libdmtx/libdmtx-0.7.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/libdmtx/Manifest b/media-libs/libdmtx/Manifest
index 2dd77a6ee5a4..567d3655705d 100644
--- a/media-libs/libdmtx/Manifest
+++ b/media-libs/libdmtx/Manifest
@@ -1 +1,2 @@
DIST libdmtx-0.7.4.tar.gz 370999 BLAKE2B 7c87d1b1ca8a1466aed6dbd8b60b31c1acacbff46d99855a2366c89a0998acbc8e0b3d3e70612d6bfc736b48e2001d8de14b9169920e802490623009f3395ea9 SHA512 307aeb30506e60fc44550d1bb86081634f0718d53e7b878b45b0e704e75c5996e27285a16881b7c3a93cafa9a9b125175dadc0f0c2c2f976878666eb652108ae
+DIST libdmtx-0.7.5.tar.gz 790944 BLAKE2B af94a998e6ab0b06c17d64d6c720e874540830282fd1219260aa1e5fb44159b59f63fcfd1fbd750333ae50b080c341ec02b81216c2e975a8ef85628b23d4fb55 SHA512 c4bccc9eff4a93b6bb417ed23ed46e82cc98b650a94be40479d192af8537ee02a16700fbbd8f2271035ff8b804c40ab6461825d94bd80a3081d3a4b3988ea22a
diff --git a/media-libs/libdmtx/libdmtx-0.7.5.ebuild b/media-libs/libdmtx/libdmtx-0.7.5.ebuild
new file mode 100644
index 000000000000..1210c5c02638
--- /dev/null
+++ b/media-libs/libdmtx/libdmtx-0.7.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Barcode data matrix reading and writing library"
+HOMEPAGE="http://libdmtx.sourceforge.net/"
+SRC_URI="https://github.com/dmtx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} + || die
+}