summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-03-06 21:41:34 +0100
committerSam James <sam@gentoo.org>2022-03-15 19:47:33 +0000
commitb11c0db3e5c71771b390c582e26ddfcd2f4262cd (patch)
treef31c61eebb03ceaf805492a7f0ce3e8e97cee2c8
parentdev-ruby/timecop: Stabilize 0.9.4 x86, #835167 (diff)
downloadgentoo-b11c0db3e5c71771b390c582e26ddfcd2f4262cd.tar.gz
gentoo-b11c0db3e5c71771b390c582e26ddfcd2f4262cd.tar.bz2
gentoo-b11c0db3e5c71771b390c582e26ddfcd2f4262cd.zip
media-plugins/gst-plugins-libav: Fix ffmpeg-5 compatibility with 1.18.4
Closes: https://bugs.gentoo.org/831604 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/24426 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-plugins/gst-plugins-libav/Manifest1
-rw-r--r--media-plugins/gst-plugins-libav/gst-plugins-libav-1.18.4-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-libav/Manifest b/media-plugins/gst-plugins-libav/Manifest
index b9e661fe2e54..4bd7ffb7bbc1 100644
--- a/media-plugins/gst-plugins-libav/Manifest
+++ b/media-plugins/gst-plugins-libav/Manifest
@@ -1,3 +1,4 @@
DIST gst-libav-1.16.3.tar.xz 9472760 BLAKE2B 3e98381244d74aa695c737a898711b311518749c6f949af7bd03d08cdf383cbe1a78cea8e3f0268fdb2132bec930803f8fa31e919c6c268b6f8d58092f01fd04 SHA512 37fe621a8d45ac6bf51383a776f3091cc114faaf84b0097e86f33eb4e8c0b70b4cc6fa467aad63daca9b1b24db24c10a067c973ef8232c2965eedeba3d251b0b
DIST gst-libav-1.18.4.tar.xz 281576 BLAKE2B 5ce7b15163a0671744ca6920865b2e3be35ac9209f8b3b0e73202684fe4da2e16abdee2be2d3844170cd688b58b3eadf89b3f3b87b457dc939ae409fe42bc410 SHA512 4eb10af6698f724bbc8d5b7b215e7349e6ff3b52e24b3987ee4077db1ae27ae0d6f25309adc50f0fccdf5af4d617634a7339ad1e5466a737c40a25c52c0d023f
DIST gst-libav-1.20.0.tar.xz 277816 BLAKE2B 7e18e73ceeb67668ff8e327639fca235a261057061017e97064423c2dfe913690f44c935ff6e68d5c754f009cb9ffe76b2a4276c2b139943be71db6f93271999 SHA512 51cedfc3489915507d7640220aafe4f71ef3bbe5e7de9aa18187f211275a29917a893ee0375a89f256bda6c63e5103e1c4614f3e236ffe46e550ce518c9e7109
+DIST gst-plugins-libav-1.18.4_ffmpeg-5.patch.bz2 2454 BLAKE2B 7fd89996181f178b6597f3d445fb7b39b41e72173706b52e1b6aad28d35b54268a8aaeadcafebb002ed8264435cbfb7a0252713fc3f566dc002fdde71d6d6e70 SHA512 8da49c16fa2b4567016a16205b3be5830af2420ad8dfff0811f61237903751119be2a73a0953acdc0682c0c81de197af9196ba2abfc9f46bd2652b41f358db56
diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.18.4-r1.ebuild b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.18.4-r1.ebuild
new file mode 100644
index 000000000000..c07c905066d9
--- /dev/null
+++ b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.18.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gstreamer-meson
+
+MY_PN="gst-libav"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.xz"
+SRC_URI+=" https://cmpct.info/~sam/gentoo/distfiles/${CATEGORY}/${PN}/${P}_ffmpeg-5.patch.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${MY_PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${MY_PV}:1.0[${MULTILIB_USEDEP}]
+ >=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/gst-plugins-libav-1.18.4_ffmpeg-4.4.patch"
+ "${WORKDIR}/${P}_ffmpeg-5.patch"
+)