summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 11:44:49 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 11:47:55 +0100
commitb1f960073ca686cb5bdf51bdf470f9f6a1960840 (patch)
treeff88ec03e1cacaff129a51b2901760eb0dd962e2
parentwww-client/chromium: x86 stable wrt bug #568396 (diff)
downloadgentoo-b1f960073ca686cb5bdf51bdf470f9f6a1960840.tar.gz
gentoo-b1f960073ca686cb5bdf51bdf470f9f6a1960840.tar.bz2
gentoo-b1f960073ca686cb5bdf51bdf470f9f6a1960840.zip
dev-python/pysvn: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568392 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pysvn/Manifest1
-rw-r--r--dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch99
-rw-r--r--dev-python/pysvn/pysvn-1.8.0.ebuild60
3 files changed, 160 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index 7af541054db7..5db2a53ad52a 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1,2 +1,3 @@
DIST pysvn-1.7.10.tar.gz 352631 SHA256 cb8a7eca9fd5d077f4b086c79cc1115a2f38a37979eee836ff258b4da0aee517 SHA512 3404ce53f974ff91a7eecea29176f6b71f1dbb37a716880dfd3d2961d4c6e0c81f87aa46308994d4f7ed6a6cbca7f7451753e1de43ce95fef4443fc5f70ff3aa WHIRLPOOL 99ac425ad2e19355521c73947cf33b2c5bff0023af686d699fdfcd7abc8c5f965974c9762b0dbd3ae3cddfc833e35ac549af1de54ca2472d1354a8fa126e8c36
DIST pysvn-1.7.9.tar.gz 352320 SHA256 8a58ea6405e5f5ffd0850fc5ed6bc29a93b3573da099293f49ef3241e5be1692 SHA512 966f9b57f63abc68d82a0f0f0d710d3109c2bd515eb0b0dacdca140b0db32154c802d27b4f79062da19f0d18ff6332b729c6f9c06e0a74742161a00b74bef7aa WHIRLPOOL 53f27a30ce97b723fe0d1a8540221e25e593fc00789eab7b6e2814f3ffe3ff8f485523ad7fe3bff7c1b5d101fb87d694a1c18111d2523895835ea72ea1ee6aab
+DIST pysvn-1.8.0.tar.gz 366583 SHA256 39596f4884ed689cdb5a4e210e421724302a566c7ba756cc4d46bbfeb0c8326b SHA512 14a70b910be986eba638a903edde5046c93314fedb08a7c15d464dc51da1c7efeb87147cc68c00ff9ac1b4ca506d099d3aedf7e4d86f92642c7304ef9540653b WHIRLPOOL 90a795f4d6a1c353321a116f5676741ce2121122de0426d045893e2688cc10bcd248ffef98da6d920daba70e2406ce136fed972e8172b7e648c6dd02f04e608d
diff --git a/dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch
new file mode 100644
index 000000000000..9b4c3a075e8f
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.8.0-respect_flags.patch
@@ -0,0 +1,99 @@
+ Source/setup_configure.py | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/Source/setup_configure.py b/Source/setup_configure.py
+index afeee2d..47f2717 100644
+--- a/Source/setup_configure.py
++++ b/Source/setup_configure.py
+@@ -849,8 +849,8 @@ class CompilerGCC(Compiler):
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -976,8 +976,8 @@ class MacOsxCompilerGCC(CompilerGCC):
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
+- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
++ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
++ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % pycxx_version,
+@@ -1032,11 +1032,11 @@ class MacOsxCompilerGCC(CompilerGCC):
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1048,7 +1048,7 @@ class MacOsxCompilerGCC(CompilerGCC):
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
++ '$(CXXFLAGS) ',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1074,13 +1074,12 @@ class MacOsxCompilerGCC(CompilerGCC):
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+- '-framework Security '
+- '%(LDLIBS)s' )
++ '-framework Security' )
+
+ class UnixCompilerGCC(CompilerGCC):
+ def __init__( self, setup ):
+@@ -1140,11 +1139,11 @@ class UnixCompilerGCC(CompilerGCC):
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1155,6 +1154,7 @@ class UnixCompilerGCC(CompilerGCC):
+ self._addVar( 'PYTHON_ARCH_SPECIFIC_INC', distutils.sysconfig.get_python_inc( True ) )
+
+ py_cflags_list = [
++ '$(CXXFLAGS)',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1176,7 +1176,7 @@ class UnixCompilerGCC(CompilerGCC):
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/pysvn-1.8.0.ebuild b/dev-python/pysvn/pysvn-1.8.0.ebuild
new file mode 100644
index 000000000000..2f797d4cb6c9
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.8.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-6.2.6[${PYTHON_USEDEP}]
+ dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-respect_flags.patch )
+
+DISTUTILS_IN_SOURCE_BUILD=true
+
+python_prepare_all() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ cd Source || die
+ # all config options from 1.7.6 are all already set
+ esetup.py configure
+}
+
+python_compile() {
+ cd Source || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/. )
+ use examples && local EXAMPLES=( Examples/Client/. )
+ distutils-r1_python_install_all
+}