summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaymond Jennings <shentino@gmail.com>2017-10-11 23:50:58 -0700
committerPatrice Clement <monsieurp@gentoo.org>2017-10-15 23:11:03 +0200
commitb268b306966b45a54da8a5573e09915e0ca92a96 (patch)
tree49d7663e1d1ba7dd98e4625cf56bc40136237ce6
parentwww-apps/kibana-bin: drop old. (diff)
downloadgentoo-b268b306966b45a54da8a5573e09915e0ca92a96.tar.gz
gentoo-b268b306966b45a54da8a5573e09915e0ca92a96.tar.bz2
gentoo-b268b306966b45a54da8a5573e09915e0ca92a96.zip
net-misc/bopm: fix security bug with pid file.
In theory, someone who explots a hacked bopm could then use it to attack root owned processes. This puts the bopm-written PID file into a disposable junk directory and lets start-stop-daemon do all the grunt work. Bug: https://bugs.gentoo.org/631882 Closes: https://github.com/gentoo/gentoo/pull/5924
-rw-r--r--net-misc/bopm/bopm-3.1.3-r4.ebuild (renamed from net-misc/bopm/bopm-3.1.3-r3.ebuild)3
-rw-r--r--net-misc/bopm/files/bopm-3.1.3-quarantine-bad-pid-file.patch16
-rw-r--r--net-misc/bopm/files/bopm.init.d-r2 (renamed from net-misc/bopm/files/bopm.init.d-r1)4
3 files changed, 21 insertions, 2 deletions
diff --git a/net-misc/bopm/bopm-3.1.3-r3.ebuild b/net-misc/bopm/bopm-3.1.3-r4.ebuild
index 5e306a502712..5c2096926f29 100644
--- a/net-misc/bopm/bopm-3.1.3-r3.ebuild
+++ b/net-misc/bopm/bopm-3.1.3-r4.ebuild
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-remove-njabl.patch
"${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-quarantine-bad-pid-file.patch
)
pkg_setup() {
@@ -52,7 +53,7 @@ src_install() {
# If anybody wants libopm, please install net-libs/libopm
rm -r "${ED}"usr/$(get_libdir) "${ED}"usr/include || die
- newinitd "${FILESDIR}"/bopm.init.d-r1 ${PN}
+ newinitd "${FILESDIR}"/bopm.init.d-r2 ${PN}
newconfd "${FILESDIR}"/bopm.conf.d-r1 ${PN}
dodir /var/log/bopm
diff --git a/net-misc/bopm/files/bopm-3.1.3-quarantine-bad-pid-file.patch b/net-misc/bopm/files/bopm-3.1.3-quarantine-bad-pid-file.patch
new file mode 100644
index 000000000000..fedcd0980a04
--- /dev/null
+++ b/net-misc/bopm/files/bopm-3.1.3-quarantine-bad-pid-file.patch
@@ -0,0 +1,16 @@
+Bopm writes its own pid file, but this is handled by the init script via
+openrc-run.
+---
+diff --git a/bopm.conf.sample b/bopm.conf.sample
+index e26dc17..fa5ce1d 100644
+--- a/bopm.conf.sample
++++ b/bopm.conf.sample
+@@ -9,7 +9,7 @@ options {
+ * Full path and filename for storing the process ID of the running
+ * BOPM.
+ */
+- pidfile = "/run/bopm/bopm.pid";
++ pidfile = "/run/bopm/junk/bopm.pid";
+
+ /*
+ * How many seconds to store the IP address of hosts which are
diff --git a/net-misc/bopm/files/bopm.init.d-r1 b/net-misc/bopm/files/bopm.init.d-r2
index 6a292f800be2..de6d959b9f74 100644
--- a/net-misc/bopm/files/bopm.init.d-r1
+++ b/net-misc/bopm/files/bopm.init.d-r2
@@ -12,5 +12,7 @@ depend() {
}
start_pre() {
- checkpath -o ${BOPM_UID} -d "$(dirname "${PIDFILE}")"
+ checkpath -o 0:0 -d /run/bopm
+ checkpath -o ${BOPM_UID} -d /run/bopm/junk
+ checkpath -o ${BOPM_UID} -f /run/bopm/junk/bopm.pid
}