summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-08-24 11:01:01 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-08-24 11:01:01 -0400
commitb2e206ae1296ba85a0f5dc624903e182af65bf3a (patch)
treeb640d827a7709ebf2b64b2b3ad2f897417198404
parentprofiles: mask USE=command-args for net-analyzer/nrpe. (diff)
downloadgentoo-b2e206ae1296ba85a0f5dc624903e182af65bf3a.tar.gz
gentoo-b2e206ae1296ba85a0f5dc624903e182af65bf3a.tar.bz2
gentoo-b2e206ae1296ba85a0f5dc624903e182af65bf3a.zip
net-analyzer/nrpe: new revision adding the command-args flag back.
After some discussion on the mailing list, I've decided to add back the "command-args" USE flag, but to mask it in package.use.mask. Gentoo-Bug: 628596 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--net-analyzer/nrpe/nrpe-3.2.0-r2.ebuild (renamed from net-analyzer/nrpe/nrpe-3.2.0-r1.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-analyzer/nrpe/nrpe-3.2.0-r1.ebuild b/net-analyzer/nrpe/nrpe-3.2.0-r2.ebuild
index 08d233c3de60..ca614e36b646 100644
--- a/net-analyzer/nrpe/nrpe-3.2.0-r1.ebuild
+++ b/net-analyzer/nrpe/nrpe-3.2.0-r2.ebuild
@@ -11,7 +11,7 @@ SRC_URI="${HOMEPAGE}/releases/download/${P}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="selinux ssl"
+IUSE="command-args selinux ssl"
DEPEND="sys-apps/tcp-wrappers
ssl? ( dev-libs/openssl:0 )"
@@ -32,6 +32,7 @@ src_configure() {
--with-nrpe-user=nagios \
--with-nrpe-group=nagios \
--with-piddir=/run \
+ $(use_enable command-args) \
$(use_enable ssl)
}
@@ -61,4 +62,12 @@ pkg_postinst(){
elog 'Some users have reported incompatibilities between nrpe-2.x and'
elog 'nrpe-3.x. We recommend that you use the same major version for'
elog 'both your server and clients.'
+
+ if use command-args ; then
+ ewarn ''
+ ewarn 'You have enabled command-args for NRPE. That lets clients'
+ ewarn 'supply arguments to the commands that are run, and IS A'
+ ewarn 'SECURITY RISK!'
+ ewarn''
+ fi
}